3.11.0-11 - Add valgrind-3.11.0-no-stv.patch (GCC6 workaround).

This commit is contained in:
Mark Wielaard 2016-01-31 00:16:44 +01:00
parent bef89a922b
commit 0ddacd6627
2 changed files with 30 additions and 1 deletions

View File

@ -0,0 +1,22 @@
--- valgrind-3.11.0.orig/configure 2015-11-15 18:08:05.399929722 +0100
+++ valgrind-3.11.0/configure 2016-01-30 19:33:09.616564942 +0100
@@ -8630,7 +8630,7 @@
_ACEOF
if ac_fn_c_try_compile "$LINENO"; then :
-PREFERRED_STACK_BOUNDARY_2="-mpreferred-stack-boundary=2"
+PREFERRED_STACK_BOUNDARY_2="-mpreferred-stack-boundary=2 -mno-stv"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
--- valgrind-3.11.0.orig/configure.ac 2015-11-15 18:08:05.497930840 +0100
+++ valgrind-3.11.0/configure.ac 2016-01-30 19:32:54.833417794 +0100
@@ -1836,7 +1836,7 @@
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
return 0;
]])], [
-PREFERRED_STACK_BOUNDARY_2="-mpreferred-stack-boundary=2"
+PREFERRED_STACK_BOUNDARY_2="-mpreferred-stack-boundary=2 -mno-stv"
AC_MSG_RESULT([yes])
], [
PREFERRED_STACK_BOUNDARY_2=""

View File

@ -3,7 +3,7 @@
Summary: Tool for finding memory management bugs in programs
Name: %{?scl_prefix}valgrind
Version: 3.11.0
Release: 10%{?dist}
Release: 11%{?dist}
Epoch: 1
License: GPLv2+
URL: http://www.valgrind.org/
@ -101,6 +101,9 @@ Patch17: valgrind-3.11.0-x86_unwind.patch
# KDE#358478 drd/tests/std_thread.cpp doesn't build with GCC6
Patch18: valgrind-3.11.0-drd_std_thread.patch
# GCC#69454 Workaround for ix86_expand_prologue internal compiler error
Patch19: valgrind-3.11.0-no-stv.patch
%if %{build_multilib}
# Ensure glibc{,-devel} is installed for both multilib arches
BuildRequires: /lib/libc.so.6 /usr/lib/libc.so /lib64/libc.so.6 /usr/lib64/libc.so
@ -223,6 +226,7 @@ Valgrind User Manual for details.
%patch16 -p1
%patch17 -p1
%patch18 -p1
%patch19 -p1
%build
# We need to use the software collection compiler and binutils if available.
@ -415,6 +419,9 @@ echo ===============END TESTING===============
%endif
%changelog
* Sat Jan 30 2016 Mark Wielaard <mjw@redhat.com> - 3.11.0-11
- Add valgrind-3.11.0-no-stv.patch (GCC6 workaround).
* Mon Jan 25 2016 Mark Wielaard <mjw@redhat.com> - 3.11.0-10
- Add valgrind-3.11.0-drd_std_thread.patch GCC6 build fix.