3.16.1-1 - Update to upstream valgrind 3.16.1.

This commit is contained in:
Mark Wielaard 2020-06-23 13:09:53 +02:00
parent a5301888c2
commit 0bfb6d5ba4
4 changed files with 7 additions and 37 deletions

1
.gitignore vendored
View File

@ -37,3 +37,4 @@
/valgrind-3.16.0.GIT.tar.bz2
/valgrind-3.16.0.RC2.tar.bz2
/valgrind-3.16.0.tar.bz2
/valgrind-3.16.1.tar.bz2

View File

@ -1 +1 @@
SHA512 (valgrind-3.16.0.tar.bz2) = 6c82a0121e0ffde79f84943ea0f5791159ad3e37a490c1a18ff23f41cd4de62b62110e9c4d48b95b06d542f2a6d638492ecaeba9fed48f7e909e959aa4b4856d
SHA512 (valgrind-3.16.1.tar.bz2) = 2a4173efe1b6facdd2f5c5ee8ed006704168eba1813736fccc8191d60363afd96197512cf42037e65f18d4ddd49adc74a54c47210df216fba3c46bf68ef0f950

View File

@ -1,29 +0,0 @@
commit fb6f7abcbc92506d302fb18a2c5fc853d2929248
Author: Carl Love <cel@us.ibm.com>
Date: Tue Jun 9 10:42:03 2020 -0500
Power PC Fix extraction of the L field for sync instruction
The L field is currently a two bit[22:21] field in ISA 3.0. The size of the
L field has changed over time.
Currently the ISA 3.0 Valgrind sync instruction support code sets the
flag_L for the instruction L field to a five bit value that includes bits
that are marked reserved the sync instruction. This patch fixes the issue for ISA 3.0
to only setting flag_L the specified two bits.
Valgrind bugzilla: https://bugs.kde.org/show_bug.cgi?id=422677
diff --git a/VEX/priv/guest_ppc_toIR.c b/VEX/priv/guest_ppc_toIR.c
index 582c59ec0..c4965a19e 100644
--- a/VEX/priv/guest_ppc_toIR.c
+++ b/VEX/priv/guest_ppc_toIR.c
@@ -8777,7 +8777,7 @@ static Bool dis_memsync ( UInt theInstr )
/* X-Form, XL-Form */
UChar opc1 = ifieldOPC(theInstr);
UInt b11to25 = IFIELD(theInstr, 11, 15);
- UChar flag_L = ifieldRegDS(theInstr);
+ UChar flag_L = IFIELD(theInstr, 21, 2); //ISA 3.0
UInt b11to20 = IFIELD(theInstr, 11, 10);
UInt M0 = IFIELD(theInstr, 11, 5);
UChar rD_addr = ifieldRegDS(theInstr);

View File

@ -2,8 +2,8 @@
Summary: Tool for finding memory management bugs in programs
Name: %{?scl_prefix}valgrind
Version: 3.16.0
Release: 3%{?dist}
Version: 3.16.1
Release: 1%{?dist}
Epoch: 1
License: GPLv2+
URL: http://www.valgrind.org/
@ -93,9 +93,6 @@ Patch5: valgrind-3.16.0-some-stack-protector.patch
# Add some -Wl,z,now.
Patch6: valgrind-3.16.0-some-Wl-z-now.patch
# KDE#422677 PPC sync instruction L field should only be 2 bits in ISA 3.0
Patch7: valgrind-3.16.0-ppc-L-field.patch
BuildRequires: glibc-devel
%if %{build_openmpi}
@ -227,8 +224,6 @@ Valgrind User Manual for details.
%patch6 -p1
%endif
%patch7 -p1
%build
# Some patches (might) touch Makefile.am or configure.ac files.
@ -448,6 +443,9 @@ fi
%endif
%changelog
* Tue Jun 23 2020 Mark Wielaard <mjw@fedoraproject.org> - 3.16.1-1
- Update to upstream valgrind 3.16.1.
* Fri Jun 19 2020 Mark Wielaard <mjw@fedoraproject.org> - 3.16.0-3
- Add valgrind-3.16.0-ppc-L-field.patch