Update to 0.38.1
This commit is contained in:
parent
f86cfe5f55
commit
49fca2d524
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@
|
|||||||
/vala-0.37.90.tar.xz
|
/vala-0.37.90.tar.xz
|
||||||
/vala-0.37.91.tar.xz
|
/vala-0.37.91.tar.xz
|
||||||
/vala-0.38.0.tar.xz
|
/vala-0.38.0.tar.xz
|
||||||
|
/vala-0.38.1.tar.xz
|
||||||
|
@ -1,68 +0,0 @@
|
|||||||
From 8bd7fbc9e39ca6396ee323bef420dadeeac54a7d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rico Tzschichholz <ricotz@ubuntu.com>
|
|
||||||
Date: Fri, 8 Sep 2017 14:31:41 +0200
|
|
||||||
Subject: [PATCH] codegen: Try to use a more unique internal define for
|
|
||||||
properties
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=787436
|
|
||||||
---
|
|
||||||
codegen/valagobjectmodule.vala | 8 ++++----
|
|
||||||
codegen/valagtypemodule.vala | 2 +-
|
|
||||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/codegen/valagobjectmodule.vala b/codegen/valagobjectmodule.vala
|
|
||||||
index 33bb87805..8b3e7a269 100644
|
|
||||||
--- a/codegen/valagobjectmodule.vala
|
|
||||||
+++ b/codegen/valagobjectmodule.vala
|
|
||||||
@@ -144,7 +144,7 @@ public class Vala.GObjectModule : GTypeModule {
|
|
||||||
|
|
||||||
var cinst = new CCodeFunctionCall (new CCodeIdentifier ("g_object_class_install_property"));
|
|
||||||
cinst.add_argument (ccall);
|
|
||||||
- cinst.add_argument (new CCodeConstant (get_ccode_upper_case_name (prop)));
|
|
||||||
+ cinst.add_argument (new CCodeConstant ("%s_PROPERTY".printf (get_ccode_upper_case_name (prop))));
|
|
||||||
cinst.add_argument (get_param_spec (prop));
|
|
||||||
|
|
||||||
ccode.add_expression (cinst);
|
|
||||||
@@ -228,7 +228,7 @@ public class Vala.GObjectModule : GTypeModule {
|
|
||||||
cfunc = new CCodeIdentifier (get_ccode_real_name (prop.get_accessor));
|
|
||||||
}
|
|
||||||
|
|
||||||
- ccode.add_case (new CCodeIdentifier (get_ccode_upper_case_name (prop)));
|
|
||||||
+ ccode.add_case (new CCodeIdentifier ("%s_PROPERTY".printf (get_ccode_upper_case_name (prop))));
|
|
||||||
if (prop.property_type.is_real_struct_type ()) {
|
|
||||||
var st = prop.property_type.data_type as Struct;
|
|
||||||
|
|
||||||
@@ -335,7 +335,7 @@ public class Vala.GObjectModule : GTypeModule {
|
|
||||||
cfunc = new CCodeIdentifier (get_ccode_real_name (prop.set_accessor));
|
|
||||||
}
|
|
||||||
|
|
||||||
- ccode.add_case (new CCodeIdentifier (get_ccode_upper_case_name (prop)));
|
|
||||||
+ ccode.add_case (new CCodeIdentifier ("%s_PROPERTY".printf (get_ccode_upper_case_name (prop))));
|
|
||||||
ccall = new CCodeFunctionCall (cfunc);
|
|
||||||
ccall.add_argument (cself);
|
|
||||||
if (prop.property_type is ArrayType && ((ArrayType)prop.property_type).element_type.data_type == string_type.data_type) {
|
|
||||||
@@ -684,7 +684,7 @@ public class Vala.GObjectModule : GTypeModule {
|
|
||||||
base.visit_property (prop);
|
|
||||||
|
|
||||||
if (is_gobject_property (prop) && prop.parent_symbol is Class) {
|
|
||||||
- prop_enum.add_value (new CCodeEnumValue (get_ccode_upper_case_name (prop)));
|
|
||||||
+ prop_enum.add_value (new CCodeEnumValue ("%s_PROPERTY".printf (get_ccode_upper_case_name (prop))));
|
|
||||||
|
|
||||||
if (prop.initializer != null && prop.set_accessor != null && !prop.set_accessor.automatic_body) {
|
|
||||||
// generate a custom initializer if it couldn't be done at class_init time
|
|
||||||
diff --git a/codegen/valagtypemodule.vala b/codegen/valagtypemodule.vala
|
|
||||||
index 6d0f0d2eb..e75036041 100644
|
|
||||||
--- a/codegen/valagtypemodule.vala
|
|
||||||
+++ b/codegen/valagtypemodule.vala
|
|
||||||
@@ -1732,7 +1732,7 @@ public class Vala.GTypeModule : GErrorModule {
|
|
||||||
public override CCodeExpression get_param_spec_cexpression (Property prop) {
|
|
||||||
var cl = (TypeSymbol) prop.parent_symbol;
|
|
||||||
var prop_array = new CCodeIdentifier ("%s_properties".printf (get_ccode_lower_case_name (cl)));
|
|
||||||
- var prop_enum_value = new CCodeIdentifier (get_ccode_upper_case_name (prop));
|
|
||||||
+ var prop_enum_value = new CCodeIdentifier ("%s_PROPERTY".printf (get_ccode_upper_case_name (prop)));
|
|
||||||
|
|
||||||
return new CCodeElementAccess (prop_array, prop_enum_value);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.14.1
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (vala-0.38.0.tar.xz) = 7dbce81474710c730fec2c465e38800b893af6e9882ebada22758acca5b3f71d9b10281e49aee2f99937cdc235a743ef190f0b1dfb9e229b7e16d06b7bd53eda
|
SHA512 (vala-0.38.1.tar.xz) = 00ed915c0ca0a095626e4189fd6331e59e53c95619f76bff51413f822e73eedac8fb0937f0fb8bc32821154d68c9d7207e120be3c71596e2e0daa855b20f1f8a
|
||||||
|
12
vala.spec
12
vala.spec
@ -2,8 +2,8 @@
|
|||||||
%global priority 90
|
%global priority 90
|
||||||
|
|
||||||
Name: vala
|
Name: vala
|
||||||
Version: 0.38.0
|
Version: 0.38.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A modern programming language for GNOME
|
Summary: A modern programming language for GNOME
|
||||||
|
|
||||||
# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
|
# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
|
||||||
@ -11,9 +11,6 @@ License: LGPLv2+ and BSD
|
|||||||
URL: https://wiki.gnome.org/Projects/Vala
|
URL: https://wiki.gnome.org/Projects/Vala
|
||||||
Source0: https://download.gnome.org/sources/vala/0.38/vala-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/vala/0.38/vala-%{version}.tar.xz
|
||||||
|
|
||||||
# Backported from upstream
|
|
||||||
Patch0: 0001-codegen-Try-to-use-a-more-unique-internal-define-for.patch
|
|
||||||
|
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
@ -21,7 +18,7 @@ BuildRequires: gobject-introspection-devel
|
|||||||
BuildRequires: graphviz-devel
|
BuildRequires: graphviz-devel
|
||||||
BuildRequires: libxslt
|
BuildRequires: libxslt
|
||||||
# only if Vala source files are patched
|
# only if Vala source files are patched
|
||||||
BuildRequires: vala
|
#BuildRequires: vala
|
||||||
|
|
||||||
# for tests
|
# for tests
|
||||||
BuildRequires: dbus-x11
|
BuildRequires: dbus-x11
|
||||||
@ -220,6 +217,9 @@ done
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 11 2017 Kalev Lember <klember@redhat.com> - 0.38.1-1
|
||||||
|
- Update to 0.38.1
|
||||||
|
|
||||||
* Fri Sep 08 2017 Kalev Lember <klember@redhat.com> - 0.38.0-2
|
* Fri Sep 08 2017 Kalev Lember <klember@redhat.com> - 0.38.0-2
|
||||||
- Backport a patch to fix baobab (bgo#787419)
|
- Backport a patch to fix baobab (bgo#787419)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user