- Patch broken ModuleInit attribute (upstream bug 587444)
This commit is contained in:
parent
45effa9883
commit
26820d6c73
11
vala-0.7.4-moduleinit.patch
Normal file
11
vala-0.7.4-moduleinit.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- vala-0.7.4/codegen/valatyperegisterfunction.vala.moduleinit 2009-05-09 13:22:22.000000000 -0400
|
||||||
|
+++ vala-0.7.4/codegen/valatyperegisterfunction.vala 2009-07-14 03:34:59.236422291 -0400
|
||||||
|
@@ -62,7 +62,7 @@
|
||||||
|
if (!plugin) {
|
||||||
|
type_block.add_statement (cdecl);
|
||||||
|
} else {
|
||||||
|
- definition_fragment.append (cdecl);
|
||||||
|
+ declaration_fragment.append (cdecl);
|
||||||
|
}
|
||||||
|
|
||||||
|
CCodeFunction fun;
|
10
vala.spec
10
vala.spec
@ -15,7 +15,7 @@
|
|||||||
|
|
||||||
Name: vala
|
Name: vala
|
||||||
Version: 0.7.4
|
Version: 0.7.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A modern programming language for GNOME
|
Summary: A modern programming language for GNOME
|
||||||
|
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -25,6 +25,8 @@ URL: http://live.gnome.org/Vala
|
|||||||
Source0: http://download.gnome.org/sources/vala/0.7/vala-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/vala/0.7/vala-%{version}.tar.bz2
|
||||||
Source1: vala-mode.el
|
Source1: vala-mode.el
|
||||||
Source2: vala-init.el
|
Source2: vala-init.el
|
||||||
|
# http://bugzilla.gnome.org/show_bug.cgi?id=587444
|
||||||
|
Patch0: vala-0.7.4-moduleinit.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: gtk2-devel flex bison devhelp gecko-libs >= 1.9
|
BuildRequires: gtk2-devel flex bison devhelp gecko-libs >= 1.9
|
||||||
@ -114,10 +116,11 @@ An Emacs mode for editing Vala source code.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .moduleinit
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-vapigen --enable-gen-project
|
%configure --enable-vapigen
|
||||||
# Don't use rpath!
|
# Don't use rpath!
|
||||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
@ -184,6 +187,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
|
||||||
|
- Patch broken ModuleInit attribute (upstream bug 587444)
|
||||||
|
|
||||||
* Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
|
* Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
|
||||||
- Update to 0.7.4
|
- Update to 0.7.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user