Update to 0.12.1
This commit is contained in:
parent
b5b28e8abf
commit
110fa51693
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/vala-0.11.7.tar.bz2
|
/vala-0.11.7.tar.bz2
|
||||||
/vala-0.12.0.tar.bz2
|
/vala-0.12.0.tar.bz2
|
||||||
|
/vala-0.12.1.tar.xz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
b11fafaa705085342156312e356b6ff2 vala-0.12.0.tar.bz2
|
27e6e852b8f6b5695654029b7914b89d vala-0.12.1.tar.xz
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
From 5d74330d6c660ec7bc6caa6b3c23921b93358204 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?J=C3=BCrg=20Billeter?= <j@bitron.ch>
|
|
||||||
Date: Tue, 5 Apr 2011 19:28:31 +0200
|
|
||||||
Subject: [PATCH] Allow access to length of constant array in constant initializer lists
|
|
||||||
|
|
||||||
Fixes bug 643010.
|
|
||||||
---
|
|
||||||
vala/valamemberaccess.vala | 3 +++
|
|
||||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/vala/valamemberaccess.vala b/vala/valamemberaccess.vala
|
|
||||||
index dfb0eb6..7f4b6df 100644
|
|
||||||
--- a/vala/valamemberaccess.vala
|
|
||||||
+++ b/vala/valamemberaccess.vala
|
|
||||||
@@ -169,6 +169,9 @@ public class Vala.MemberAccess : Expression {
|
|
||||||
var method = symbol_reference as Method;
|
|
||||||
if (symbol_reference is Constant) {
|
|
||||||
return true;
|
|
||||||
+ } else if (symbol_reference is ArrayLengthField && inner != null && inner.symbol_reference is Constant) {
|
|
||||||
+ // length of constant array
|
|
||||||
+ return true;
|
|
||||||
} else if (method != null &&
|
|
||||||
(method.binding == MemberBinding.STATIC || prototype_access)) {
|
|
||||||
return true;
|
|
||||||
--
|
|
||||||
1.7.4.2
|
|
||||||
|
|
12
vala.spec
12
vala.spec
@ -1,8 +1,8 @@
|
|||||||
%global api_ver 0.12
|
%global api_ver 0.12
|
||||||
|
|
||||||
Name: vala
|
Name: vala
|
||||||
Version: 0.12.0
|
Version: 0.12.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A modern programming language for GNOME
|
Summary: A modern programming language for GNOME
|
||||||
|
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -13,12 +13,10 @@ URL: http://live.gnome.org/Vala
|
|||||||
# note: do not use a macro for directory name
|
# note: do not use a macro for directory name
|
||||||
# as it breaks Colin Walters' automatic build script
|
# as it breaks Colin Walters' automatic build script
|
||||||
# see https://bugzilla.redhat.com/show_bug.cgi?id=609292
|
# see https://bugzilla.redhat.com/show_bug.cgi?id=609292
|
||||||
Source0: http://download.gnome.org/sources/vala/0.12/vala-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/vala/0.12/vala-%{version}.tar.xz
|
||||||
Source1: vala-mode.el
|
Source1: vala-mode.el
|
||||||
Source2: vala-init.el
|
Source2: vala-init.el
|
||||||
Source3: emacs-vala-COPYING
|
Source3: emacs-vala-COPYING
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=643010
|
|
||||||
Patch0: vala-0.12.0-allow_constant_arrays.patch
|
|
||||||
|
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
@ -139,7 +137,6 @@ the emacs-%{name} package to use Vala with GNU Emacs.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .allow_constant_arrays
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -235,6 +232,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 17 2011 Tomas Bzatek <tbzatek@redhat.com> - 0.12.1-1
|
||||||
|
- Update to 0.12.1
|
||||||
|
|
||||||
* Tue Apr 5 2011 Michel Salim <salimma@fedoraproject.org> - 0.12.0-2
|
* Tue Apr 5 2011 Michel Salim <salimma@fedoraproject.org> - 0.12.0-2
|
||||||
- Allow access to length of constant array in constant initializer lists
|
- Allow access to length of constant array in constant initializer lists
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user