Update to 0.19.0
This commit is contained in:
parent
d842894b28
commit
06852d62e4
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/vala-0.18.1.tar.xz
|
||||
/vala-0.19.0.tar.xz
|
||||
|
@ -1,32 +0,0 @@
|
||||
From c755bb4bd3b078363193ea41495e4c9f2782a9d8 Mon Sep 17 00:00:00 2001
|
||||
From: "Jasper St. Pierre" <jstpierre@mecheye.net>
|
||||
Date: Sat, 2 Feb 2013 04:56:39 -0500
|
||||
Subject: [PATCH] valagirparser: Ignore the new instance-parameter tag
|
||||
|
||||
g-ir-scanner will now start emitting the instance parameter; since
|
||||
vala doesn't need this, just skip it.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=693054
|
||||
---
|
||||
vala/valagirparser.vala | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/vala/valagirparser.vala b/vala/valagirparser.vala
|
||||
index 0a90886..8256ef2 100644
|
||||
--- a/vala/valagirparser.vala
|
||||
+++ b/vala/valagirparser.vala
|
||||
@@ -2896,6 +2896,11 @@ public class Vala.GirParser : CodeVisitor {
|
||||
next ();
|
||||
|
||||
while (current_token == MarkupTokenType.START_ELEMENT) {
|
||||
+ if (reader.name == "instance-parameter") {
|
||||
+ skip_element ();
|
||||
+ continue;
|
||||
+ }
|
||||
+
|
||||
if (!push_metadata ()) {
|
||||
skip_element ();
|
||||
continue;
|
||||
--
|
||||
1.8.1.4
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
0d684cbddd3a7655fe54c030e4183dbd vala-0.18.1.tar.xz
|
||||
928821c5dad4674043fc6f052e874c8d vala-0.19.0.tar.xz
|
||||
|
18
vala.spec
18
vala.spec
@ -1,9 +1,9 @@
|
||||
%global api_ver 0.18
|
||||
%global api_ver 0.20
|
||||
%global priority 90
|
||||
|
||||
Name: vala
|
||||
Version: 0.18.1
|
||||
Release: 4%{?dist}
|
||||
Version: 0.19.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A modern programming language for GNOME
|
||||
|
||||
# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
|
||||
@ -13,17 +13,11 @@ URL: http://live.gnome.org/Vala
|
||||
# note: do not use a macro for directory name
|
||||
# as it breaks Colin Walters' automatic build script
|
||||
# see https://bugzilla.redhat.com/show_bug.cgi?id=609292
|
||||
Source0: http://download.gnome.org/sources/vala/0.18/vala-%{version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/vala/0.19/vala-%{version}.tar.xz
|
||||
Source1: vala-mode.el
|
||||
Source2: vala-init.el
|
||||
Source3: emacs-vala-COPYING
|
||||
|
||||
# Backported patch to ignore the "instance-parameter" tag emitted by g-ir-scanner
|
||||
Patch0: 0001-valagirparser-Ignore-the-new-instance-parameter-tag.patch
|
||||
|
||||
# for patch0
|
||||
BuildRequires: vala
|
||||
|
||||
BuildRequires: flex
|
||||
BuildRequires: bison
|
||||
BuildRequires: glib2-devel
|
||||
@ -135,7 +129,6 @@ the emacs-%{name} package to use Vala with GNU Emacs.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -280,6 +273,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Feb 22 2013 Kalev Lember <kalevlember@gmail.com> - 0.19.0-1
|
||||
- Update to 0.19.0
|
||||
|
||||
* Wed Feb 20 2013 Kalev Lember <kalevlember@gmail.com> - 0.18.1-4
|
||||
- Temporarily BR vala itself to build with the patch applied
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user