uuid/ossp-uuid.patch

208 lines
8.7 KiB
Diff

diff -urN uuid-1.5.1.orig/Makefile.PL uuid-1.5.1/Makefile.PL
--- uuid-1.5.1.orig/Makefile.PL 2006-01-15 12:37:43.000000000 -0600
+++ uuid-1.5.1/Makefile.PL 2006-09-21 15:59:40.000000000 -0500
@@ -44,7 +44,7 @@
all pure_all:
\@if [ ! -d build ]; then mkdir build; fi
\@if [ ! -f build/Makefile ]; then (cd build && ../configure --disable-shared); fi
- \@if [ ! -f build/libuuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libuuid.la); fi
+ \@if [ ! -f build/libossp-uuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libossp-uuid.la); fi
\@if [ ! -f perl/Makefile ]; then (cd perl && \$(PERL) Makefile.PL \$(ARGS)); fi
\@cd perl && \$(MAKE) \$(MFLAGS) \$\@
diff -urN uuid-1.5.1.orig/Makefile.in uuid-1.5.1/Makefile.in
--- uuid-1.5.1.orig/Makefile.in 2006-07-31 07:20:03.000000000 -0500
+++ uuid-1.5.1/Makefile.in 2006-09-21 16:06:31.000000000 -0500
@@ -61,13 +61,13 @@
PHP = @PHP@
PG_CONFIG = @PG_CONFIG@
-LIB_NAME = libuuid.la
+LIB_NAME = libossp-uuid.la
LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
-DCE_NAME = libuuid_dce.la
+DCE_NAME = libossp-uuid_dce.la
DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
-CXX_NAME = libuuid++.la
+CXX_NAME = libossp-uuid++.la
CXX_OBJS = uuid++.lo $(LIB_OBJS)
PRG_NAME = uuid
@@ -78,10 +78,10 @@
PERL_NAME = $(S)/perl/blib/lib/OSSP/uuid.pm
PERL_OBJS = $(S)/perl/uuid.pm
-PHP_NAME = $(S)/php/modules/uuid.so
+PHP_NAME = $(S)/php/modules/ossp-uuid.so
PHP_OBJS = $(S)/php/uuid.c
-PGSQL_NAME = $(S)/pgsql/libuuid.so
+PGSQL_NAME = $(S)/pgsql/libossp-uuid.so
PGSQL_OBJS = $(S)/pgsql/uuid.c
TARGETS = $(LIB_NAME) @DCE_NAME@ @CXX_NAME@ $(PRG_NAME) @PERL_NAME@ @PHP_NAME@ @PGSQL_NAME@
@@ -230,7 +230,7 @@
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(mandir)/man1
$(SHTOOL) install -c -m 755 uuid-config $(DESTDIR)$(bindir)/
$(SHTOOL) install -c -m 644 $(S)/uuid-config.1 $(DESTDIR)$(mandir)/man1/
- $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/
+ $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
$(SHTOOL) install -c -m 644 uuid.h $(DESTDIR)$(includedir)/
-@if [ ".$(WITH_DCE)" = .yes ]; then \
echo "$(SHTOOL) install -c -m 644 $(S)/uuid_dce.h $(DESTDIR)$(includedir)/"; \
@@ -240,7 +240,7 @@
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/"; \
$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/; \
fi
- $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/
+ $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/ossp-uuid.3
-@if [ ".$(WITH_CXX)" = .yes ]; then \
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/"; \
$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/; \
@@ -275,7 +275,7 @@
-@if [ ".$(WITH_CXX)" = .yes ]; then \
$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(libdir)/$(CXX_NAME); \
fi
- -$(RM) $(DESTDIR)$(mandir)/man3/uuid.3
+ -$(RM) $(DESTDIR)$(mandir)/man3/ossp-uuid.3
-@if [ ".$(WITH_CXX)" = .yes ]; then \
echo "$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3"; \
$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3; \
@@ -289,7 +289,7 @@
echo "$(RM) $(DESTDIR)$(includedir)/uuid++.hh"; \
$(RM) $(DESTDIR)$(includedir)/uuid++.hh; \
fi
- -$(RM) $(DESTDIR)$(libdir)/pkgconfig/uuid.pc
+ -$(RM) $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
-$(RM) $(DESTDIR)$(mandir)/man1/uuid-config.1
-$(RM) $(DESTDIR)$(bindir)/uuid-config
-$(RMDIR) $(DESTDIR)$(mandir)/man1 >/dev/null 2>&1 || $(TRUE)
diff -urN uuid-1.5.1.orig/perl/Makefile.PL uuid-1.5.1/perl/Makefile.PL
--- uuid-1.5.1.orig/perl/Makefile.PL 2006-01-13 00:44:33.000000000 -0600
+++ uuid-1.5.1/perl/Makefile.PL 2006-09-21 15:59:40.000000000 -0500
@@ -33,9 +33,9 @@
use ExtUtils::MakeMaker;
# determine source directory
-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
- or die "no source directory found (where libuuid.la is located)";
+my ($srcdir) = map { my $d = $_; $d =~ s/\/libossp-uuid\.la$//; $d }
+ grep { -f $_ } ("../libossp-uuid.la", glob("../*/libossp-uuid.la"))
+ or die "no source directory found (where libossp-uuid.la is located)";
# determine extra build options
my $compat = 0;
@@ -47,7 +47,7 @@
VERSION_FROM => 'uuid.pm',
ABSTRACT_FROM => 'uuid.pod',
PREREQ_PM => {},
- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
+ LIBS => [ "-L$srcdir/.libs -L$srcdir -lossp-uuid" ],
DEFINE => '',
INC => "-I. -I$srcdir",
PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',
diff -urN uuid-1.5.1.orig/pgsql/Makefile uuid-1.5.1/pgsql/Makefile
--- uuid-1.5.1.orig/pgsql/Makefile 2006-07-31 07:36:58.000000000 -0500
+++ uuid-1.5.1/pgsql/Makefile 2006-09-21 16:07:23.000000000 -0500
@@ -17,13 +17,13 @@
top_builddir := $(dir $(PGXS))../..
include $(top_builddir)/src/Makefile.global
-NAME = uuid
+NAME = ossp-uuid
OBJS = uuid.o
SO_MAJOR_VERSION = 1
SO_MINOR_VERSION = 0
override CPPFLAGS := -I.. $(CPPFLAGS)
-SHLIB_LINK := -L../.libs -luuid
+SHLIB_LINK := -L../.libs -lossp-uuid
SHLIB_LINK += $(shell test $(shell uname -s) = FreeBSD && echo "-Wl,-Bsymbolic")
rpath :=
@@ -33,16 +33,16 @@
include $(top_builddir)/src/Makefile.shlib
uuid.sql: uuid.sql.in
- sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
+ sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
install: all
$(mkinstalldirs) $(DESTDIR)$(pkglibdir)
$(mkinstalldirs) $(DESTDIR)$(datadir)
- $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
+ $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
$(INSTALL_DATA) uuid.sql $(DESTDIR)$(datadir)/uuid.sql
uninstall:
- -rm -f $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
+ -rm -f $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
-rm -f $(DESTDIR)$(datadir)/uuid.sql
clean distclean: clean-lib
diff -urN uuid-1.5.1.orig/php/Makefile.local uuid-1.5.1/php/Makefile.local
--- uuid-1.5.1.orig/php/Makefile.local 2006-07-31 06:41:46.000000000 -0500
+++ uuid-1.5.1/php/Makefile.local 2006-09-21 15:59:40.000000000 -0500
@@ -48,7 +48,7 @@
@version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
echo "installing PHP$$version API into $$extdir"; \
./build/shtool mkdir -f -p -m 755 $(DESTDIR)$$extdir; \
- ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/uuid.so; \
+ ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/ossp-uuid.so; \
./build/shtool install -c -m 644 uuid.php$$version $(DESTDIR)$$extdir/uuid.php
clean:
diff -urN uuid-1.5.1.orig/php/config.m4 uuid-1.5.1/php/config.m4
--- uuid-1.5.1.orig/php/config.m4 2006-01-13 00:44:34.000000000 -0600
+++ uuid-1.5.1/php/config.m4 2006-09-21 15:59:40.000000000 -0500
@@ -34,7 +34,7 @@
PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
PHP_ADD_LIBPATH([..], )
- PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
+ PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
PHP_ADD_INCLUDE([..])
PHP_SUBST(UUID_SHARED_LIBADD)
dnl avoid conflict with libc's uuid_create(3)
diff -urN uuid-1.5.1.orig/php/uuid.ts uuid-1.5.1/php/uuid.ts
--- uuid-1.5.1.orig/php/uuid.ts 2006-01-13 00:44:34.000000000 -0600
+++ uuid-1.5.1/php/uuid.ts 2006-09-21 15:59:40.000000000 -0500
@@ -34,9 +34,9 @@
$php_version = $argv[1];
-print "++ loading DSO uuid.so (low-level API)\n";
+print "++ loading DSO ossp-uuid.so (low-level API)\n";
if (!extension_loaded('uuid')) {
- dl('modules/uuid.so');
+ dl('modules/ossp-uuid.so');
}
print "++ loading PHP uuid.php${php_version} (high-level API)\n";
diff -urN uuid-1.5.1.orig/uuid-config.in uuid-1.5.1/uuid-config.in
--- uuid-1.5.1.orig/uuid-config.in 2006-01-13 00:44:30.000000000 -0600
+++ uuid-1.5.1/uuid-config.in 2006-09-21 15:59:40.000000000 -0500
@@ -120,7 +120,7 @@
output_extra="$output_extra $uuid_ldflags"
;;
--libs)
- output="$output -luuid"
+ output="$output -lossp-uuid"
output_extra="$output_extra $uuid_libs"
;;
* )
diff -urN uuid-1.5.1.orig/uuid.pc.in uuid-1.5.1/uuid.pc.in
--- uuid-1.5.1.orig/uuid.pc.in 2006-01-13 00:44:30.000000000 -0600
+++ uuid-1.5.1/uuid.pc.in 2006-09-21 15:59:40.000000000 -0500
@@ -37,6 +37,6 @@
Version: @UUID_VERSION_RAW@
URL: http://www.ossp.org/pkg/lib/uuid/
Cflags: -I${includedir}
-Libs: -L${libdir} -luuid
+Libs: -L${libdir} -lossp-uuid
Libs.private: @LIBS@