Rebuilt for IMA sigs, glibc 2.34, aarch64 flags

Related: rhbz#1991688
Resolves: #2044896
This commit is contained in:
Michal Hlavinka 2022-02-04 12:42:08 +01:00
parent ae3d252de7
commit be5918b6c7
2 changed files with 31 additions and 4 deletions

22
uuid-1.6.2-ldflags.patch Normal file
View File

@ -0,0 +1,22 @@
diff -up uuid-1.6.2/Makefile.in.ldflags uuid-1.6.2/Makefile.in
--- uuid-1.6.2/Makefile.in.ldflags 2022-01-24 20:53:01.992171989 +0100
+++ uuid-1.6.2/Makefile.in 2022-01-24 20:53:02.025171559 +0100
@@ -112,15 +112,15 @@ all: $(TARGETS)
@$(LIBTOOL) --mode=compile $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $<
$(LIB_NAME): $(LIB_OBJS)
- @$(LIBTOOL) --mode=link $(CC) -o $(LIB_NAME) $(LIB_OBJS) -rpath $(libdir) \
+ @$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) -rpath $(libdir) \
-version-info `$(SHTOOL) version -l c -d libtool $(S)/uuid_vers.h`
$(DCE_NAME): $(DCE_OBJS)
- @$(LIBTOOL) --mode=link $(CC) -o $(DCE_NAME) $(DCE_OBJS) -rpath $(libdir) \
+ @$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $(DCE_NAME) $(DCE_OBJS) -rpath $(libdir) \
-version-info `$(SHTOOL) version -l c -d libtool $(S)/uuid_vers.h`
$(CXX_NAME): $(CXX_OBJS)
- @$(LIBTOOL) --mode=link $(CXX) -o $(CXX_NAME) $(CXX_OBJS) -rpath $(libdir) \
+ @$(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -o $(CXX_NAME) $(CXX_OBJS) -rpath $(libdir) \
-version-info `$(SHTOOL) version -l c -d libtool $(S)/uuid_vers.h`
$(PRG_NAME): $(PRG_OBJS) $(LIB_NAME)

View File

@ -6,7 +6,7 @@
Name: uuid
Version: 1.6.2
Release: 53%{?dist}
Release: 54%{?dist}
Summary: Universally Unique Identifier library
License: MIT
URL: http://www.ossp.org/pkg/lib/uuid/
@ -20,10 +20,13 @@ Patch3: uuid-1.6.2-hwaddr.patch
# do not strip binaries
Patch4: uuid-1.6.2-nostrip.patch
Patch5: uuid-1.6.2-manfix.patch
Patch6: uuid-aarch64.patch
Patch5: uuid-1.6.2-manfix.patch
Patch6: uuid-aarch64.patch
BuildRequires: make
# use ldflags for libs too
Patch7: uuid-1.6.2-ldflags.patch
BuildRequires: make
BuildRequires: gcc-c++
BuildRequires: libtool
@ -111,6 +114,7 @@ DCE development headers and libraries for OSSP uuid.
%patch4 -p1 -b .nostrip
%patch5 -p1 -b .manfix
%patch6 -p1 -b .aarch64
%patch7 -p1 -b .ldflags
%build
# Build the library.
@ -121,6 +125,7 @@ export PHP_NAME=$(pwd)/php/modules/ossp-uuid.so
export PGSQL_NAME=$(pwd)/pgsql/libossp-uuid.so
export CFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS"
export LDFLAGS="-Wl,-z,now -Wl,-z,relro %{?__global_ldflags}"
%configure \
--disable-static \
--without-perl \