Fixed path to usb.ids Resolves: #506974

This commit is contained in:
Jiří Moskovčák 2009-07-01 11:20:44 +00:00
parent 97c9508164
commit 3a351c870a
2 changed files with 66 additions and 3 deletions

View File

@ -0,0 +1,59 @@
--- usbutils-0.82/Makefile.am 2009-05-07 00:05:10.000000000 +0200
+++ usbutils-0.82_hwdata/Makefile.am 2009-07-01 13:05:11.000000000 +0200
@@ -1,18 +1,9 @@
AM_LDFLAGS = \
-Wl,--as-needed
-data_DATA = \
- usb.ids
-if HAVE_ZLIB
-data_DATA += usb.ids.gz
-endif
-
sbin_PROGRAMS = \
lsusb
-sbin_SCRIPTS = \
- update-usbids.sh
-
lsusb_SOURCES = \
lsusb.c \
lsusb-t.c \
@@ -23,7 +14,7 @@ lsusb_SOURCES = \
lsusb_CPPFLAGS = \
$(AM_CPPFLAGS) \
- -DDATADIR=\"$(datadir)\"
+ -DDATADIR=\"$(datadir)/hwdata\"
lsusb_LDADD = \
$(LIBUSB_LIBS)
@@ -32,18 +23,9 @@ man_MANS = \
lsusb.8
EXTRA_DIST = \
- usb.ids \
- update-usbids.sh.in \
lsusb.8.in \
usbutils.pc.in
-usb.ids.gz: $(srcdir)/usb.ids
- gzip -c -9 $< > $@
-
-update-usbids.sh: $(srcdir)/update-usbids.sh.in
- sed 's|@usbids@|$(datadir)/usb.ids|g' $< >$@
- chmod 755 $@
-
lsusb.8: $(srcdir)/lsusb.8.in
sed 's|@usbids@|$(datadir)/usb.ids|g' $< >$@
@@ -54,9 +36,7 @@ usbutils.pc: $(srcdir)/usbutils.pc.in
sed 's|@usbids@|$(datadir)/usb.ids|g;s|@VERSION[@]|$(VERSION)|g' $< >$@
DISTCLEANFILES = \
- usb.ids.gz \
lsusb.8 \
- update-usbids.sh \
usbutils.pc
distclean-local:

View File

@ -1,6 +1,6 @@
Name: usbutils
Version: 0.82
Release: 1%{?dist}
Release: 2%{?dist}
Source: http://downloads.sourceforge.net/linux-usb/%{name}-%{version}.tar.gz
URL: http://www.linux-usb.org/
License: GPLv2+
@ -12,6 +12,7 @@ Summary: Linux USB utilities
Group: Applications/System
Conflicts: hotplug < 3:2002_01_14-2
ExcludeArch: s390 s390x
Patch0: usbutils-0.82-hwdata.patch
%description
This package contains utilities for inspecting devices connected to a
@ -19,6 +20,7 @@ USB bus.
%prep
%setup -q
%patch0 -p1
%build
%configure --sbindir=/sbin
@ -29,8 +31,6 @@ rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
# usb.ids is shipped in hwdata; nuke and adjust .pc file
rm -f $RPM_BUILD_ROOT%{_datadir}/usb.ids*
rm -f $RPM_BUILD_ROOT/sbin/update-usbids.sh
sed -i 's|usbids=/usr/share/usb.ids|usbids=/usr/share/hwdata/usb.ids|' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/usbutils.pc
%files
@ -44,6 +44,10 @@ sed -i 's|usbids=/usr/share/usb.ids|usbids=/usr/share/hwdata/usb.ids|' $RPM_BUIL
rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Jul 1 2009 Jiri Moskovcak <jmoskovc@redhat.com> 0.82-2
- minor fix in Makefile.am to properly find usb.ids from hwdata
- Resolves: #506974
* Fri May 22 2009 David Zeuthen <davidz@redhat.com> 0.82-1
- Update to 0.82