import uom-lib-1.0.1-6.module+el8+2463+615f6896
This commit is contained in:
commit
49630d0952
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/uom-lib-1.0.1.tar.gz
|
1
.uom-lib.metadata
Normal file
1
.uom-lib.metadata
Normal file
@ -0,0 +1 @@
|
||||
5172ecfd67c65e2938cce422826a74660d440e5e SOURCES/uom-lib-1.0.1.tar.gz
|
72
SOURCES/javadoc-build-failures.patch
Normal file
72
SOURCES/javadoc-build-failures.patch
Normal file
@ -0,0 +1,72 @@
|
||||
diff -Naurp uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/IntIdentifiable.java uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/IntIdentifiable.java
|
||||
--- uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/IntIdentifiable.java 2016-10-13 10:08:38.000000000 +1100
|
||||
+++ uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/IntIdentifiable.java 2017-04-07 12:24:08.335917358 +1000
|
||||
@@ -40,11 +40,10 @@ package tec.uom.lib.common.function;
|
||||
*
|
||||
* @author Werner KEIL
|
||||
* @version 1.0.5 $Date: 2016/01/04 $
|
||||
- * @see {@link Identifiable}
|
||||
*/
|
||||
public interface IntIdentifiable {
|
||||
/**
|
||||
* @return an Id
|
||||
*/
|
||||
public int getId();
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
||||
diff -Naurp uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/LongIdentifiable.java uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/LongIdentifiable.java
|
||||
--- uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/LongIdentifiable.java 2016-10-13 10:08:38.000000000 +1100
|
||||
+++ uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/LongIdentifiable.java 2017-04-07 12:24:30.761607643 +1000
|
||||
@@ -40,11 +40,10 @@ package tec.uom.lib.common.function;
|
||||
*
|
||||
* @author Werner KEIL
|
||||
* @version 1.0.1 $Date: 2014/09/17 $
|
||||
- * @see {@link Identifiable}
|
||||
*/
|
||||
public interface LongIdentifiable {
|
||||
/**
|
||||
* @return an Id
|
||||
*/
|
||||
public long getId();
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
||||
diff -Naurp uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/Parser.java uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/Parser.java
|
||||
--- uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/Parser.java 2016-10-13 10:08:38.000000000 +1100
|
||||
+++ uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/Parser.java 2017-04-07 12:25:38.582670982 +1000
|
||||
@@ -34,11 +34,6 @@ import javax.measure.format.ParserExcept
|
||||
/**
|
||||
* Represents a function that parses an input value and produces an output.
|
||||
*
|
||||
- * <p>
|
||||
- * This is a <a href=
|
||||
- * "http://docs.oracle.com/javase/8/docs/api/java/util/function/package-summary.html#package.description"
|
||||
- * >functional interface</a> whose functional method is {@link #parse()}.
|
||||
- *
|
||||
* @author <a href="mailto:units@catmedia.us">Werner Keil</a>
|
||||
* @version 1.0, 2016-10-13
|
||||
* @param <I>
|
||||
diff -Naurp uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/QuantityOperator.java uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/QuantityOperator.java
|
||||
--- uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/QuantityOperator.java 2016-10-13 10:08:38.000000000 +1100
|
||||
+++ uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/QuantityOperator.java 2017-04-07 12:26:07.941265393 +1000
|
||||
@@ -45,7 +45,7 @@ import javax.measure.Quantity;
|
||||
* result = thisOperator.apply(quantity);
|
||||
* </pre>
|
||||
*
|
||||
- * <h4>Implementation specification</h4>
|
||||
+ * <h1>Implementation specification</h1>
|
||||
* The implementation must take the input object and apply it. The
|
||||
* implementation defines the logic of the operator and is responsible for
|
||||
* documenting that logic. It may use any method on {@code Quantity} to
|
||||
diff -Naurp uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/QuantitySupplier.java uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/QuantitySupplier.java
|
||||
--- uom-lib-1.0.1.orig/common/src/main/java/tec/uom/lib/common/function/QuantitySupplier.java 2016-10-13 10:08:38.000000000 +1100
|
||||
+++ uom-lib-1.0.1/common/src/main/java/tec/uom/lib/common/function/QuantitySupplier.java 2017-04-07 12:27:59.212727858 +1000
|
||||
@@ -43,7 +43,6 @@ import javax.measure.Quantity;
|
||||
* @author Werner Keil
|
||||
* @version 0.1, $Date: 2014-11-05 $
|
||||
* @param <Q> the type of quantities supplied by this supplier
|
||||
- * @see {@link Quantity}
|
||||
*/
|
||||
//@FunctionalInterface
|
||||
public interface QuantitySupplier<Q extends Quantity<Q>> {
|
74
SPECS/uom-lib.spec
Normal file
74
SPECS/uom-lib.spec
Normal file
@ -0,0 +1,74 @@
|
||||
Name: uom-lib
|
||||
Version: 1.0.1
|
||||
Release: 6%{?dist}
|
||||
Summary: Java Unit of Measurement Libraries (JSR 363)
|
||||
License: BSD
|
||||
URL: https://github.com/unitsofmeasurement/%{name}
|
||||
Source0: https://github.com/unitsofmeasurement/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch1: javadoc-build-failures.patch
|
||||
|
||||
BuildRequires: junit
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: maven-jar-plugin
|
||||
BuildRequires: maven-install-plugin
|
||||
BuildRequires: maven-dependency-plugin
|
||||
BuildRequires: maven-source-plugin
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
BuildRequires: mvn(tec.uom:uom-parent:pom:)
|
||||
BuildRequires: mvn(javax.measure:unit-api)
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
Units of Measurement Libraries - extending and complementing JSR 363.
|
||||
|
||||
%package common
|
||||
Summary: Java Units of Measurement Common Library
|
||||
|
||||
%description common
|
||||
Units of Measurement Common Library - extending and complementing JSR 363.
|
||||
|
||||
%package javadoc
|
||||
BuildArch: noarch
|
||||
Summary: Javadoc for the Units of Measurement Libraries
|
||||
|
||||
%description javadoc
|
||||
This package contains documentation for the Units of Measurement
|
||||
Libraries (JSR 363).
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch1 -p1
|
||||
|
||||
%pom_remove_plugin :maven-javadoc-plugin common/pom.xml
|
||||
|
||||
%build
|
||||
%mvn_build
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%doc README.md
|
||||
%license LICENSE.txt
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
|
||||
%changelog
|
||||
* Fri Apr 07 2017 Nathan Scott <nathans@redhat.com> - 1.0.1-6
|
||||
- Rebuilt with a Java 8 buildroot.
|
||||
|
||||
* Wed Apr 05 2017 Nathan Scott <nathans@redhat.com> - 1.0.1-5
|
||||
- Spec file changes for building on RHEL7.
|
||||
|
||||
* Wed Mar 22 2017 Nathan Scott <nathans@redhat.com> - 1.0.1-4
|
||||
- Incorprate feedback from gil cattaneo on all uom packages.
|
||||
|
||||
* Tue Feb 28 2017 Nathan Scott <nathans@redhat.com> - 1.0.1-3
|
||||
- Resolve lintian errors - source, license, documentation.
|
||||
|
||||
* Fri Feb 24 2017 Nathan Scott <nathans@redhat.com> - 1.0.1-2
|
||||
- Add unitsofmeasurement prefix to package name.
|
||||
|
||||
* Thu Oct 13 2016 Nathan Scott <nathans@redhat.com> - 1.0.1-1
|
||||
- Initial version.
|
Loading…
Reference in New Issue
Block a user