fix segfault with unpacking of zipfiles containing dangling symlinks (bug
#134073)
This commit is contained in:
parent
7c117f88e8
commit
fc4fd70ab6
@ -1,8 +1,12 @@
|
||||
diff -ur unzip-5.51/unix/unix.c unzip-5.51-lhh/unix/unix.c
|
||||
--- unzip-5.51/unix/unix.c 2004-04-11 20:29:58.000000000 -0400
|
||||
+++ unzip-5.51-lhh/unix/unix.c 2004-11-22 14:34:21.468981000 -0500
|
||||
@@ -1052,7 +1052,9 @@
|
||||
fclose(G.outfile);
|
||||
--- unzip-5.51/unix/unix.c.mmm 2004-04-12 02:29:58.000000000 +0200
|
||||
+++ unzip-5.51/unix/unix.c 2005-02-03 14:59:46.280095080 +0100
|
||||
@@ -1049,10 +1049,13 @@
|
||||
"warning: symbolic link (%s) failed\n",
|
||||
FnFilter1(G.filename)));
|
||||
free(slnk_entry);
|
||||
- fclose(G.outfile);
|
||||
+ if (G.outfile)
|
||||
+ fclose(G.outfile);
|
||||
return;
|
||||
}
|
||||
- fclose(G.outfile); /* close "link" file for good... */
|
||||
|
12
unzip.spec
12
unzip.spec
@ -1,7 +1,7 @@
|
||||
Summary: A utility for unpacking zip files.
|
||||
Name: unzip
|
||||
Version: 5.51
|
||||
Release: 6
|
||||
Release: 7
|
||||
License: BSD
|
||||
Group: Applications/Archiving
|
||||
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip551.tar.gz
|
||||
@ -24,9 +24,9 @@ a zip archive.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch0 -p1 -b .rpmo
|
||||
%patch1 -p1 -b .4GB
|
||||
%patch2 -p1 -b .link-segv
|
||||
ln -s unix/Makefile Makefile
|
||||
|
||||
%build
|
||||
@ -47,6 +47,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-7
|
||||
- fix segfault with unpacking of zipfiles containing dangling symlinks
|
||||
(bug #134073)
|
||||
|
||||
* Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-6
|
||||
- Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user