fix open call
This commit is contained in:
parent
f4c19115b0
commit
fad71b4c2d
19
unzip-5.52-open.patch
Normal file
19
unzip-5.52-open.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
--- unzip-5.52/fileio.c.pom 2007-08-30 11:36:05.000000000 +0200
|
||||||
|
+++ unzip-5.52/fileio.c 2007-09-04 10:37:41.000000000 +0200
|
||||||
|
@@ -53,7 +53,6 @@
|
||||||
|
|
||||||
|
---------------------------------------------------------------------------*/
|
||||||
|
|
||||||
|
-
|
||||||
|
#define __FILEIO_C /* identifies this source module */
|
||||||
|
#define UNZIP_INTERNAL
|
||||||
|
#include "unzip.h"
|
||||||
|
@@ -425,7 +424,7 @@ int open_outfile(__G) /* return
|
||||||
|
Trace((stderr, "open_outfile: doing fopen(%s) for writing\n",
|
||||||
|
FnFilter1(G.filename)));
|
||||||
|
|
||||||
|
- fd = open(G.filename, O_WRONLY | O_LARGEFILE | O_CREAT);
|
||||||
|
+ fd = open(G.filename, O_WRONLY | O_LARGEFILE | O_CREAT, 0600);
|
||||||
|
if ((G.outfile = fdopen(fd, FOPW)) == (FILE *)NULL) {
|
||||||
|
Info(slide, 0x401, ((char *)slide, LoadFarString(CannotCreateFile),
|
||||||
|
FnFilter1(G.filename)));
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A utility for unpacking zip files
|
Summary: A utility for unpacking zip files
|
||||||
Name: unzip
|
Name: unzip
|
||||||
Version: 5.52
|
Version: 5.52
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip552.tar.gz
|
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip552.tar.gz
|
||||||
@ -13,6 +13,7 @@ Patch7: unzip-5.52-near-4GB.patch
|
|||||||
Patch8: unzip-5.52-near-4GB2.patch
|
Patch8: unzip-5.52-near-4GB2.patch
|
||||||
Patch9: unzip-5.52-long-filename.patch
|
Patch9: unzip-5.52-long-filename.patch
|
||||||
Patch10: unzip-5.52-makefile.patch
|
Patch10: unzip-5.52-makefile.patch
|
||||||
|
Patch11: unzip-5.52-open.patch
|
||||||
URL: http://www.info-zip.org/pub/infozip/UnZip.html
|
URL: http://www.info-zip.org/pub/infozip/UnZip.html
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -37,6 +38,7 @@ a zip archive.
|
|||||||
%patch8 -p1 -b .4GB2
|
%patch8 -p1 -b .4GB2
|
||||||
%patch9 -p1 -b .lfn
|
%patch9 -p1 -b .lfn
|
||||||
%patch10 -p1 -b .make
|
%patch10 -p1 -b .make
|
||||||
|
%patch11 -p1 -b .open
|
||||||
ln -s unix/Makefile Makefile
|
ln -s unix/Makefile Makefile
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -57,6 +59,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 4 2007 Ivana Varekova <varekova@redhat.com> - 5.52-5
|
||||||
|
- fix open call
|
||||||
|
|
||||||
* Wed Feb 7 2007 Ivana Varekova <varekova@redhat.com> - 5.52-4
|
* Wed Feb 7 2007 Ivana Varekova <varekova@redhat.com> - 5.52-4
|
||||||
- incorporate the next peckage review comment
|
- incorporate the next peckage review comment
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user