Fix: Unzip Fails on Large Zip Files

Resolves: RHEL-45993
This commit is contained in:
Jakub Martisko 2024-07-03 14:04:29 +02:00
parent b0a76ed7be
commit d971d180d2
2 changed files with 25 additions and 1 deletions

View File

@ -0,0 +1,15 @@
From: "Steven M. Schweda" <sms@antinode.info>
Subject: Fix lame code in fileio.c
Bug-Debian: https://bugs.debian.org/929502
X-Debian-version: 6.0-23
--- a/fileio.c
+++ b/fileio.c
@@ -2477,6 +2477,7 @@
*/
return (((zusz_t)sig[7]) << 56)
+ (((zusz_t)sig[6]) << 48)
+ + (((zusz_t)sig[5]) << 40)
+ (((zusz_t)sig[4]) << 32)
+ (zusz_t)((((ulg)sig[3]) << 24)
+ (((ulg)sig[2]) << 16)

View File

@ -6,7 +6,7 @@
Summary: A utility for unpacking zip files Summary: A utility for unpacking zip files
Name: unzip Name: unzip
Version: 6.0 Version: 6.0
Release: 64%{?dist} Release: 65%{?dist}
License: Info-ZIP License: Info-ZIP
Source: http://downloads.sourceforge.net/infozip/unzip60.tar.gz Source: http://downloads.sourceforge.net/infozip/unzip60.tar.gz
@ -74,6 +74,9 @@ Patch33: unzip-zipbomb-switch.patch
Patch34: unzip-gnu89-build.patch Patch34: unzip-gnu89-build.patch
Patch35: unzip-6.0-wcstombs-fortify.patch Patch35: unzip-6.0-wcstombs-fortify.patch
#https://sources.debian.org/patches/unzip/6.0-28/21-fix-warning-messages-on-big-files.patch/
Patch36: unzip-6.0-fix-warning-messages-on-big-files.patch
URL: http://infozip.sourceforge.net URL: http://infozip.sourceforge.net
BuildRequires: make BuildRequires: make
BuildRequires: bzip2-devel, gcc BuildRequires: bzip2-devel, gcc
@ -127,6 +130,7 @@ a zip archive.
%patch33 -p1 %patch33 -p1
%patch34 -p1 %patch34 -p1
%patch35 -p1 %patch35 -p1
%patch36 -p1
%build %build
# IZ_HAVE_UXUIDGID is needed for right functionality of unzip -X # IZ_HAVE_UXUIDGID is needed for right functionality of unzip -X
@ -145,6 +149,11 @@ make -f unix/Makefile prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT%{_
%{_mandir}/*/* %{_mandir}/*/*
%changelog %changelog
* Wed Jul 03 2024 Jakub Martisko <jamartis@redhat.com> - 6.0-65
- Fix: Unzip Fails on Large Zip Files
- Use the patch from Debian dealing with this
Resolves: RHEL-45993
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 6.0-64 * Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 6.0-64
- Bump release for June 2024 mass rebuild - Bump release for June 2024 mass rebuild