import UBI unzip-6.0-47.el8_10
This commit is contained in:
parent
53f96085ca
commit
c939677982
15
SOURCES/unzip-6.0-fix-warning-messages-on-big-files.patch
Normal file
15
SOURCES/unzip-6.0-fix-warning-messages-on-big-files.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
From: "Steven M. Schweda" <sms@antinode.info>
|
||||||
|
Subject: Fix lame code in fileio.c
|
||||||
|
Bug-Debian: https://bugs.debian.org/929502
|
||||||
|
X-Debian-version: 6.0-23
|
||||||
|
|
||||||
|
--- a/fileio.c
|
||||||
|
+++ b/fileio.c
|
||||||
|
@@ -2477,6 +2477,7 @@
|
||||||
|
*/
|
||||||
|
return (((zusz_t)sig[7]) << 56)
|
||||||
|
+ (((zusz_t)sig[6]) << 48)
|
||||||
|
+ + (((zusz_t)sig[5]) << 40)
|
||||||
|
+ (((zusz_t)sig[4]) << 32)
|
||||||
|
+ (zusz_t)((((ulg)sig[3]) << 24)
|
||||||
|
+ (((ulg)sig[2]) << 16)
|
@ -7,7 +7,7 @@
|
|||||||
Summary: A utility for unpacking zip files
|
Summary: A utility for unpacking zip files
|
||||||
Name: unzip
|
Name: unzip
|
||||||
Version: 6.0
|
Version: 6.0
|
||||||
Release: 46%{?dist}
|
Release: 47%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Source: http://downloads.sourceforge.net/infozip/unzip60.tar.gz
|
Source: http://downloads.sourceforge.net/infozip/unzip60.tar.gz
|
||||||
@ -76,6 +76,8 @@ Patch32: unzip-zipbomb-part5.patch
|
|||||||
Patch33: unzip-zipbomb-part6.patch
|
Patch33: unzip-zipbomb-part6.patch
|
||||||
|
|
||||||
Patch34: unzip-zipbomb-switch.patch
|
Patch34: unzip-zipbomb-switch.patch
|
||||||
|
|
||||||
|
Patch35: unzip-6.0-fix-warning-messages-on-big-files.patch
|
||||||
URL: http://www.info-zip.org/UnZip.html
|
URL: http://www.info-zip.org/UnZip.html
|
||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
|
|
||||||
@ -129,6 +131,7 @@ a zip archive.
|
|||||||
%patch32 -p1
|
%patch32 -p1
|
||||||
%patch33 -p1
|
%patch33 -p1
|
||||||
%patch34 -p1
|
%patch34 -p1
|
||||||
|
%patch35 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# IZ_HAVE_UXUIDGID is needed for right functionality of unzip -X
|
# IZ_HAVE_UXUIDGID is needed for right functionality of unzip -X
|
||||||
@ -149,6 +152,11 @@ make -f unix/Makefile prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 03 2024 Jakub Martisko <jamartis@redhat.com> - 6.0-47
|
||||||
|
- Fix: Unzip Fails on Large Zip Files
|
||||||
|
- Use the patch from Debian dealing with this
|
||||||
|
Resolves: RHEL-45997
|
||||||
|
|
||||||
* Thu Dec 16 2021 Jakub Martisko <jamartis@redhat.com> - 6.0-46
|
* Thu Dec 16 2021 Jakub Martisko <jamartis@redhat.com> - 6.0-46
|
||||||
- Add environment variable that disables the zipbomb detection
|
- Add environment variable that disables the zipbomb detection
|
||||||
- Resolves: rhbz#2020320
|
- Resolves: rhbz#2020320
|
||||||
|
Loading…
Reference in New Issue
Block a user