Fix the other problem with unpacking zipfiles containing symlinks (bug
#134073)
This commit is contained in:
parent
9965021aea
commit
9dd0bf7421
10
unzip-5.51-link-segv2.patch
Normal file
10
unzip-5.51-link-segv2.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- unzip-5.51/unix/unix.c.morn 2005-02-08 14:40:40.187895928 +0100
|
||||||
|
+++ unzip-5.51/unix/unix.c 2005-02-08 14:44:59.025546624 +0100
|
||||||
|
@@ -1002,6 +1002,7 @@
|
||||||
|
ush z_uidgid[2];
|
||||||
|
int have_uidgid_flg;
|
||||||
|
|
||||||
|
+ fchmod(fileno(G.outfile), 0400);
|
||||||
|
fclose(G.outfile);
|
||||||
|
|
||||||
|
/*---------------------------------------------------------------------------
|
12
unzip.spec
12
unzip.spec
@ -1,13 +1,15 @@
|
|||||||
Summary: A utility for unpacking zip files.
|
Summary: A utility for unpacking zip files.
|
||||||
Name: unzip
|
Name: unzip
|
||||||
Version: 5.51
|
Version: 5.51
|
||||||
Release: 8
|
Release: 9
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip551.tar.gz
|
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip551.tar.gz
|
||||||
Patch0: unzip542-rpmoptflags.patch
|
Patch0: unzip542-rpmoptflags.patch
|
||||||
Patch1: unzip-5.51-near-4GB.patch
|
Patch1: unzip-5.51-near-4GB.patch
|
||||||
Patch2: unzip-5.51-link-segv.patch
|
Patch2: unzip-5.51-link-segv.patch
|
||||||
|
Patch3: unzip-5.51-link-segv2.patch
|
||||||
|
Patch4: unzip-5.51-link-segv3.patch
|
||||||
URL: http://www.info-zip.org/pub/infozip/UnZip.html
|
URL: http://www.info-zip.org/pub/infozip/UnZip.html
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
@ -27,6 +29,8 @@ a zip archive.
|
|||||||
%patch0 -p1 -b .rpmo
|
%patch0 -p1 -b .rpmo
|
||||||
%patch1 -p1 -b .4GB
|
%patch1 -p1 -b .4GB
|
||||||
%patch2 -p1 -b .link-segv
|
%patch2 -p1 -b .link-segv
|
||||||
|
%patch3 -p1 -b .morn
|
||||||
|
%patch4 -p1 -b .morn2
|
||||||
ln -s unix/Makefile Makefile
|
ln -s unix/Makefile Makefile
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -47,7 +51,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-7
|
* Thu Feb 10 2005 Ivana Varekova <varekova@redhat.com> 5.51-9
|
||||||
|
- fix the other problem with unpacking zipfiles containing symlinks
|
||||||
|
(bug #134073)
|
||||||
|
|
||||||
|
* Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-8
|
||||||
- fix segfault with unpacking of zipfiles containing dangling symlinks
|
- fix segfault with unpacking of zipfiles containing dangling symlinks
|
||||||
(bug #134073)
|
(bug #134073)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user