Rebuild for fc4/rawhide
This commit is contained in:
parent
2cbdc98935
commit
7c117f88e8
14
unzip-5.51-link-segv.patch
Normal file
14
unzip-5.51-link-segv.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -ur unzip-5.51/unix/unix.c unzip-5.51-lhh/unix/unix.c
|
||||||
|
--- unzip-5.51/unix/unix.c 2004-04-11 20:29:58.000000000 -0400
|
||||||
|
+++ unzip-5.51-lhh/unix/unix.c 2004-11-22 14:34:21.468981000 -0500
|
||||||
|
@@ -1052,7 +1052,9 @@
|
||||||
|
fclose(G.outfile);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
- fclose(G.outfile); /* close "link" file for good... */
|
||||||
|
+
|
||||||
|
+ if (G.outfile)
|
||||||
|
+ fclose(G.outfile); /* close "link" file for good... */
|
||||||
|
slnk_entry->target[ucsize] = '\0';
|
||||||
|
if (QCOND2)
|
||||||
|
Info(slide, 0, ((char *)slide, "-> %s ",
|
10
unzip.spec
10
unzip.spec
@ -1,12 +1,13 @@
|
|||||||
Summary: A utility for unpacking zip files.
|
Summary: A utility for unpacking zip files.
|
||||||
Name: unzip
|
Name: unzip
|
||||||
Version: 5.51
|
Version: 5.51
|
||||||
Release: 4
|
Release: 6
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip551.tar.gz
|
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip551.tar.gz
|
||||||
Patch0: unzip542-rpmoptflags.patch
|
Patch0: unzip542-rpmoptflags.patch
|
||||||
Patch1: unzip-5.51-near-4GB.patch
|
Patch1: unzip-5.51-near-4GB.patch
|
||||||
|
Patch2: unzip-5.51-link-segv.patch
|
||||||
URL: http://www.info-zip.org/pub/infozip/UnZip.html
|
URL: http://www.info-zip.org/pub/infozip/UnZip.html
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
@ -25,6 +26,7 @@ a zip archive.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
ln -s unix/Makefile Makefile
|
ln -s unix/Makefile Makefile
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -45,6 +47,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-6
|
||||||
|
- Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-5
|
||||||
|
- Fix segfault on extraction of symlinks
|
||||||
|
|
||||||
* Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
|
* Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
|
||||||
- Extend max file/archive size to 2^32-8193 (4294959103) bytes
|
- Extend max file/archive size to 2^32-8193 (4294959103) bytes
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user