Solve problem with symlink errors in archive with many files
This commit is contained in:
parent
8d0bd3ff76
commit
197087d9bc
17
unzip-6.0-symlink.patch
Normal file
17
unzip-6.0-symlink.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff --git a/process.c b/process.c
|
||||
index 1e9a1e1..905732b 100644
|
||||
--- a/process.c
|
||||
+++ b/process.c
|
||||
@@ -1751,6 +1751,12 @@ int process_cdir_file_hdr(__G) /* return PK-type error code */
|
||||
= (G.crec.general_purpose_bit_flag & (1 << 11)) == (1 << 11);
|
||||
#endif
|
||||
|
||||
+#ifdef SYMLINKS
|
||||
+ /* Initialize the symlink flag, may be set by the platform-specific
|
||||
+ mapattr function. */
|
||||
+ G.pInfo->symlink = 0;
|
||||
+#endif
|
||||
+
|
||||
return PK_COOL;
|
||||
|
||||
} /* end function process_cdir_file_hdr() */
|
@ -1,7 +1,7 @@
|
||||
Summary: A utility for unpacking zip files
|
||||
Name: unzip
|
||||
Version: 6.0
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
License: BSD
|
||||
Group: Applications/Archiving
|
||||
Source: http://downloads.sourceforge.net/infozip/unzip60.tar.gz
|
||||
@ -22,6 +22,8 @@ Patch6: unzip-6.0-manpage-fix.patch
|
||||
# This also resolves the license issue in that old function.
|
||||
# Original came from here: https://projects.parabolagnulinux.org/abslibre.git/plain/libre/unzip-libre/match.patch
|
||||
Patch7: unzip-6.0-fix-recmatch.patch
|
||||
# Update process.c
|
||||
Patch8: unzip-6.0-symlink.patch
|
||||
URL: http://www.info-zip.org/UnZip.html
|
||||
BuildRequires: bzip2-devel
|
||||
|
||||
@ -45,6 +47,7 @@ a zip archive.
|
||||
%patch5 -p1 -b .nostrip
|
||||
%patch6 -p1 -b .manpage-fix
|
||||
%patch7 -p1 -b .recmatch
|
||||
%patch8 -p1 -b .symlink
|
||||
|
||||
%build
|
||||
make -f unix/Makefile CF_NOOPT="-I. -DUNIX $RPM_OPT_FLAGS" generic_gcc %{?_smp_mflags}
|
||||
@ -60,6 +63,10 @@ make -f unix/Makefile prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Mon Oct 21 2013 Petr Stodulka <pstodulk@redhat.com> - 6.0.-12
|
||||
- Solve problem with symlink errors in archive with many files
|
||||
(#740012,#972427)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user