Fix FTBFS problem occasioned by _default_patch_fuzz = 0 in rawhide
This commit is contained in:
parent
66ee88be19
commit
ba9818e73f
@ -1,5 +1,42 @@
|
|||||||
--- unixODBC-2.2.11/sqp/sqpStoreDataType.c.lr 2005-10-15 23:11:50.000000000 +0200
|
diff -Naur unixODBC-2.2.12.orig/DriverManager/DriverManager.exp unixODBC-2.2.12/DriverManager/DriverManager.exp
|
||||||
+++ unixODBC-2.2.11/sqp/sqpStoreDataType.c 2005-10-15 23:12:12.000000000 +0200
|
--- unixODBC-2.2.12.orig/DriverManager/DriverManager.exp 2005-03-09 04:06:42.000000000 -0500
|
||||||
|
+++ unixODBC-2.2.12/DriverManager/DriverManager.exp 2008-07-28 20:50:14.000000000 -0400
|
||||||
|
@@ -153,6 +153,8 @@
|
||||||
|
SQLTablesA
|
||||||
|
SQLTransact
|
||||||
|
ODBCSharedTraceFlag
|
||||||
|
+dm_log_write
|
||||||
|
+__post_internal_error
|
||||||
|
uodbc_open_stats
|
||||||
|
uodbc_close_stats
|
||||||
|
uodbc_get_stats
|
||||||
|
diff -Naur unixODBC-2.2.12.orig/cur/Makefile.am unixODBC-2.2.12/cur/Makefile.am
|
||||||
|
--- unixODBC-2.2.12.orig/cur/Makefile.am 2005-10-18 13:07:31.000000000 -0400
|
||||||
|
+++ unixODBC-2.2.12/cur/Makefile.am 2008-07-28 20:50:14.000000000 -0400
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
|
||||||
|
libodbccr_la_LDFLAGS = \
|
||||||
|
-version-info @LIB_VERSION@ \
|
||||||
|
- -export-symbols @srcdir@/cur.exp -export-dynamic
|
||||||
|
+ -export-symbols @srcdir@/cur.exp -export-dynamic ../DriverManager/libodbc.la
|
||||||
|
|
||||||
|
libodbccr_la_SOURCES = \
|
||||||
|
SQLAllocHandle.c \
|
||||||
|
diff -Naur unixODBC-2.2.12.orig/cur/Makefile.in unixODBC-2.2.12/cur/Makefile.in
|
||||||
|
--- unixODBC-2.2.12.orig/cur/Makefile.in 2006-08-31 08:24:23.000000000 -0400
|
||||||
|
+++ unixODBC-2.2.12/cur/Makefile.in 2008-07-28 20:50:14.000000000 -0400
|
||||||
|
@@ -252,7 +252,7 @@
|
||||||
|
|
||||||
|
libodbccr_la_LDFLAGS = \
|
||||||
|
-version-info @LIB_VERSION@ \
|
||||||
|
- -export-symbols @srcdir@/cur.exp -export-dynamic
|
||||||
|
+ -export-symbols @srcdir@/cur.exp -export-dynamic ../DriverManager/libodbc.la
|
||||||
|
|
||||||
|
libodbccr_la_SOURCES = \
|
||||||
|
SQLAllocHandle.c \
|
||||||
|
diff -Naur unixODBC-2.2.12.orig/sqp/sqpStoreDataType.c unixODBC-2.2.12/sqp/sqpStoreDataType.c
|
||||||
|
--- unixODBC-2.2.12.orig/sqp/sqpStoreDataType.c 2004-07-26 04:34:47.000000000 -0400
|
||||||
|
+++ unixODBC-2.2.12/sqp/sqpStoreDataType.c 2008-07-28 20:50:14.000000000 -0400
|
||||||
@@ -8,6 +8,13 @@
|
@@ -8,6 +8,13 @@
|
||||||
|
|
||||||
#include "sqp.h"
|
#include "sqp.h"
|
||||||
@ -14,36 +51,3 @@
|
|||||||
|
|
||||||
void sqpStoreDataType( char *pszType, int nPrecision, int nScale )
|
void sqpStoreDataType( char *pszType, int nPrecision, int nScale )
|
||||||
{
|
{
|
||||||
--- unixODBC-2.2.11/cur/Makefile.am.lr 2005-10-15 23:47:18.000000000 +0200
|
|
||||||
+++ unixODBC-2.2.11/cur/Makefile.am 2005-10-15 23:47:35.000000000 +0200
|
|
||||||
@@ -9,7 +9,7 @@
|
|
||||||
|
|
||||||
libodbccr_la_LDFLAGS = \
|
|
||||||
-version-info @LIB_VERSION@ \
|
|
||||||
- -export-symbols @srcdir@/cur.exp -export-dynamic
|
|
||||||
+ -export-symbols @srcdir@/cur.exp -export-dynamic ../DriverManager/libodbc.la
|
|
||||||
|
|
||||||
# PAH - Redundant?
|
|
||||||
#libodbccr_la_DEPENDENCIES = \
|
|
||||||
--- unixODBC-2.2.11/cur/Makefile.in.lr 2005-10-15 23:31:03.000000000 +0200
|
|
||||||
+++ unixODBC-2.2.11/cur/Makefile.in 2005-10-15 23:31:50.000000000 +0200
|
|
||||||
@@ -255,7 +255,7 @@
|
|
||||||
|
|
||||||
libodbccr_la_LDFLAGS = \
|
|
||||||
-version-info @LIB_VERSION@ \
|
|
||||||
- -export-symbols @srcdir@/cur.exp -export-dynamic
|
|
||||||
+ -export-symbols @srcdir@/cur.exp -export-dynamic ../DriverManager/libodbc.la
|
|
||||||
|
|
||||||
|
|
||||||
# PAH - Redundant?
|
|
||||||
--- unixODBC-2.2.11/DriverManager/DriverManager.exp.lr 2005-10-16 00:41:59.000000000 +0200
|
|
||||||
+++ unixODBC-2.2.11/DriverManager/DriverManager.exp 2005-10-16 00:43:09.000000000 +0200
|
|
||||||
@@ -151,6 +151,8 @@
|
|
||||||
SQLTablesA
|
|
||||||
SQLTransact
|
|
||||||
ODBCSharedTraceFlag
|
|
||||||
+dm_log_write
|
|
||||||
+__post_internal_error
|
|
||||||
uodbc_open_stats
|
|
||||||
uodbc_close_stats
|
|
||||||
uodbc_get_stats
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A complete ODBC driver manager for Linux
|
Summary: A complete ODBC driver manager for Linux
|
||||||
Name: unixODBC
|
Name: unixODBC
|
||||||
Version: 2.2.12
|
Version: 2.2.12
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.unixODBC.org/
|
URL: http://www.unixODBC.org/
|
||||||
# Programs are GPL, libraries are LGPL, except News Server library is GPL.
|
# Programs are GPL, libraries are LGPL, except News Server library is GPL.
|
||||||
@ -174,6 +174,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 28 2008 Tom Lane <tgl@redhat.com> 2.2.12-9
|
||||||
|
- Fix build failure caused by new default patch fuzz = 0 policy in rawhide.
|
||||||
|
|
||||||
* Fri Jun 13 2008 Tom Lane <tgl@redhat.com> 2.2.12-8
|
* Fri Jun 13 2008 Tom Lane <tgl@redhat.com> 2.2.12-8
|
||||||
- Install icons in /usr/share/pixmaps, not /usr/share/icons as this package
|
- Install icons in /usr/share/pixmaps, not /usr/share/icons as this package
|
||||||
has historically done; the former is considered correct.
|
has historically done; the former is considered correct.
|
||||||
|
Loading…
Reference in New Issue
Block a user