Rebase to 2.3.11
This commit is contained in:
parent
a0604fc32e
commit
98f9f57a27
@ -1,9 +1,154 @@
|
|||||||
Set the major .so version to 2 for all unixODBC shared libraries, to reflect
|
Set the major .so version to 2 for all unixODBC shared libraries, to reflect
|
||||||
the incompatible ABI changes in 2.2.14.
|
the incompatible ABI changes in 2.2.14.
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/Drivers/MiniSQL/Makefile.am.soname unixODBC-2.3.3/Drivers/MiniSQL/Makefile.am
|
Note that we only patch 'Makefile.am' files and not 'Makefile.in' files,
|
||||||
--- unixODBC-2.3.3/Drivers/MiniSQL/Makefile.am.soname 2015-08-22 18:39:16.000000000 +0200
|
as we use 'autoconf' instead of the 'configure' setup tool
|
||||||
+++ unixODBC-2.3.3/Drivers/MiniSQL/Makefile.am 2015-08-25 12:27:47.005775376 +0200
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/MiniSQL/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/MiniSQL/Makefile.am.patched 2022-05-19 10:56:27.087060411 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcminiS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libodbcminiS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libodbcminiS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libodbcminiS_la_SOURCES = odbcminiS.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/PostgreSQL/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/PostgreSQL/Makefile.am.patched 2022-05-19 10:56:27.090060438 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcpsqlS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libodbcpsqlS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libodbcpsqlS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libodbcpsqlS_la_SOURCES = odbcpsqlS.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/esoob/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/esoob/Makefile.am.patched 2022-05-19 10:56:27.093060465 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libesoobS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libesoobS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libesoobS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libesoobS_la_SOURCES = esoobS.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/sapdb/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/sapdb/Makefile.am.patched 2022-05-19 10:56:27.096060492 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libsapdbS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libsapdbS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libsapdbS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libsapdbS_la_SOURCES = sapdb.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/Oracle/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/Oracle/Makefile.am.patched 2022-05-19 10:56:27.098060510 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = liboraodbcS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-liboraodbcS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+liboraodbcS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
liboraodbcS_la_SOURCES = oraodbcS.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/Mimer/Makefile.am 2021-03-02 14:50:37.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/Mimer/Makefile.am.patched 2022-05-19 10:56:27.100060528 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libmimerS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libmimerS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libmimerS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libmimerS_la_SOURCES = mimerS.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/MySQL/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/MySQL/Makefile.am.patched 2022-05-19 10:56:27.102060546 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcmyS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libodbcmyS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libodbcmyS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libodbcmyS_la_SOURCES = odbcmyS.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/txt/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/txt/Makefile.am.patched 2022-05-19 10:56:27.103060555 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbctxtS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libodbctxtS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libodbctxtS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libodbctxtS_la_SOURCES = drvcfg.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/drvcfg1/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/drvcfg1/Makefile.am.patched 2022-05-19 10:56:27.105060573 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcdrvcfg1S.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libodbcdrvcfg1S_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libodbcdrvcfg1S_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libodbcdrvcfg1S_la_SOURCES = drvcfg1.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/oplodbc/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/oplodbc/Makefile.am.patched 2022-05-19 10:56:27.107060592 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = liboplodbcS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-liboplodbcS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+liboplodbcS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
liboplodbcS_la_SOURCES = oplodbc.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/tds/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/tds/Makefile.am.patched 2022-05-19 10:56:27.108060601 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libtdsS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libtdsS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libtdsS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libtdsS_la_SOURCES = tdsS.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/drvcfg2/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/drvcfg2/Makefile.am.patched 2022-05-19 10:56:27.110060619 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcdrvcfg2S.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libodbcdrvcfg2S_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libodbcdrvcfg2S_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libodbcdrvcfg2S_la_SOURCES = drvcfg2.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/DRVConfig/nn/Makefile.am 2021-03-02 14:44:29.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/DRVConfig/nn/Makefile.am.patched 2022-05-19 10:56:27.112060637 +0200
|
||||||
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcnnS.la
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
||||||
|
|
||||||
|
-libodbcnnS_la_LDFLAGS = -module -no-undefined -version-info 1:0:0 -avoid-version -shared
|
||||||
|
+libodbcnnS_la_LDFLAGS = -module -no-undefined -version-info $(LIB_VERSION) -avoid-version -shared
|
||||||
|
|
||||||
|
libodbcnnS_la_SOURCES = drvcfg.c
|
||||||
|
|
||||||
|
--- unixODBC-2.3.11/Drivers/MiniSQL/Makefile.am 2018-01-02 11:48:19.000000000 +0100
|
||||||
|
+++ unixODBC-2.3.11/Drivers/MiniSQL/Makefile.am.patched 2022-05-19 10:56:27.114060655 +0200
|
||||||
@@ -193,6 +193,6 @@ EXTRA_DIST = \
|
@@ -193,6 +193,6 @@ EXTRA_DIST = \
|
||||||
_sqlFreeEnv.c \
|
_sqlFreeEnv.c \
|
||||||
_sqlFreeStmt.c
|
_sqlFreeStmt.c
|
||||||
@ -12,33 +157,8 @@ diff -up unixODBC-2.3.3/Drivers/MiniSQL/Makefile.am.soname unixODBC-2.3.3/Driver
|
|||||||
+libodbcmini_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) \
|
+libodbcmini_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) \
|
||||||
-L@msql_libraries@ -lmsql -module
|
-L@msql_libraries@ -lmsql -module
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/Drivers/nn/Makefile.am.soname unixODBC-2.3.3/Drivers/nn/Makefile.am
|
--- unixODBC-2.3.11/Drivers/template/Makefile.am 2022-05-02 16:52:53.000000000 +0200
|
||||||
--- unixODBC-2.3.3/Drivers/nn/Makefile.am.soname 2014-05-05 10:27:13.000000000 +0200
|
+++ unixODBC-2.3.11/Drivers/template/Makefile.am.patched 2022-05-19 10:56:27.116060673 +0200
|
||||||
+++ unixODBC-2.3.3/Drivers/nn/Makefile.am 2015-08-25 12:27:47.007775386 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libnn.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include -I.
|
|
||||||
|
|
||||||
-libnn_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libnn_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
EXTRA_DIST = \
|
|
||||||
nnconfig.h \
|
|
||||||
diff -up unixODBC-2.3.3/Drivers/Postgre7.1/Makefile.am.soname unixODBC-2.3.3/Drivers/Postgre7.1/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/Drivers/Postgre7.1/Makefile.am.soname 2014-05-05 10:27:13.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/Drivers/Postgre7.1/Makefile.am 2015-08-25 12:27:47.009775396 +0200
|
|
||||||
@@ -3,7 +3,7 @@ lib_LTLIBRARIES = libodbcpsql.la
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
libodbcpsql_la_LDFLAGS = \
|
|
||||||
- -version-info 2:0:0 \
|
|
||||||
+ -version-info $(LIB_VERSION) \
|
|
||||||
-no-undefined \
|
|
||||||
$(LIBSOCKET) $(LIBNSL) \
|
|
||||||
-export-dynamic \
|
|
||||||
diff -up unixODBC-2.3.3/Drivers/template/Makefile.am.soname unixODBC-2.3.3/Drivers/template/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/Drivers/template/Makefile.am.soname 2014-05-05 10:27:13.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/Drivers/template/Makefile.am 2015-08-25 12:27:47.012775410 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libtemplate.la
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libtemplate.la
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include -I. $(LTDLINCL)
|
AM_CPPFLAGS = -I@top_srcdir@/include -I. $(LTDLINCL)
|
||||||
@ -48,159 +168,14 @@ diff -up unixODBC-2.3.3/Drivers/template/Makefile.am.soname unixODBC-2.3.3/Drive
|
|||||||
|
|
||||||
EXTRA_DIST = \
|
EXTRA_DIST = \
|
||||||
driver.h \
|
driver.h \
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/drvcfg1/Makefile.am.soname unixODBC-2.3.3/DRVConfig/drvcfg1/Makefile.am
|
--- unixODBC-2.3.11/Drivers/nn/Makefile.am 2018-01-02 11:48:19.000000000 +0100
|
||||||
--- unixODBC-2.3.3/DRVConfig/drvcfg1/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
+++ unixODBC-2.3.11/Drivers/nn/Makefile.am.patched 2022-05-19 10:56:27.118060691 +0200
|
||||||
+++ unixODBC-2.3.3/DRVConfig/drvcfg1/Makefile.am 2015-08-25 12:27:47.014775420 +0200
|
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libnn.la
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcdrvcfg1S.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
AM_CPPFLAGS = -I@top_srcdir@/include -I.
|
||||||
|
|
||||||
-libodbcdrvcfg1S_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
-libnn_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
||||||
+libodbcdrvcfg1S_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
+libnn_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
||||||
|
|
||||||
libodbcdrvcfg1S_la_SOURCES = drvcfg1.c
|
EXTRA_DIST = \
|
||||||
|
nnconfig.h \
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/drvcfg2/Makefile.am.soname unixODBC-2.3.3/DRVConfig/drvcfg2/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/drvcfg2/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/drvcfg2/Makefile.am 2015-08-25 12:27:47.016775430 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcdrvcfg2S.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libodbcdrvcfg2S_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libodbcdrvcfg2S_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libodbcdrvcfg2S_la_SOURCES = drvcfg2.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/esoob/Makefile.am.soname unixODBC-2.3.3/DRVConfig/esoob/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/esoob/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/esoob/Makefile.am 2015-08-25 12:27:47.017775434 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libesoobS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libesoobS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libesoobS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libesoobS_la_SOURCES = esoobS.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/Mimer/Makefile.am.soname unixODBC-2.3.3/DRVConfig/Mimer/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/Mimer/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/Mimer/Makefile.am 2015-08-25 12:27:47.019775444 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libmimerS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libmimerS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libmimerS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libmimerS_la_SOURCES = mimerS.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/MiniSQL/Makefile.am.soname unixODBC-2.3.3/DRVConfig/MiniSQL/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/MiniSQL/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/MiniSQL/Makefile.am 2015-08-25 12:27:47.020775449 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcminiS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libodbcminiS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libodbcminiS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libodbcminiS_la_SOURCES = odbcminiS.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/MySQL/Makefile.am.soname unixODBC-2.3.3/DRVConfig/MySQL/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/MySQL/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/MySQL/Makefile.am 2015-08-25 12:27:47.023775464 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcmyS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libodbcmyS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libodbcmyS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libodbcmyS_la_SOURCES = odbcmyS.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/nn/Makefile.am.soname unixODBC-2.3.3/DRVConfig/nn/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/nn/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/nn/Makefile.am 2015-08-25 12:27:47.024775469 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcnnS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libodbcnnS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libodbcnnS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libodbcnnS_la_SOURCES = drvcfg.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/oplodbc/Makefile.am.soname unixODBC-2.3.3/DRVConfig/oplodbc/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/oplodbc/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/oplodbc/Makefile.am 2015-08-25 12:27:47.026775478 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = liboplodbcS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-liboplodbcS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+liboplodbcS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
liboplodbcS_la_SOURCES = oplodbc.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/Oracle/Makefile.am.soname unixODBC-2.3.3/DRVConfig/Oracle/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/Oracle/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/Oracle/Makefile.am 2015-08-25 12:27:47.027775483 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = liboraodbcS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-liboraodbcS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+liboraodbcS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
liboraodbcS_la_SOURCES = oraodbcS.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/PostgreSQL/Makefile.am.soname unixODBC-2.3.3/DRVConfig/PostgreSQL/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/PostgreSQL/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/PostgreSQL/Makefile.am 2015-08-25 12:27:47.029775493 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbcpsqlS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libodbcpsqlS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libodbcpsqlS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libodbcpsqlS_la_SOURCES = odbcpsqlS.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/sapdb/Makefile.am.soname unixODBC-2.3.3/DRVConfig/sapdb/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/sapdb/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/sapdb/Makefile.am 2015-08-25 12:27:47.031775503 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libsapdbS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libsapdbS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libsapdbS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libsapdbS_la_SOURCES = sapdb.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/tds/Makefile.am.soname unixODBC-2.3.3/DRVConfig/tds/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/tds/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/tds/Makefile.am 2015-08-25 12:27:47.032775507 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libtdsS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libtdsS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libtdsS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libtdsS_la_SOURCES = tdsS.c
|
|
||||||
|
|
||||||
diff -up unixODBC-2.3.3/DRVConfig/txt/Makefile.am.soname unixODBC-2.3.3/DRVConfig/txt/Makefile.am
|
|
||||||
--- unixODBC-2.3.3/DRVConfig/txt/Makefile.am.soname 2014-05-05 10:26:41.000000000 +0200
|
|
||||||
+++ unixODBC-2.3.3/DRVConfig/txt/Makefile.am 2015-08-25 12:27:47.034775517 +0200
|
|
||||||
@@ -2,7 +2,7 @@ lib_LTLIBRARIES = libodbctxtS.la
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I@top_srcdir@/include $(LTDLINCL)
|
|
||||||
|
|
||||||
-libodbctxtS_la_LDFLAGS = -no-undefined -version-info 1:0:0 -module
|
|
||||||
+libodbctxtS_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION) -module
|
|
||||||
|
|
||||||
libodbctxtS_la_SOURCES = drvcfg.c
|
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (unixODBC-2.3.9.tar.gz) = 6637eab751401522e0af775cb104cd07693b82927453a98e5af28e079f4b9f40e1cfab8cb36f509c46dced89b45244bc5ed1a3dda17ba5a52a844e8e82f187bb
|
SHA512 (unixODBC-2.3.11.tar.gz) = dddc32f90a7962e6988e1130a8093c6fb8b9ff532cad270d572250324aecbc739f45f9d8021d217313910bab25b08e69009b4f87456575535e93be1f46f5f13d
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A complete ODBC driver manager for Linux
|
Summary: A complete ODBC driver manager for Linux
|
||||||
Name: unixODBC
|
Name: unixODBC
|
||||||
Version: 2.3.9
|
Version: 2.3.11
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.unixODBC.org/
|
URL: http://www.unixODBC.org/
|
||||||
# Programs are GPL, libraries are LGPL, except News Server library is GPL.
|
# Programs are GPL, libraries are LGPL, except News Server library is GPL.
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
@ -67,7 +67,7 @@ make all
|
|||||||
%install
|
%install
|
||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
|
install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
|
||||||
%multilib_fix_c_header --file %{_includedir}/unixodbc_conf.h
|
%multilib_fix_c_header --file %{_includedir}/unixODBC/unixodbc_conf.h
|
||||||
|
|
||||||
# add some explanatory documentation
|
# add some explanatory documentation
|
||||||
cp %{SOURCE5} README.dist
|
cp %{SOURCE5} README.dist
|
||||||
@ -75,13 +75,8 @@ cp %{SOURCE5} README.dist
|
|||||||
# remove obsolete Postgres drivers from the package (but not the setup code)
|
# remove obsolete Postgres drivers from the package (but not the setup code)
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
|
rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
|
||||||
|
|
||||||
# make directory for unversioned plugins and create appropriate symlinks
|
# make directory for unversioned plugins
|
||||||
mkdir $RPM_BUILD_ROOT%{_libdir}/%{name}
|
mkdir $RPM_BUILD_ROOT%{_libdir}/%{name}
|
||||||
cd $RPM_BUILD_ROOT%{_libdir}/%{name}
|
|
||||||
ln -s ../libodbcpsqlS.so.2.0.0 libodbcpsqlS.so
|
|
||||||
ln -s ../libodbcmyS.so.2.0.0 libodbcmyS.so
|
|
||||||
ln -s ../libtdsS.so.2.0.0 libtdsS.so
|
|
||||||
cd -
|
|
||||||
|
|
||||||
# copy text driver documentation into main doc directory
|
# copy text driver documentation into main doc directory
|
||||||
# currently disabled because upstream no longer includes text driver
|
# currently disabled because upstream no longer includes text driver
|
||||||
@ -103,15 +98,6 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
|
|||||||
find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
|
find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
|
||||||
find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
|
find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
|
||||||
|
|
||||||
# move these to main package, they're often dlopened...
|
|
||||||
for lib in libodbcpsqlS.so libodbcmyS.so libtdsS.so
|
|
||||||
do
|
|
||||||
echo "%{_libdir}/%{name}/$lib" >> base-so-list
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/$lib
|
|
||||||
grep -v "/$lib$" devel-so-list > devel-so-list.x
|
|
||||||
mv -f devel-so-list.x devel-so-list
|
|
||||||
done
|
|
||||||
|
|
||||||
%files -f base-so-list
|
%files -f base-so-list
|
||||||
%doc README COPYING AUTHORS ChangeLog NEWS doc
|
%doc README COPYING AUTHORS ChangeLog NEWS doc
|
||||||
%doc README.dist
|
%doc README.dist
|
||||||
@ -129,6 +115,9 @@ done
|
|||||||
%_libdir/pkgconfig/*.pc
|
%_libdir/pkgconfig/*.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 16 2022 Michal Schorm <mschorm@redhat.com> - 2.3.11-1
|
||||||
|
- Rebase to 2.3.11
|
||||||
|
|
||||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.9-6
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.9-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user