- fix some unknown symbols
This commit is contained in:
parent
4b703de37d
commit
5fb088efaa
49
unixODBC-2.2.11-stricmp.patch
Normal file
49
unixODBC-2.2.11-stricmp.patch
Normal file
@ -0,0 +1,49 @@
|
||||
--- unixODBC-2.2.11/sqp/sqpStoreDataType.c.lr 2005-10-15 23:11:50.000000000 +0200
|
||||
+++ unixODBC-2.2.11/sqp/sqpStoreDataType.c 2005-10-15 23:12:12.000000000 +0200
|
||||
@@ -8,6 +8,13 @@
|
||||
|
||||
#include "sqp.h"
|
||||
#include <sqlext.h>
|
||||
+#ifndef WIN32
|
||||
+#ifndef HAVE_STRICMP
|
||||
+#define stricmp(s1,s2) strcasecmp(s1,s2)
|
||||
+#define strnicmp(s1,s2,n) strncasecmp(s1,s2,n)
|
||||
+#endif
|
||||
+#endif
|
||||
+
|
||||
|
||||
void sqpStoreDataType( char *pszType, int nPrecision, int nScale )
|
||||
{
|
||||
--- unixODBC-2.2.11/cur/Makefile.am.lr 2005-10-15 23:47:18.000000000 +0200
|
||||
+++ unixODBC-2.2.11/cur/Makefile.am 2005-10-15 23:47:35.000000000 +0200
|
||||
@@ -9,7 +9,7 @@
|
||||
|
||||
libodbccr_la_LDFLAGS = \
|
||||
-version-info @LIB_VERSION@ \
|
||||
- -export-symbols @srcdir@/cur.exp -export-dynamic
|
||||
+ -export-symbols @srcdir@/cur.exp -export-dynamic ../DriverManager/libodbc.la
|
||||
|
||||
# PAH - Redundant?
|
||||
#libodbccr_la_DEPENDENCIES = \
|
||||
--- unixODBC-2.2.11/cur/Makefile.in.lr 2005-10-15 23:31:03.000000000 +0200
|
||||
+++ unixODBC-2.2.11/cur/Makefile.in 2005-10-15 23:31:50.000000000 +0200
|
||||
@@ -255,7 +255,7 @@
|
||||
|
||||
libodbccr_la_LDFLAGS = \
|
||||
-version-info @LIB_VERSION@ \
|
||||
- -export-symbols @srcdir@/cur.exp -export-dynamic
|
||||
+ -export-symbols @srcdir@/cur.exp -export-dynamic ../DriverManager/libodbc.la
|
||||
|
||||
|
||||
# PAH - Redundant?
|
||||
--- unixODBC-2.2.11/DriverManager/DriverManager.exp.lr 2005-10-16 00:41:59.000000000 +0200
|
||||
+++ unixODBC-2.2.11/DriverManager/DriverManager.exp 2005-10-16 00:43:09.000000000 +0200
|
||||
@@ -151,6 +151,8 @@
|
||||
SQLTablesA
|
||||
SQLTransact
|
||||
ODBCSharedTraceFlag
|
||||
+dm_log_write
|
||||
+__post_internal_error
|
||||
uodbc_open_stats
|
||||
uodbc_close_stats
|
||||
uodbc_get_stats
|
@ -1,7 +1,7 @@
|
||||
Summary: A complete ODBC driver manager for Linux.
|
||||
Name: unixODBC
|
||||
Version: 2.2.11
|
||||
Release: 3
|
||||
Release: 4
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
|
||||
@ -12,6 +12,7 @@ Patch1: depcomp.patch
|
||||
Patch3: unixODBC-2.2.11-symbols.patch
|
||||
Patch4: parserupdate.patch
|
||||
Patch5: nortldglobal.patch
|
||||
Patch6: unixODBC-2.2.11-stricmp.patch
|
||||
URL: http://www.unixODBC.org/
|
||||
Conflicts: iodbc
|
||||
BuildPrereq: kdelibs-devel qt-devel libmng-devel XFree86-devel automake autoconf libtool
|
||||
@ -49,6 +50,7 @@ This package contains components for the ODBCConfig and DataManager
|
||||
%patch1 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
|
||||
# 2.2.8 includes a libtool that is too old for some of our architectures.
|
||||
# Blow it away and replace with build system's libtool. (We intend to use
|
||||
@ -168,6 +170,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Sun Oct 16 2005 Florian La Roche <laroche@redhat.com>
|
||||
- link against dependent libs
|
||||
- fix some bugs to resolve unknown symbols ;-(
|
||||
|
||||
* Thu Sep 29 2005 Tom Lane <tgl@redhat.com> 2.2.11-3
|
||||
- Force update of yac.h because the copy in the distributed tarball does not
|
||||
match bison 2.0's numbering of symbols (bz #162676)
|
||||
|
Loading…
Reference in New Issue
Block a user