Added manual pages for iusql, dltest, odbc_config
This commit is contained in:
parent
d66da83e74
commit
1a1c1c22ae
52
dltest.1
Normal file
52
dltest.1
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
.TH dltest 1 "Thu 13 Feb 2014" "version 2.3.2" "UnixODBC manual pages"
|
||||||
|
.SH NAME
|
||||||
|
dltest \- A simple library symbol test
|
||||||
|
|
||||||
|
.SH SYNOPSIS
|
||||||
|
.B dltest
|
||||||
|
.R [
|
||||||
|
.I library symbol
|
||||||
|
.R ]
|
||||||
|
|
||||||
|
.SH DESCRIPTION
|
||||||
|
.B dltest
|
||||||
|
is simple test of occurence of the
|
||||||
|
.I symbol
|
||||||
|
in the
|
||||||
|
.IR library .
|
||||||
|
The
|
||||||
|
.I library
|
||||||
|
must be a full (with path) file name of the shared object, in which the search for
|
||||||
|
.I symbol
|
||||||
|
should be performed.
|
||||||
|
|
||||||
|
Without any parameters, dltest print short help message.
|
||||||
|
|
||||||
|
.SH EXAMPLES
|
||||||
|
To determine if the symbol
|
||||||
|
.B printf
|
||||||
|
is found in the
|
||||||
|
.IR libc-2\.18\.so :
|
||||||
|
|
||||||
|
.RS
|
||||||
|
$ dltest /usr/lib/libc-2.18.so printf
|
||||||
|
.RE
|
||||||
|
|
||||||
|
.SH AUTHORS
|
||||||
|
The authors of unixODBC are
|
||||||
|
.MT pharvey@codebydesign.com
|
||||||
|
Peter Harvey
|
||||||
|
.ME
|
||||||
|
and
|
||||||
|
.MT nick@lurcher.org
|
||||||
|
Nick Gorham
|
||||||
|
.ME .
|
||||||
|
For the full list of contributors see the
|
||||||
|
.I AUTHORS
|
||||||
|
file.
|
||||||
|
|
||||||
|
.SH COPYRIGHT
|
||||||
|
unixODBC is licensed under the GNU Lesser General Public License. For details
|
||||||
|
about the license, see the
|
||||||
|
.I COPYING
|
||||||
|
file.
|
117
odbc_config.1
Normal file
117
odbc_config.1
Normal file
@ -0,0 +1,117 @@
|
|||||||
|
.TH odbc_config 1 "Thu 13 Feb 2014" "version 2.3.2" "UnixODBC manual pages"
|
||||||
|
|
||||||
|
.SH NAME
|
||||||
|
odbc_config \- get compile options for compiling unixODBC client
|
||||||
|
|
||||||
|
.SH SYNOPSIS
|
||||||
|
.SY odbc_config
|
||||||
|
.OP \-\-prefix
|
||||||
|
.OP \-\-exec-prefix
|
||||||
|
.OP \-\-include-prefix
|
||||||
|
.OP \-\-lib-prefix
|
||||||
|
.OP \-\-bin-prefix
|
||||||
|
.OP \-\-version
|
||||||
|
.OP \-\-libs
|
||||||
|
.OP \-\-static-libs
|
||||||
|
.OP \-\-libtool-libs
|
||||||
|
.OP \-\-cflags
|
||||||
|
.OP \-\-odbcversion
|
||||||
|
.OP \-\-odbcini
|
||||||
|
.OP \-\-odbcinstini
|
||||||
|
.OP \-\-header
|
||||||
|
.OP \-\-ulen
|
||||||
|
.YS
|
||||||
|
|
||||||
|
.SH DESCRIPTION
|
||||||
|
.B odbc_config
|
||||||
|
provides built-in options, specified at build time of the unixODBC suite, which
|
||||||
|
are useful for building unixODBC clients and similar programs.
|
||||||
|
|
||||||
|
.SH OPTIONS
|
||||||
|
.B
|
||||||
|
.IP \-\-prefix
|
||||||
|
Prefix for architecture-independent file tree.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-exec-prefix
|
||||||
|
Prefix for architecture-dependent file tree.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-include-prefix
|
||||||
|
Directory with C header files for unixODBC.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-lib-prefix
|
||||||
|
Directory with object code (.so) libraries.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-bin-prefix
|
||||||
|
Location of user executables.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-version
|
||||||
|
unixODBC version.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-libs
|
||||||
|
Compiler flags for linking dynamic libraries.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-static-libs
|
||||||
|
Absolute file name of static unixODBC library.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-libtool-libs
|
||||||
|
Absolute file name of libtool unixODBC library.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-cflags
|
||||||
|
Compiler flags to find include files and critical compiler flags and defines used
|
||||||
|
when compiling the libodbc library.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-odbcversion
|
||||||
|
Version of the ODBC specification used by the unixODBC.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-odbcini
|
||||||
|
Absolute file name of the system-wide DSN configuration file
|
||||||
|
.IR odbc.ini .
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-odbcinstini
|
||||||
|
Absolute file name of the driver configuration file
|
||||||
|
.IR odbcinst.ini .
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-header
|
||||||
|
Definitions of used C preprocessor constants. It is suitable to be piped into
|
||||||
|
C header file.
|
||||||
|
|
||||||
|
.B
|
||||||
|
.IP \-\-ulen
|
||||||
|
Compiler flag for defining
|
||||||
|
.IR SIZEOF_SQLULEN .
|
||||||
|
|
||||||
|
.SH SEE ALSO
|
||||||
|
.BR odbcinst.ini (5),
|
||||||
|
.BR odbc.ini (5)
|
||||||
|
|
||||||
|
.SH AUTHORS
|
||||||
|
The authors of unixODBC are
|
||||||
|
.MT pharvey@codebydesign.com
|
||||||
|
Peter Harvey
|
||||||
|
.ME
|
||||||
|
and
|
||||||
|
.MT nick@lurcher.org
|
||||||
|
Nick Gorham
|
||||||
|
.ME .
|
||||||
|
For the full list of contributors see the
|
||||||
|
.I AUTHORS
|
||||||
|
file.
|
||||||
|
|
||||||
|
.SH COPYRIGHT
|
||||||
|
unixODBC is licensed under the GNU Lesser General Public License. For details
|
||||||
|
about the license, see the
|
||||||
|
.I COPYING
|
||||||
|
file.
|
22
unixODBC-isql.1.patch
Normal file
22
unixODBC-isql.1.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- unixODBC-2.3.2/man/isql.1 2013-07-04 15:32:06.000000000 +0200
|
||||||
|
+++ unixODBC-2.3.2/man/isql.1.new 2014-02-18 10:06:43.913129715 +0100
|
||||||
|
@@ -1,8 +1,7 @@
|
||||||
|
-\" vim:language en_US.UTF-8:
|
||||||
|
.TH isql 1 "Tue 25 Jun 2013" "version 2.3.2" "UnixODBC manual pages"
|
||||||
|
|
||||||
|
.SH NAME
|
||||||
|
-isql - unixODBC command-line interactive SQL tool
|
||||||
|
+isql, iusql \- unixODBC command-line interactive SQL tool
|
||||||
|
|
||||||
|
.SH SYNOPSIS
|
||||||
|
\fBisql\fR \fIDSN\fR [\fIUSER\fR [\fIPASSWORD\fR]] [\fIoptions\fR]
|
||||||
|
@@ -13,6 +12,9 @@
|
||||||
|
or interactively. It has some interesting options such as an option to generate
|
||||||
|
output wrapped in an HTML table.
|
||||||
|
|
||||||
|
+.B iusql
|
||||||
|
+is the same tool with built-in Unicode support.
|
||||||
|
+
|
||||||
|
.SH ARGUMENTS
|
||||||
|
|
||||||
|
.IP \fBDSN\fR
|
@ -1,63 +0,0 @@
|
|||||||
diff -urN unixODBC-2.3.2.old/man/Makefile.am unixODBC-2.3.2/man/Makefile.am
|
|
||||||
--- unixODBC-2.3.2.old/man/Makefile.am 2013-10-24 12:01:31.188624319 +0200
|
|
||||||
+++ unixODBC-2.3.2/man/Makefile.am 2013-10-24 12:02:41.306813429 +0200
|
|
||||||
@@ -1,2 +1,2 @@
|
|
||||||
-dist_man_MANS = isql.1 odbc.ini.5 odbcinst.1 odbcinst.ini.5
|
|
||||||
+dist_man_MANS = isql.1 odbc.ini.5 odbcinst.1 odbcinst.ini.5 unixODBC.7
|
|
||||||
|
|
||||||
diff -urN unixODBC-2.3.2.old/man/unixODBC.7 unixODBC-2.3.2/man/unixODBC.7
|
|
||||||
--- unixODBC-2.3.2.old/man/unixODBC.7 1970-01-01 01:00:00.000000000 +0100
|
|
||||||
+++ unixODBC-2.3.2/man/unixODBC.7 2013-10-24 12:02:07.643722514 +0200
|
|
||||||
@@ -0,0 +1,52 @@
|
|
||||||
+.TH unixODBC 7 "Tue 22. Oct 2013" "version 2.3.2" "unixODBC manual pages"
|
|
||||||
+
|
|
||||||
+.SH NAME
|
|
||||||
+unixODBC \- An ODBC implementation for Unix
|
|
||||||
+
|
|
||||||
+.SH DESCRIPTION
|
|
||||||
+ODBC is an open specification for providing application developers with a
|
|
||||||
+predictable API with which to access Data Sources. Data Sources include SQL
|
|
||||||
+Servers and any Data Source with an ODBC Driver.
|
|
||||||
+
|
|
||||||
+The unixODBC Project goals are to develop and promote unixODBC to be the
|
|
||||||
+definitive standard for ODBC on non MS Windows platforms.
|
|
||||||
+
|
|
||||||
+.SH ENVIRONMENT VARIABLES
|
|
||||||
+
|
|
||||||
+.IP \fBODBCSYSINI
|
|
||||||
+Overloads path to unixODBC configuration files. By default equals to '/etc'.
|
|
||||||
+
|
|
||||||
+.IP \fBODBCINSTINI
|
|
||||||
+Overloads the name of the drivers configuration file. It is relative to
|
|
||||||
+\fBODBCSYSINI\fR and by default set to 'odbcinst.ini'.
|
|
||||||
+
|
|
||||||
+.IP \fBODBCINSTUI
|
|
||||||
+Overloads the library name for UI. The final name that is searched for is
|
|
||||||
+evaluated as "lib$ODBCINSTUI". By default it is set to 'odbcinstQ4', so
|
|
||||||
+the resulting library name is 'libodbcinstQ4'.
|
|
||||||
+
|
|
||||||
+.IP \fBODBCSEARCH
|
|
||||||
+Overloads the configuration mode and determines where to look for configuration
|
|
||||||
+files. Must be set to one of ODBC_SYSTEM_DSN, ODBC_USER_DSN or ODBC_BOTH_DSN
|
|
||||||
+(the last one is the default value).
|
|
||||||
+
|
|
||||||
+.IP \fBODBCINI
|
|
||||||
+Overloads the path to user configuration file. By default it is set
|
|
||||||
+to "~/.odbc.ini".
|
|
||||||
+
|
|
||||||
+.SH SEE ALSO
|
|
||||||
+.BR isql (1),
|
|
||||||
+.BR odbcinst (1),
|
|
||||||
+.BR odbc.ini (5),
|
|
||||||
+.BR odbcinst.ini (5)
|
|
||||||
+
|
|
||||||
+.SH AUTHORS
|
|
||||||
+
|
|
||||||
+The authors of unixODBC are Peter Harvey <\fIpharvey@codebydesign.com\fR> and
|
|
||||||
+Nick Gorham <\fInick@easysoft.com\fR>. For the full list of contributors see the
|
|
||||||
+AUTHORS file.
|
|
||||||
+
|
|
||||||
+.SH COPYRIGHT
|
|
||||||
+
|
|
||||||
+unixODBC is licensed under the GNU Lesser General Public License. For details
|
|
||||||
+about the license, see the COPYING file.
|
|
52
unixODBC.7
Normal file
52
unixODBC.7
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
.TH unixODBC 7 "Tue 22. Oct 2013" "version 2.3.2" "unixODBC manual pages"
|
||||||
|
|
||||||
|
.SH NAME
|
||||||
|
unixODBC \- An ODBC implementation for Unix
|
||||||
|
|
||||||
|
.SH DESCRIPTION
|
||||||
|
ODBC is an open specification for providing application developers with a
|
||||||
|
predictable API with which to access Data Sources. Data Sources include SQL
|
||||||
|
Servers and any Data Source with an ODBC Driver.
|
||||||
|
|
||||||
|
The unixODBC Project goals are to develop and promote unixODBC to be the
|
||||||
|
definitive standard for ODBC on non MS Windows platforms.
|
||||||
|
|
||||||
|
.SH ENVIRONMENT VARIABLES
|
||||||
|
|
||||||
|
.IP \fBODBCSYSINI
|
||||||
|
Overloads path to unixODBC configuration files. By default equals to '/etc'.
|
||||||
|
|
||||||
|
.IP \fBODBCINSTINI
|
||||||
|
Overloads the name of the drivers configuration file. It is relative to
|
||||||
|
\fBODBCSYSINI\fR and by default set to 'odbcinst.ini'.
|
||||||
|
|
||||||
|
.IP \fBODBCINSTUI
|
||||||
|
Overloads the library name for UI. The final name that is searched for is
|
||||||
|
evaluated as "lib$ODBCINSTUI". By default it is set to 'odbcinstQ4', so
|
||||||
|
the resulting library name is 'libodbcinstQ4'.
|
||||||
|
|
||||||
|
.IP \fBODBCSEARCH
|
||||||
|
Overloads the configuration mode and determines where to look for configuration
|
||||||
|
files. Must be set to one of ODBC_SYSTEM_DSN, ODBC_USER_DSN or ODBC_BOTH_DSN
|
||||||
|
(the last one is the default value).
|
||||||
|
|
||||||
|
.IP \fBODBCINI
|
||||||
|
Overloads the path to user configuration file. By default it is set
|
||||||
|
to "~/.odbc.ini".
|
||||||
|
|
||||||
|
.SH SEE ALSO
|
||||||
|
.BR isql (1),
|
||||||
|
.BR odbcinst (1),
|
||||||
|
.BR odbc.ini (5),
|
||||||
|
.BR odbcinst.ini (5)
|
||||||
|
|
||||||
|
.SH AUTHORS
|
||||||
|
|
||||||
|
The authors of unixODBC are Peter Harvey <\fIpharvey@codebydesign.com\fR> and
|
||||||
|
Nick Gorham <\fInick@easysoft.com\fR>. For the full list of contributors see the
|
||||||
|
AUTHORS file.
|
||||||
|
|
||||||
|
.SH COPYRIGHT
|
||||||
|
|
||||||
|
unixODBC is licensed under the GNU Lesser General Public License. For details
|
||||||
|
about the license, see the COPYING file.
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A complete ODBC driver manager for Linux
|
Summary: A complete ODBC driver manager for Linux
|
||||||
Name: unixODBC
|
Name: unixODBC
|
||||||
Version: 2.3.2
|
Version: 2.3.2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.unixODBC.org/
|
URL: http://www.unixODBC.org/
|
||||||
# Programs are GPL, libraries are LGPL, except News Server library is GPL.
|
# Programs are GPL, libraries are LGPL, except News Server library is GPL.
|
||||||
@ -11,12 +11,16 @@ Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
|
|||||||
Source1: odbcinst.ini
|
Source1: odbcinst.ini
|
||||||
Source4: conffile.h
|
Source4: conffile.h
|
||||||
Source5: README.dist
|
Source5: README.dist
|
||||||
|
Source6: iusql.1
|
||||||
|
Source7: dltest.1
|
||||||
|
Source8: odbc_config.1
|
||||||
|
Source9: unixODBC.7
|
||||||
|
|
||||||
Patch1: depcomp.patch
|
Patch1: depcomp.patch
|
||||||
Patch6: export-symbols.patch
|
Patch6: export-symbols.patch
|
||||||
Patch8: so-version-bump.patch
|
Patch8: so-version-bump.patch
|
||||||
Patch9: keep-typedefs.patch
|
Patch9: keep-typedefs.patch
|
||||||
Patch10: unixODBC-man.patch
|
Patch10: unixODBC-isql.1.patch
|
||||||
|
|
||||||
Conflicts: iodbc
|
Conflicts: iodbc
|
||||||
|
|
||||||
@ -125,6 +129,12 @@ do
|
|||||||
mv -f devel-so-list.x devel-so-list
|
mv -f devel-so-list.x devel-so-list
|
||||||
done
|
done
|
||||||
|
|
||||||
|
# install man pages that are not part of the upstream yet
|
||||||
|
install -Dm644 %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/man1/iusql.1
|
||||||
|
install -Dm644 %{SOURCE7} $RPM_BUILD_ROOT%{_mandir}/man1/dltest.1
|
||||||
|
install -Dm644 %{SOURCE8} $RPM_BUILD_ROOT%{_mandir}/man1/odbc_config.1
|
||||||
|
install -Dm644 %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/man7/unixODBC.7
|
||||||
|
|
||||||
%files -f base-so-list
|
%files -f base-so-list
|
||||||
%doc README COPYING AUTHORS ChangeLog NEWS doc
|
%doc README COPYING AUTHORS ChangeLog NEWS doc
|
||||||
%doc README.dist
|
%doc README.dist
|
||||||
@ -144,6 +154,9 @@ done
|
|||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 18 2014 Jan Stanek <jstanek@redhat.com> - 2.3.2-4
|
||||||
|
- Added manual pages for iusql, dltest, odbc_config
|
||||||
|
|
||||||
* Fri Dec 06 2013 Jan Stanek <jstanek@redhat.com> - 2.3.2-3
|
* Fri Dec 06 2013 Jan Stanek <jstanek@redhat.com> - 2.3.2-3
|
||||||
- Renamed README.fedora to README.dist
|
- Renamed README.fedora to README.dist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user