b49a5b4c60
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/units#859df262f39231f07c782347346a5935507ef64d
48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
From 06a4ba00e8e4188486fa962dbccbfa1e6afe2cf2 Mon Sep 17 00:00:00 2001
|
|
From: Kamil Dudka <kdudka@redhat.com>
|
|
Date: Wed, 8 Aug 2018 18:08:34 +0200
|
|
Subject: [PATCH] Makefile.in: do not update currency.units from network
|
|
|
|
Builds of packages are supposed to be reproducible.
|
|
---
|
|
Makefile.in | 9 +--------
|
|
1 file changed, 1 insertion(+), 8 deletions(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 70e2e10..7c1ee5b 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -61,8 +61,6 @@ CFLAGS = @CFLAGS@
|
|
CPPFLAGS = @CPPFLAGS@
|
|
OBJECTS = units.@OBJEXT@ parse.tab.@OBJEXT@ getopt.@OBJEXT@ getopt1.@OBJEXT@ @STRFUNC@
|
|
|
|
-.PHONY: currency-units-update
|
|
-
|
|
.SUFFIXES:
|
|
.SUFFIXES: .c .@OBJEXT@ .rc .res .texinfo .pdf
|
|
|
|
@@ -110,7 +108,7 @@ units_cur_inst: units_cur
|
|
-e "s@/usr/bin/python@$(PYTHON)@" \
|
|
$(srcdir)/units_cur > units_cur_inst
|
|
|
|
-install-support: definitions.units units_cur_inst currency-units-update
|
|
+install-support: definitions.units units_cur_inst
|
|
$(MKDIR_P) $(DESTDIR)@UDAT@ $(DESTDIR)$(bindir) $(DESTDIR)@CDAT@
|
|
$(INSTALL_DATA) $(srcdir)/definitions.units $(DESTDIR)@UDAT@definitions.units
|
|
-rm -f $(DESTDIR)@UDAT@currency.units
|
|
@@ -207,11 +205,6 @@ texclean:
|
|
-rm -f units.log UnitsMKS.log UnitsWin.log \
|
|
*.aux *.cp *.fn *.ky *.op *.pg *.toc *.tp *.vr
|
|
|
|
-currency-units-update:
|
|
- @echo "Trying to update currency.units (will use existing file if this fails)"
|
|
- -$(srcdir)/units_cur currency.units
|
|
- if [ ! -s currency.units ]; then cp $(srcdir)/currency.units currency.units;fi
|
|
-
|
|
sig:
|
|
echo units-`sed -n -e '/\#.*VERSION/s/.*"\(.*\)"/\1/gp' \
|
|
$(srcdir)/units.c`.tar.gz > distname
|
|
--
|
|
2.17.1
|
|
|