new upstream release - 2.11
This commit is contained in:
parent
b4cef9b392
commit
4cca982792
2
sources
2
sources
@ -1 +1 @@
|
|||||||
08dc084526a879dd04b64ef46db2b80d units-2.10.tar.gz
|
1d83f4e68135495aa9267b848de78dc5 units-2.11.tar.gz
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
From 767f49f2d3e6ded0f2e01563fcf2d272aa6a7141 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
Date: Mon, 31 Mar 2014 14:38:57 +0200
|
|
||||||
Subject: [PATCH] units_cur2: encode utf-8 for sys.stdout, too
|
|
||||||
|
|
||||||
Otherwise, the script ends up with the following error:
|
|
||||||
|
|
||||||
$ python2 ./units_cur2 - | cat
|
|
||||||
./units_cur2:53: RuntimeWarning: Argument <type 'str'> is not an unicode object. Passing an encoded string will likely have unexpected results.
|
|
||||||
ascii = unidecode(names[i])
|
|
||||||
Traceback (most recent call last):
|
|
||||||
File "./units_cur2", line 114, in <module>
|
|
||||||
outfile.write(outstr.replace('\n',os.linesep))
|
|
||||||
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 41: ordinal not in range(128)
|
|
||||||
---
|
|
||||||
units_cur2 | 3 ++-
|
|
||||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/units_cur2 b/units_cur2
|
|
||||||
index 7d4e8f5..d810be5 100755
|
|
||||||
--- a/units_cur2
|
|
||||||
+++ b/units_cur2
|
|
||||||
@@ -104,7 +104,8 @@ for metal in metals:
|
|
||||||
|
|
||||||
try:
|
|
||||||
if outfile == '-':
|
|
||||||
- outfile = sys.stdout
|
|
||||||
+ info = codecs.lookup('utf8')
|
|
||||||
+ outfile = codecs.StreamReaderWriter(sys.stdout, info.streamreader, info.streamwriter)
|
|
||||||
else:
|
|
||||||
outfile = codecs.open(outfile,'w','utf8')
|
|
||||||
except IOError, exc:
|
|
||||||
--
|
|
||||||
1.7.1
|
|
||||||
|
|
Binary file not shown.
BIN
units-2.11.tar.gz.sig
Normal file
BIN
units-2.11.tar.gz.sig
Normal file
Binary file not shown.
10
units.spec
10
units.spec
@ -1,9 +1,8 @@
|
|||||||
Summary: A utility for converting amounts from one unit to another
|
Summary: A utility for converting amounts from one unit to another
|
||||||
Name: units
|
Name: units
|
||||||
Version: 2.10
|
Version: 2.11
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Source: ftp://ftp.gnu.org/gnu/units/%{name}-%{version}.tar.gz
|
Source: ftp://ftp.gnu.org/gnu/units/%{name}-%{version}.tar.gz
|
||||||
Patch0: units-2.10-bz1082335.patch
|
|
||||||
URL: http://www.gnu.org/software/units/units.html
|
URL: http://www.gnu.org/software/units/units.html
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
@ -24,8 +23,6 @@ well as conversions such as Fahrenheit to Celsius.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
touch units_cur3
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -60,6 +57,9 @@ fi
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 03 2014 Kamil Dudka <kdudka@redhat.com> - 2.11-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Mon Mar 31 2014 Kamil Dudka <kdudka@redhat.com> - 2.10-2
|
* Mon Mar 31 2014 Kamil Dudka <kdudka@redhat.com> - 2.10-2
|
||||||
- require python-unidecode used by the units_cur script
|
- require python-unidecode used by the units_cur script
|
||||||
- improve utf-8 support in the units_cur script
|
- improve utf-8 support in the units_cur script
|
||||||
|
Loading…
Reference in New Issue
Block a user