- Added missing glob patch to cvs
- Place python macros within the %with_python check
This commit is contained in:
parent
41fa06700a
commit
b51bd8aa76
13
unbound-1.2-glob.patch
Normal file
13
unbound-1.2-glob.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -Naur unbound-1.2.0/validator/val_anchor.c unbound-1.2.0.new/validator/val_anchor.c
|
||||||
|
--- unbound-1.2.0/validator/val_anchor.c 2009-01-07 07:24:34.000000000 -0500
|
||||||
|
+++ unbound-1.2.0.new/validator/val_anchor.c 2009-01-20 17:31:43.000000000 -0500
|
||||||
|
@@ -718,7 +718,8 @@
|
||||||
|
log_err("wildcard trusted-keys-file %s: expansion "
|
||||||
|
"failed (%s)", pat, strerror(errno));
|
||||||
|
}
|
||||||
|
- return 0;
|
||||||
|
+ /* ignore globs that yield no files */
|
||||||
|
+ return 1;
|
||||||
|
}
|
||||||
|
/* process files found, if any */
|
||||||
|
for(i=0; i<(size_t)g.gl_pathc; i++) {
|
13
unbound.spec
13
unbound.spec
@ -1,12 +1,15 @@
|
|||||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
|
||||||
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
|
||||||
# not ready yet
|
# not ready yet
|
||||||
%{?!with_python: %define with_python 0}
|
%{?!with_python: %define with_python 0}
|
||||||
|
|
||||||
|
%if %{with_python}
|
||||||
|
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
|
%endif
|
||||||
|
|
||||||
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
||||||
Name: unbound
|
Name: unbound
|
||||||
Version: 1.3.0
|
Version: 1.3.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: http://www.nlnetlabs.nl/unbound/
|
Url: http://www.nlnetlabs.nl/unbound/
|
||||||
Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
|
Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
|
||||||
@ -190,6 +193,10 @@ fi
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
|
||||||
|
- Added missing glob patch to cvs
|
||||||
|
- Place python macros within the %%with_python check
|
||||||
|
|
||||||
* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
|
* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
|
||||||
- Updated to 1.3.0
|
- Updated to 1.3.0
|
||||||
- Added unbound-python sub package. disabled for now
|
- Added unbound-python sub package. disabled for now
|
||||||
|
Loading…
Reference in New Issue
Block a user