Update to 1.12.0
- DNS flag day 2020 applied - DNS over HTTPS support - EDNS client tag support Upstream changelog: https://nlnetlabs.nl/projects/unbound/download/#unbound-1-12-0
This commit is contained in:
parent
9bf72f2b97
commit
9b40e98f88
2
.gitignore
vendored
2
.gitignore
vendored
@ -59,3 +59,5 @@ unbound-1.4.5.tar.gz
|
||||
/unbound-1.10.0.tar.gz.asc
|
||||
/unbound-1.10.1.tar.gz
|
||||
/unbound-1.10.1.tar.gz.asc
|
||||
/unbound-1.12.0.tar.gz
|
||||
/unbound-1.12.0.tar.gz.asc
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (unbound-1.10.1.tar.gz) = d07f3ac0e751c17a3ff7d99518c22529cf6856861218564a2ca073422905525cb9ddaf76c9600187946fadb7324343bcd85c34ff06bd322e0ea621a2d258bb85
|
||||
SHA512 (unbound-1.10.1.tar.gz.asc) = 95d32b4ebfac501a1ae481c9211a88f7ad115e51a470794c6273bea7fedff62cef71445a4110b686938657b9450502bd5d47935e4552d3a9fc740b1348d6d991
|
||||
SHA512 (unbound-1.12.0.tar.gz) = 90d99bc65e9ba62e50a7809dbf1e98889d0fc9fd50cf3cc99b726c67bcaeda0c2bc176d09f84771adb9796833b595591462f96e949d6969a47d6898d8fae3479
|
||||
SHA512 (unbound-1.12.0.tar.gz.asc) = b9db74bde4cd2ecbd9ba04468716135f4a45b437f17e92564f0e595e5e3462e955808aa1f0dea17a9a6fd1403c32e4eff7815f22e630229db10f50080c9a85a3
|
||||
|
@ -1,74 +0,0 @@
|
||||
--- a/services/authzone.c 2020-04-16 13:01:10.550618034 +0200
|
||||
+++ b/services/authzone.c 2020-04-16 13:07:04.624476160 +0200
|
||||
@@ -5331,7 +5331,7 @@
|
||||
log_assert(xfr->task_transfer);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_transfer->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return; /* stop on quit */
|
||||
}
|
||||
@@ -5770,7 +5770,7 @@
|
||||
log_assert(xfr->task_transfer);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_transfer->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return; /* stop on quit */
|
||||
}
|
||||
@@ -5812,7 +5812,7 @@
|
||||
log_assert(xfr->task_transfer);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_transfer->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return 0; /* stop on quit */
|
||||
}
|
||||
@@ -5893,7 +5893,7 @@
|
||||
log_assert(xfr->task_transfer);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_transfer->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return 0; /* stop on quit */
|
||||
}
|
||||
@@ -6107,7 +6107,7 @@
|
||||
log_assert(xfr->task_probe);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_probe->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return; /* stop on quit */
|
||||
}
|
||||
@@ -6143,7 +6143,7 @@
|
||||
log_assert(xfr->task_probe);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_probe->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return 0; /* stop on quit */
|
||||
}
|
||||
@@ -6388,7 +6388,7 @@
|
||||
log_assert(xfr->task_probe);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_probe->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return; /* stop on quit */
|
||||
}
|
||||
@@ -6465,7 +6465,7 @@
|
||||
log_assert(xfr->task_nextprobe);
|
||||
lock_basic_lock(&xfr->lock);
|
||||
env = xfr->task_nextprobe->env;
|
||||
- if(env->outnet->want_to_quit) {
|
||||
+ if(!env || env->outnet->want_to_quit) {
|
||||
lock_basic_unlock(&xfr->lock);
|
||||
return; /* stop on quit */
|
||||
}
|
13
unbound.spec
13
unbound.spec
@ -35,8 +35,8 @@
|
||||
|
||||
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
||||
Name: unbound
|
||||
Version: 1.10.1
|
||||
Release: 5%{?extra_version:.%{extra_version}}%{?dist}
|
||||
Version: 1.12.0
|
||||
Release: 1%{?extra_version:.%{extra_version}}%{?dist}
|
||||
License: BSD
|
||||
Url: https://nlnetlabs.nl/projects/unbound/
|
||||
Source: https://nlnetlabs.nl/downloads/%{name}/%{name}-%{version}%{?extra_version}.tar.gz
|
||||
@ -59,8 +59,7 @@ Source17: unbound-anchor.service
|
||||
Source18: https://nlnetlabs.nl/downloads/%{name}/%{name}-%{version}%{?extra_version}.tar.gz.asc
|
||||
Source19: http://keys.gnupg.net/pks/lookup?op=get&search=0x9F6F1C2D7E045F8D#/wouter.nlnetlabs.nl.key
|
||||
|
||||
# https://github.com/NLnetLabs/unbound/issues/220
|
||||
Patch0: unbound-1.10.0-auth-callback.patch
|
||||
#Patch0: # No patches
|
||||
|
||||
BuildRequires: gcc, make
|
||||
BuildRequires: flex, openssl-devel
|
||||
@ -214,6 +213,9 @@ pushd %{dir_primary}
|
||||
%endif
|
||||
%if %{with systemd}
|
||||
--enable-systemd \
|
||||
%endif
|
||||
%if %{with doh}
|
||||
--with-libnghttp2 \
|
||||
%endif
|
||||
%{configure_args}
|
||||
|
||||
@ -448,6 +450,9 @@ popd
|
||||
%attr(0644,root,root) %config %{_sysconfdir}/%{name}/root.key
|
||||
|
||||
%changelog
|
||||
* Tue Oct 13 2020 Petr Menšík <pemensik@redhat.com> - 1.12.0-1
|
||||
- Update to 1.12.0 (#1860887)
|
||||
|
||||
* Tue Sep 15 2020 Petr Menšík <pemensik@redhat.com> - 1.10.1-5
|
||||
- Move command line tools to utils subpackage
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user