Remove last python2 dependency from python3 build
This commit is contained in:
parent
157c83d87f
commit
631ffb8d75
320
unbound-1.7.2-python3-devel.patch
Normal file
320
unbound-1.7.2-python3-devel.patch
Normal file
@ -0,0 +1,320 @@
|
|||||||
|
From b5aab36d41f374eddb0f66f28f251588f53a1e1e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Wouter Wijngaards <wouter@nlnetlabs.nl>
|
||||||
|
Date: Wed, 27 Jun 2018 05:46:36 +0000
|
||||||
|
Subject: [PATCH 1/2] - #4109: Fix that package config depends on python
|
||||||
|
unconditionally.
|
||||||
|
|
||||||
|
git-svn-id: file:///svn/unbound/trunk@4757 be551aaa-1e26-0410-a405-d3ace91eadb9
|
||||||
|
---
|
||||||
|
configure | 257 +++++++++++++++++++++++++++++++----------------------------
|
||||||
|
configure.ac | 5 +-
|
||||||
|
2 files changed, 137 insertions(+), 125 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index 3f1c372a..2a1687ae 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -670,9 +670,6 @@ SYSTEMD_DAEMON_LIBS
|
||||||
|
SYSTEMD_DAEMON_CFLAGS
|
||||||
|
SYSTEMD_LIBS
|
||||||
|
SYSTEMD_CFLAGS
|
||||||
|
-PKG_CONFIG_LIBDIR
|
||||||
|
-PKG_CONFIG_PATH
|
||||||
|
-PKG_CONFIG
|
||||||
|
staticexe
|
||||||
|
PC_LIBEVENT_DEPENDENCY
|
||||||
|
UNBOUND_EVENT_UNINSTALL
|
||||||
|
@@ -697,6 +694,9 @@ swig
|
||||||
|
SWIG_LIB
|
||||||
|
SWIG
|
||||||
|
PC_PY_DEPENDENCY
|
||||||
|
+PKG_CONFIG_LIBDIR
|
||||||
|
+PKG_CONFIG_PATH
|
||||||
|
+PKG_CONFIG
|
||||||
|
PY_MAJOR_VERSION
|
||||||
|
PYTHON_SITE_PKG
|
||||||
|
PYTHON_LDFLAGS
|
||||||
|
@@ -16930,7 +16930,136 @@ $as_echo "#define HAVE_PYTHON 1" >>confdefs.h
|
||||||
|
CPPFLAGS="$PYTHON_CPPFLAGS"
|
||||||
|
fi
|
||||||
|
ub_have_python=yes
|
||||||
|
- PC_PY_DEPENDENCY="python"
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
||||||
|
+ if test -n "$ac_tool_prefix"; then
|
||||||
|
+ # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
|
||||||
|
+set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
|
||||||
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||||
|
+$as_echo_n "checking for $ac_word... " >&6; }
|
||||||
|
+if ${ac_cv_path_PKG_CONFIG+:} false; then :
|
||||||
|
+ $as_echo_n "(cached) " >&6
|
||||||
|
+else
|
||||||
|
+ case $PKG_CONFIG in
|
||||||
|
+ [\\/]* | ?:[\\/]*)
|
||||||
|
+ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
|
||||||
|
+ ;;
|
||||||
|
+ *)
|
||||||
|
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||||
|
+for as_dir in $PATH
|
||||||
|
+do
|
||||||
|
+ IFS=$as_save_IFS
|
||||||
|
+ test -z "$as_dir" && as_dir=.
|
||||||
|
+ for ac_exec_ext in '' $ac_executable_extensions; do
|
||||||
|
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||||
|
+ ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
||||||
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||||
|
+ break 2
|
||||||
|
+ fi
|
||||||
|
+done
|
||||||
|
+ done
|
||||||
|
+IFS=$as_save_IFS
|
||||||
|
+
|
||||||
|
+ ;;
|
||||||
|
+esac
|
||||||
|
+fi
|
||||||
|
+PKG_CONFIG=$ac_cv_path_PKG_CONFIG
|
||||||
|
+if test -n "$PKG_CONFIG"; then
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
|
||||||
|
+$as_echo "$PKG_CONFIG" >&6; }
|
||||||
|
+else
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
+$as_echo "no" >&6; }
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+fi
|
||||||
|
+if test -z "$ac_cv_path_PKG_CONFIG"; then
|
||||||
|
+ ac_pt_PKG_CONFIG=$PKG_CONFIG
|
||||||
|
+ # Extract the first word of "pkg-config", so it can be a program name with args.
|
||||||
|
+set dummy pkg-config; ac_word=$2
|
||||||
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||||
|
+$as_echo_n "checking for $ac_word... " >&6; }
|
||||||
|
+if ${ac_cv_path_ac_pt_PKG_CONFIG+:} false; then :
|
||||||
|
+ $as_echo_n "(cached) " >&6
|
||||||
|
+else
|
||||||
|
+ case $ac_pt_PKG_CONFIG in
|
||||||
|
+ [\\/]* | ?:[\\/]*)
|
||||||
|
+ ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
|
||||||
|
+ ;;
|
||||||
|
+ *)
|
||||||
|
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||||
|
+for as_dir in $PATH
|
||||||
|
+do
|
||||||
|
+ IFS=$as_save_IFS
|
||||||
|
+ test -z "$as_dir" && as_dir=.
|
||||||
|
+ for ac_exec_ext in '' $ac_executable_extensions; do
|
||||||
|
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||||
|
+ ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
||||||
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||||
|
+ break 2
|
||||||
|
+ fi
|
||||||
|
+done
|
||||||
|
+ done
|
||||||
|
+IFS=$as_save_IFS
|
||||||
|
+
|
||||||
|
+ ;;
|
||||||
|
+esac
|
||||||
|
+fi
|
||||||
|
+ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
|
||||||
|
+if test -n "$ac_pt_PKG_CONFIG"; then
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_PKG_CONFIG" >&5
|
||||||
|
+$as_echo "$ac_pt_PKG_CONFIG" >&6; }
|
||||||
|
+else
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
+$as_echo "no" >&6; }
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+ if test "x$ac_pt_PKG_CONFIG" = x; then
|
||||||
|
+ PKG_CONFIG=""
|
||||||
|
+ else
|
||||||
|
+ case $cross_compiling:$ac_tool_warned in
|
||||||
|
+yes:)
|
||||||
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
|
||||||
|
+$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
|
||||||
|
+ac_tool_warned=yes ;;
|
||||||
|
+esac
|
||||||
|
+ PKG_CONFIG=$ac_pt_PKG_CONFIG
|
||||||
|
+ fi
|
||||||
|
+else
|
||||||
|
+ PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+fi
|
||||||
|
+if test -n "$PKG_CONFIG"; then
|
||||||
|
+ _pkg_min_version=0.9.0
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking pkg-config is at least version $_pkg_min_version" >&5
|
||||||
|
+$as_echo_n "checking pkg-config is at least version $_pkg_min_version... " >&6; }
|
||||||
|
+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||||
|
+$as_echo "yes" >&6; }
|
||||||
|
+ else
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
+$as_echo "no" >&6; }
|
||||||
|
+ PKG_CONFIG=""
|
||||||
|
+ fi
|
||||||
|
+fi
|
||||||
|
+ if test -n "$PKG_CONFIG" && \
|
||||||
|
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\"python\${PY_MAJOR_VERSION}\"\""; } >&5
|
||||||
|
+ ($PKG_CONFIG --exists --print-errors ""python${PY_MAJOR_VERSION}"") 2>&5
|
||||||
|
+ ac_status=$?
|
||||||
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||||
|
+ test $ac_status = 0; }; then
|
||||||
|
+ PC_PY_DEPENDENCY="python${PY_MAJOR_VERSION}"
|
||||||
|
+else
|
||||||
|
+ PC_PY_DEPENDENCY="python"
|
||||||
|
+fi
|
||||||
|
|
||||||
|
|
||||||
|
# Check for SWIG
|
||||||
|
@@ -18960,126 +19089,6 @@ else
|
||||||
|
fi
|
||||||
|
|
||||||
|
have_systemd=no
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
||||||
|
- if test -n "$ac_tool_prefix"; then
|
||||||
|
- # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
|
||||||
|
-set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
|
||||||
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||||
|
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||||
|
-if ${ac_cv_path_PKG_CONFIG+:} false; then :
|
||||||
|
- $as_echo_n "(cached) " >&6
|
||||||
|
-else
|
||||||
|
- case $PKG_CONFIG in
|
||||||
|
- [\\/]* | ?:[\\/]*)
|
||||||
|
- ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
|
||||||
|
- ;;
|
||||||
|
- *)
|
||||||
|
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||||
|
-for as_dir in $PATH
|
||||||
|
-do
|
||||||
|
- IFS=$as_save_IFS
|
||||||
|
- test -z "$as_dir" && as_dir=.
|
||||||
|
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||||
|
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||||
|
- ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
||||||
|
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||||
|
- break 2
|
||||||
|
- fi
|
||||||
|
-done
|
||||||
|
- done
|
||||||
|
-IFS=$as_save_IFS
|
||||||
|
-
|
||||||
|
- ;;
|
||||||
|
-esac
|
||||||
|
-fi
|
||||||
|
-PKG_CONFIG=$ac_cv_path_PKG_CONFIG
|
||||||
|
-if test -n "$PKG_CONFIG"; then
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
|
||||||
|
-$as_echo "$PKG_CONFIG" >&6; }
|
||||||
|
-else
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
-$as_echo "no" >&6; }
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-fi
|
||||||
|
-if test -z "$ac_cv_path_PKG_CONFIG"; then
|
||||||
|
- ac_pt_PKG_CONFIG=$PKG_CONFIG
|
||||||
|
- # Extract the first word of "pkg-config", so it can be a program name with args.
|
||||||
|
-set dummy pkg-config; ac_word=$2
|
||||||
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||||
|
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||||
|
-if ${ac_cv_path_ac_pt_PKG_CONFIG+:} false; then :
|
||||||
|
- $as_echo_n "(cached) " >&6
|
||||||
|
-else
|
||||||
|
- case $ac_pt_PKG_CONFIG in
|
||||||
|
- [\\/]* | ?:[\\/]*)
|
||||||
|
- ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
|
||||||
|
- ;;
|
||||||
|
- *)
|
||||||
|
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||||
|
-for as_dir in $PATH
|
||||||
|
-do
|
||||||
|
- IFS=$as_save_IFS
|
||||||
|
- test -z "$as_dir" && as_dir=.
|
||||||
|
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||||
|
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||||
|
- ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
||||||
|
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||||
|
- break 2
|
||||||
|
- fi
|
||||||
|
-done
|
||||||
|
- done
|
||||||
|
-IFS=$as_save_IFS
|
||||||
|
-
|
||||||
|
- ;;
|
||||||
|
-esac
|
||||||
|
-fi
|
||||||
|
-ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
|
||||||
|
-if test -n "$ac_pt_PKG_CONFIG"; then
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_PKG_CONFIG" >&5
|
||||||
|
-$as_echo "$ac_pt_PKG_CONFIG" >&6; }
|
||||||
|
-else
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
-$as_echo "no" >&6; }
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
- if test "x$ac_pt_PKG_CONFIG" = x; then
|
||||||
|
- PKG_CONFIG=""
|
||||||
|
- else
|
||||||
|
- case $cross_compiling:$ac_tool_warned in
|
||||||
|
-yes:)
|
||||||
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
|
||||||
|
-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
|
||||||
|
-ac_tool_warned=yes ;;
|
||||||
|
-esac
|
||||||
|
- PKG_CONFIG=$ac_pt_PKG_CONFIG
|
||||||
|
- fi
|
||||||
|
-else
|
||||||
|
- PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-fi
|
||||||
|
-if test -n "$PKG_CONFIG"; then
|
||||||
|
- _pkg_min_version=0.9.0
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking pkg-config is at least version $_pkg_min_version" >&5
|
||||||
|
-$as_echo_n "checking pkg-config is at least version $_pkg_min_version... " >&6; }
|
||||||
|
- if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||||
|
-$as_echo "yes" >&6; }
|
||||||
|
- else
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
-$as_echo "no" >&6; }
|
||||||
|
- PKG_CONFIG=""
|
||||||
|
- fi
|
||||||
|
-fi
|
||||||
|
if test "x$enable_systemd" != xno; then :
|
||||||
|
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 1828253c..b2c95d1a 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -586,7 +586,10 @@ if test x_$ub_test_python != x_no; then
|
||||||
|
CPPFLAGS="$PYTHON_CPPFLAGS"
|
||||||
|
fi
|
||||||
|
ub_have_python=yes
|
||||||
|
- PC_PY_DEPENDENCY="python"
|
||||||
|
+ PKG_PROG_PKG_CONFIG
|
||||||
|
+ PKG_CHECK_EXISTS(["python${PY_MAJOR_VERSION}"],
|
||||||
|
+ [PC_PY_DEPENDENCY="python${PY_MAJOR_VERSION}"],
|
||||||
|
+ [PC_PY_DEPENDENCY="python"])
|
||||||
|
AC_SUBST(PC_PY_DEPENDENCY)
|
||||||
|
|
||||||
|
# Check for SWIG
|
||||||
|
--
|
||||||
|
2.14.4
|
||||||
|
|
31
unbound-1.7.2-python3-pkgconfig.patch
Normal file
31
unbound-1.7.2-python3-pkgconfig.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From bca54a8b252d4a75e940424dc761c6a4e487eb84 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Wouter Wijngaards <wouter@nlnetlabs.nl>
|
||||||
|
Date: Wed, 27 Jun 2018 06:07:31 +0000
|
||||||
|
Subject: [PATCH 2/2] =?UTF-8?q?-=20Patch,=20do=20not=20export=20python=20f?=
|
||||||
|
=?UTF-8?q?rom=20pkg-config,=20from=20Petr=20Men=C5=A1=C3=ADk.?=
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
git-svn-id: file:///svn/unbound/trunk@4758 be551aaa-1e26-0410-a405-d3ace91eadb9
|
||||||
|
---
|
||||||
|
contrib/libunbound.pc.in | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/contrib/libunbound.pc.in b/contrib/libunbound.pc.in
|
||||||
|
index 0cb9f875..810c5713 100644
|
||||||
|
--- a/contrib/libunbound.pc.in
|
||||||
|
+++ b/contrib/libunbound.pc.in
|
||||||
|
@@ -7,7 +7,8 @@ Name: unbound
|
||||||
|
Description: Library with validating, recursive, and caching DNS resolver
|
||||||
|
URL: http://www.unbound.net
|
||||||
|
Version: @PACKAGE_VERSION@
|
||||||
|
-Requires: @PC_LIBEVENT_DEPENDENCY@ @PC_PY_DEPENDENCY@
|
||||||
|
+Requires: libcrypto libssl @PC_LIBEVENT_DEPENDENCY@
|
||||||
|
+Requires.private: @PC_PY_DEPENDENCY@
|
||||||
|
Libs: -L${libdir} -lunbound -lssl -lcrypto
|
||||||
|
Libs.private: @SSLLIB@ @LIBS@
|
||||||
|
Cflags: -I${includedir}
|
||||||
|
--
|
||||||
|
2.14.4
|
||||||
|
|
@ -34,7 +34,7 @@
|
|||||||
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
||||||
Name: unbound
|
Name: unbound
|
||||||
Version: 1.7.2
|
Version: 1.7.2
|
||||||
Release: 2%{?extra_version:.%{extra_version}}%{?dist}
|
Release: 3%{?extra_version:.%{extra_version}}%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: https://www.unbound.net/
|
Url: https://www.unbound.net/
|
||||||
Source: https://www.unbound.net/downloads/%{name}-%{version}%{?extra_version}.tar.gz
|
Source: https://www.unbound.net/downloads/%{name}-%{version}%{?extra_version}.tar.gz
|
||||||
@ -56,6 +56,8 @@ Source16: unbound-munin.README
|
|||||||
Source17: unbound-anchor.service
|
Source17: unbound-anchor.service
|
||||||
|
|
||||||
Patch1: unbound-1.7.2-stub-fwd-ttl.patch
|
Patch1: unbound-1.7.2-stub-fwd-ttl.patch
|
||||||
|
Patch2: unbound-1.7.2-python3-devel.patch
|
||||||
|
Patch3: unbound-1.7.2-python3-pkgconfig.patch
|
||||||
|
|
||||||
BuildRequires: gcc, make
|
BuildRequires: gcc, make
|
||||||
BuildRequires: flex, openssl-devel
|
BuildRequires: flex, openssl-devel
|
||||||
@ -161,6 +163,8 @@ Python 3 modules and extensions for unbound
|
|||||||
|
|
||||||
pushd %{pkgname}
|
pushd %{pkgname}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1 -b .python3
|
||||||
|
%patch3 -p1 -b .python3
|
||||||
|
|
||||||
# only for snapshots
|
# only for snapshots
|
||||||
# autoreconf -iv
|
# autoreconf -iv
|
||||||
@ -428,6 +432,9 @@ popd
|
|||||||
%attr(0644,root,root) %config %{_sysconfdir}/%{name}/root.key
|
%attr(0644,root,root) %config %{_sysconfdir}/%{name}/root.key
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 27 2018 Petr Menšík <pemensik@redhat.com> - 1.7.2-3
|
||||||
|
- Remove last python2 dependency from python3 build
|
||||||
|
|
||||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.7.2-2
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.7.2-2
|
||||||
- Rebuilt for Python 3.7
|
- Rebuilt for Python 3.7
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user