* Mon Aug 08 2011 Paul Wouters <paul@xelerance.com> - 1.4.12-2
- Fix for python module load in the server (Tom Hendrikx) - No longer enable --enable-debug as it causes degraded performance under load.
This commit is contained in:
parent
087b8ded39
commit
446ddec917
11
unbound-1.4.12-pythonmod.patch
Normal file
11
unbound-1.4.12-pythonmod.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- pythonmod/pythonmod.c.orig 2011-08-08 20:45:48.344987246 +0200
|
||||||
|
+++ pythonmod/pythonmod.c 2011-08-08 21:31:41.429025557 +0200
|
||||||
|
@@ -153,6 +153,8 @@
|
||||||
|
}
|
||||||
|
PyRun_SimpleString("sys.path.append('"RUN_DIR"') \n");
|
||||||
|
PyRun_SimpleString("sys.path.append('"SHARE_DIR"') \n");
|
||||||
|
+ PyRun_SimpleString("import sysconfig \n");
|
||||||
|
+ PyRun_SimpleString("sys.path.append(sysconfig.get_path('purelib')) \n");
|
||||||
|
if (PyRun_SimpleString("from unboundmodule import *\n") < 0)
|
||||||
|
{
|
||||||
|
log_err("pythonmod: cannot initialize core module: unboundmodule.py");
|
11
unbound.spec
11
unbound.spec
@ -9,7 +9,7 @@
|
|||||||
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
||||||
Name: unbound
|
Name: unbound
|
||||||
Version: 1.4.12
|
Version: 1.4.12
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: http://www.nlnetlabs.nl/unbound/
|
Url: http://www.nlnetlabs.nl/unbound/
|
||||||
Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
|
Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
|
||||||
@ -20,6 +20,7 @@ Source4: unbound_munin_
|
|||||||
Source5: root.key
|
Source5: root.key
|
||||||
Source6: dlv.isc.org.key
|
Source6: dlv.isc.org.key
|
||||||
Patch1: unbound-1.2-glob.patch
|
Patch1: unbound-1.2-glob.patch
|
||||||
|
Patch2: unbound-1.4.12-pythonmod.patch
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -93,10 +94,11 @@ Python modules and extensions for unbound
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-ldns= --with-libevent --with-pthreads --with-ssl \
|
%configure --with-ldns= --with-libevent --with-pthreads --with-ssl \
|
||||||
--disable-rpath --enable-XXXdebug --disable-static \
|
--disable-rpath --disable-static \
|
||||||
--with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
|
--with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
|
||||||
--with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
|
--with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
|
||||||
%if %{with_python}
|
%if %{with_python}
|
||||||
@ -199,6 +201,11 @@ fi
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 08 2011 Paul Wouters <paul@xelerance.com> - 1.4.12-2
|
||||||
|
- Fix for python module load in the server (Tom Hendrikx)
|
||||||
|
- No longer enable --enable-debug as it causes degraded performance
|
||||||
|
under load.
|
||||||
|
|
||||||
* Mon Jul 18 2011 Paul Wouters <paul@xelerance.com> - 1.4.12-1
|
* Mon Jul 18 2011 Paul Wouters <paul@xelerance.com> - 1.4.12-1
|
||||||
- Updated to 1.4.12
|
- Updated to 1.4.12
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user