* Wed Feb 01 2012 Paul Wouters <paul@nohats.ca> - 1.4.15-2
- Patch for SONAME version (libtool's -version-number vs -version-info)
This commit is contained in:
parent
3bde9d279c
commit
1637b0e712
49
unbound-1.4.15-version.patch
Normal file
49
unbound-1.4.15-version.patch
Normal file
@ -0,0 +1,49 @@
|
||||
>From fe05ea0802ff3f2fd2f49ed0bb3f1f0f4542f196 Mon Sep 17 00:00:00 2001
|
||||
From: "Robert S. Edmonds" <edmonds@debian.org>
|
||||
Date: Sat, 28 Jan 2012 20:05:43 -0500
|
||||
Subject: [PATCH] Makefile.in: use -version-info, not -version-number
|
||||
|
||||
from the libtool manual:
|
||||
|
||||
-version-info current[:revision[:age]]
|
||||
If output-file is a libtool library, use interface version
|
||||
information current, revision, and age to build it (see
|
||||
Versioning). Do not use this flag to specify package release
|
||||
information, rather see the -release flag.
|
||||
|
||||
-version-number major[:minor[:revision]]
|
||||
If output-file is a libtool library, compute interface version
|
||||
information so that the resulting library uses the specified
|
||||
major, minor and revision numbers. This is designed to permit
|
||||
libtool to be used with existing projects where identical
|
||||
version numbers are already used across operating systems. New
|
||||
projects should use the -version-info flag instead.
|
||||
---
|
||||
Makefile.in | 4 ++--
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index bdd8dba..4c26f52 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -224,7 +224,7 @@ ALL_OBJ=$(COMMON_OBJ) $(UNITTEST_OBJ) $(DAEMON_OBJ) \
|
||||
|
||||
COMPILE=$(LIBTOOL) --tag=CC --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS)
|
||||
LINK=$(LIBTOOL) --tag=CC --mode=link $(CC) $(staticexe) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS)
|
||||
-LINK_LIB=$(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(staticexe) -version-number @LIBUNBOUND_CURRENT@:@LIBUNBOUND_REVISION@:@LIBUNBOUND_AGE@ -no-undefined
|
||||
+LINK_LIB=$(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(staticexe) -version-info @LIBUNBOUND_CURRENT@:@LIBUNBOUND_REVISION@:@LIBUNBOUND_AGE@ -no-undefined
|
||||
|
||||
.PHONY: clean realclean doc lint all install uninstall tests test strip lib longtest longcheck check
|
||||
|
||||
@@ -369,7 +369,7 @@ libunbound/python/libunbound_wrap.c: $(srcdir)/libunbound/python/libunbound.i $(
|
||||
|
||||
# Pyunbound python unbound wrapper
|
||||
_unbound.la: libunbound_wrap.lo libunbound.la
|
||||
- $(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -module -version-number @LIBUNBOUND_CURRENT@:@LIBUNBOUND_REVISION@:@LIBUNBOUND_AGE@ -no-undefined -o $@ libunbound_wrap.lo -rpath $(PYTHON_SITE_PKG) L. -L.libs -lunbound $(LIBS)
|
||||
+ $(LIBTOOL) --tag=CC --mode=link $(CC) $(RUNTIME_PATH) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -module -version-info @LIBUNBOUND_CURRENT@:@LIBUNBOUND_REVISION@:@LIBUNBOUND_AGE@ -no-undefined -o $@ libunbound_wrap.lo -rpath $(PYTHON_SITE_PKG) L. -L.libs -lunbound $(LIBS)
|
||||
|
||||
util/config_file.c: util/configparser.h
|
||||
util/configlexer.c: $(srcdir)/util/configlexer.lex util/configparser.h
|
||||
--
|
||||
1.7.8.3
|
||||
|
@ -8,7 +8,7 @@
|
||||
Summary: Validating, recursive, and caching DNS(SEC) resolver
|
||||
Name: unbound
|
||||
Version: 1.4.15
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: BSD
|
||||
Url: http://www.nlnetlabs.nl/unbound/
|
||||
Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
|
||||
@ -21,6 +21,7 @@ Source6: dlv.isc.org.key
|
||||
Source7: unbound-keygen.service
|
||||
Source8: tmpfiles-unbound.conf
|
||||
Patch1: unbound-1.2-glob.patch
|
||||
Patch2: unbound-1.4.15-version.patch
|
||||
|
||||
Group: System Environment/Daemons
|
||||
BuildRequires: flex, openssl-devel , ldns-devel >= 1.5.0,
|
||||
@ -93,6 +94,7 @@ Python modules and extensions for unbound
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure --with-ldns= --with-libevent --with-pthreads --with-ssl \
|
||||
@ -219,6 +221,9 @@ fi
|
||||
/bin/systemctl try-restart unbound-keygen.service >/dev/null 2>&1 || :
|
||||
|
||||
%changelog
|
||||
* Wed Feb 01 2012 Paul Wouters <paul@nohats.ca> - 1.4.15-2
|
||||
- Patch for SONAME version (libtool's -version-number vs -version-info)
|
||||
|
||||
* Fri Jan 27 2012 Paul Wouters <pwouters@redhat.com> - 1.4.15-1
|
||||
- Upgraded to 1.4.15
|
||||
- Updated unbound.conf to show how to configure listening on tls443
|
||||
|
Loading…
Reference in New Issue
Block a user