+ umockdev-0.16.2-2
Better build fix patch
This commit is contained in:
parent
f01b7be260
commit
16ec9963af
@ -1,47 +0,0 @@
|
||||
From 7939e8defe7530431730eb6f83e423071846640d Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Wed, 25 Aug 2021 12:29:12 +0200
|
||||
Subject: [PATCH] docs: Remove types handling from docs
|
||||
|
||||
umockdev doesn't export any GObject object types, so gtk-doc should not
|
||||
be trying to create an empty types file, or including an object class
|
||||
tree in its documentation.
|
||||
|
||||
See https://gitlab.gnome.org/GNOME/gtk-doc/issues/48
|
||||
See https://github.com/mesonbuild/meson/issues/3892
|
||||
See https://bugzilla.redhat.com/show_bug.cgi?id=1604585
|
||||
---
|
||||
docs/reference/meson.build | 1 -
|
||||
docs/reference/umockdev-docs.xml | 4 ----
|
||||
2 files changed, 5 deletions(-)
|
||||
|
||||
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
|
||||
index 737f861..25977af 100644
|
||||
--- a/docs/reference/meson.build
|
||||
+++ b/docs/reference/meson.build
|
||||
@@ -14,7 +14,6 @@ gnome.gtkdoc('umockdev',
|
||||
src_dir: [meson.build_root(), umockdev_c, umockdev_ioctl_c],
|
||||
content_files: [version_xml],
|
||||
ignore_headers: ['uevent_sender.h', 'ioctl_tree.h', 'debug.h'],
|
||||
- scan_args: ['--rebuild-types'],
|
||||
dependencies: [glib, gobject, declare_dependency(link_with : [umockdev_lib])],
|
||||
install: true,
|
||||
)
|
||||
diff --git a/docs/reference/umockdev-docs.xml b/docs/reference/umockdev-docs.xml
|
||||
index 4d7216f..0228aef 100644
|
||||
--- a/docs/reference/umockdev-docs.xml
|
||||
+++ b/docs/reference/umockdev-docs.xml
|
||||
@@ -33,10 +33,6 @@
|
||||
<xi:include href="xml/umockdeverror.xml"/>
|
||||
|
||||
</chapter>
|
||||
- <chapter id="object-tree">
|
||||
- <title>Object Hierarchy</title>
|
||||
- <xi:include href="xml/tree_index.sgml"/>
|
||||
- </chapter>
|
||||
<index id="api-index-full">
|
||||
<title>API Index</title>
|
||||
<xi:include href="xml/api-index-full.xml"><xi:fallback /></xi:include>
|
||||
--
|
||||
2.31.1
|
||||
|
56
0001-docs-Work-around-creation-of-umockdev.types.patch
Normal file
56
0001-docs-Work-around-creation-of-umockdev.types.patch
Normal file
@ -0,0 +1,56 @@
|
||||
From e79dc63b931b4d1603bae09a81d9953733721208 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 26 Aug 2021 13:52:38 +0200
|
||||
Subject: [PATCH] docs: Work-around creation of umockdev.types
|
||||
|
||||
meson doesn't seem to have a way to tell gtk-doc where the .c files to
|
||||
extract the type functions from would be when they're generated, like
|
||||
they are for Vala sources.
|
||||
|
||||
Work around this by providing a static .types file.
|
||||
|
||||
See https://github.com/mesonbuild/meson/issues/3892
|
||||
---
|
||||
docs/reference/meson.build | 9 ++-------
|
||||
docs/reference/umockdev.types | 4 ++++
|
||||
2 files changed, 6 insertions(+), 7 deletions(-)
|
||||
create mode 100644 docs/reference/umockdev.types
|
||||
|
||||
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
|
||||
index 737f861..8c5e5da 100644
|
||||
--- a/docs/reference/meson.build
|
||||
+++ b/docs/reference/meson.build
|
||||
@@ -3,18 +3,13 @@ version_xml = configure_file(
|
||||
output: 'version.xml',
|
||||
configuration: conf)
|
||||
|
||||
-# HACK: need to find valac'ed umockdev.c for gtk-doc; https://github.com/mesonbuild/meson/issues/3892
|
||||
-# this isn't predictable between meson versions
|
||||
-umockdev_c = run_command('sh', '-ec', 'find -name umockdev.c| xargs dirname').stdout().strip()
|
||||
-umockdev_ioctl_c = run_command('sh', '-ec', 'find -name umockdev-ioctl.c| xargs dirname').stdout().strip()
|
||||
-
|
||||
gnome = import('gnome')
|
||||
gnome.gtkdoc('umockdev',
|
||||
main_xml: 'umockdev-docs.xml',
|
||||
- src_dir: [meson.build_root(), umockdev_c, umockdev_ioctl_c],
|
||||
+ src_dir: [meson.build_root()],
|
||||
content_files: [version_xml],
|
||||
+ gobject_typesfile: 'umockdev.types',
|
||||
ignore_headers: ['uevent_sender.h', 'ioctl_tree.h', 'debug.h'],
|
||||
- scan_args: ['--rebuild-types'],
|
||||
dependencies: [glib, gobject, declare_dependency(link_with : [umockdev_lib])],
|
||||
install: true,
|
||||
)
|
||||
diff --git a/docs/reference/umockdev.types b/docs/reference/umockdev.types
|
||||
new file mode 100644
|
||||
index 0000000..e35006e
|
||||
--- /dev/null
|
||||
+++ b/docs/reference/umockdev.types
|
||||
@@ -0,0 +1,4 @@
|
||||
+umockdev_ioctl_base_get_type
|
||||
+umockdev_ioctl_client_get_type
|
||||
+umockdev_ioctl_data_get_type
|
||||
+umockdev_testbed_get_type
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: umockdev
|
||||
Version: 0.16.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Mock hardware devices
|
||||
|
||||
License: LGPLv2+
|
||||
@ -17,8 +17,8 @@ BuildRequires: libpcap-devel
|
||||
BuildRequires: vala
|
||||
BuildRequires: chrpath
|
||||
|
||||
# https://github.com/martinpitt/umockdev/pull/139
|
||||
Patch0: 0001-docs-Remove-types-handling-from-docs.patch
|
||||
# https://github.com/martinpitt/umockdev/pull/141
|
||||
Patch0: 0001-docs-Work-around-creation-of-umockdev.types.patch
|
||||
|
||||
%description
|
||||
With this program and libraries you can easily create mock udev objects.
|
||||
@ -72,6 +72,10 @@ rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/umockdev
|
||||
%{_datadir}/vala/vapi/umockdev-1.0.vapi
|
||||
|
||||
%changelog
|
||||
* Mon Aug 30 2021 Bastien Nocera <bnocera@redhat.com> - 0.16.2-2
|
||||
+ umockdev-0.16.2-2
|
||||
- Better build fix patch
|
||||
|
||||
* Wed Aug 25 2021 Bastien Nocera <bnocera@redhat.com> - 0.16.2-1
|
||||
+ umockdev-0.16.2-1
|
||||
- Update to 0.16.2
|
||||
|
Loading…
Reference in New Issue
Block a user