Fix building with cmocka >= 1.1.6

This commit is contained in:
Andreas Schneider 2023-02-27 10:35:24 +01:00
parent 80c043d907
commit 284272133b
2 changed files with 37 additions and 1 deletions

View File

@ -0,0 +1,31 @@
From 850f24c6366abda30bfd77734b90330b8809d306 Mon Sep 17 00:00:00 2001
From: Andreas Schneider <asn@samba.org>
Date: Fri, 17 Feb 2023 17:51:27 +0100
Subject: [PATCH] cmake: Fix cmocka >= 1.1.6 find_package() in CONFIG mode
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Andreas Schneider <asn@samba.org>
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
---
tests/CMakeLists.txt | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 635e86e..68e050e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,5 +1,9 @@
project(tests C)
+if (TARGET cmocka::cmocka)
+ set(CMOCKA_LIBRARY cmocka::cmocka)
+endif()
+
add_library(uwrap_fake_socket_wrapper SHARED uwrap_fake_socket_wrapper.c)
target_compile_options(uwrap_fake_socket_wrapper
PRIVATE
--
2.39.2

View File

@ -1,6 +1,6 @@
Name: uid_wrapper
Version: 1.3.0
Release: 2%{?dist}
Release: 3%{?dist}
Summary: A wrapper for privilege separation
License: GPLv3+
@ -10,6 +10,8 @@ Source0: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz
Source1: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz.asc
Source2: uid_wrapper.keyring
Patch0: uid_wrapper-fix-cmocka-1.1.6+-support.patch
BuildRequires: gcc
BuildRequires: cmake
BuildRequires: gnupg2
@ -62,6 +64,9 @@ gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
%{_mandir}/man1/uid_wrapper.1*
%changelog
* Mon Feb 27 2023 Andreas Schneider <asn@redhat.com> - 1.3.0-3
- Fix building with cmocka >= 1.1.6
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild