Fix firewire drives identification (#909010)
This commit is contained in:
parent
0c52c76e0a
commit
5d437962f2
26
udisks-2.1.1-firewire-ident.patch
Normal file
26
udisks-2.1.1-firewire-ident.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From b841e30a98459816dfc49a735d3db4355a88edcd Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Zeuthen <zeuthen@gmail.com>
|
||||||
|
Date: Tue, 19 Mar 2013 04:31:40 +0000
|
||||||
|
Subject: Properly identify firewire devices as non-system devices
|
||||||
|
|
||||||
|
This was reported in bug 62077.
|
||||||
|
|
||||||
|
https://bugs.freedesktop.org/show_bug.cgi?id=62077
|
||||||
|
|
||||||
|
Signed-off-by: David Zeuthen <zeuthen@gmail.com>
|
||||||
|
---
|
||||||
|
diff --git a/src/udiskslinuxblock.c b/src/udiskslinuxblock.c
|
||||||
|
index a1781cf..d619850 100644
|
||||||
|
--- a/src/udiskslinuxblock.c
|
||||||
|
+++ b/src/udiskslinuxblock.c
|
||||||
|
@@ -354,7 +354,7 @@ update_hints (UDisksLinuxBlock *block,
|
||||||
|
connection_bus = udisks_drive_get_connection_bus (drive);
|
||||||
|
removable = udisks_drive_get_media_removable (drive);
|
||||||
|
if (removable ||
|
||||||
|
- (g_strcmp0 (connection_bus, "usb") == 0 || g_strcmp0 (connection_bus, "firewire") == 0) ||
|
||||||
|
+ (g_strcmp0 (connection_bus, "usb") == 0 || g_strcmp0 (connection_bus, "ieee1394") == 0) ||
|
||||||
|
(g_str_has_prefix (device_file, "/dev/mmcblk") || g_str_has_prefix (device_file, "/dev/mspblk")))
|
||||||
|
{
|
||||||
|
hint_system = FALSE;
|
||||||
|
--
|
||||||
|
cgit v0.9.0.2-2-gbebe
|
12
udisks2.spec
12
udisks2.spec
@ -8,7 +8,7 @@
|
|||||||
Summary: Disk Manager
|
Summary: Disk Manager
|
||||||
Name: udisks2
|
Name: udisks2
|
||||||
Version: 2.1.0
|
Version: 2.1.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.freedesktop.org/wiki/Software/udisks
|
URL: http://www.freedesktop.org/wiki/Software/udisks
|
||||||
@ -63,6 +63,12 @@ Requires: ntfsprogs
|
|||||||
# for /proc/self/mountinfo, only available in 2.6.26 or higher
|
# for /proc/self/mountinfo, only available in 2.6.26 or higher
|
||||||
Conflicts: kernel < 2.6.26
|
Conflicts: kernel < 2.6.26
|
||||||
|
|
||||||
|
|
||||||
|
# Cannot mount external firewire hard drive or usb thumb drive as normal user, root required
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=909010
|
||||||
|
Patch0: udisks-2.1.1-firewire-ident.patch
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
udisks provides a daemon, D-Bus API and command line tools for
|
udisks provides a daemon, D-Bus API and command line tools for
|
||||||
managing disks and storage devices. This package is for the udisks 2.x
|
managing disks and storage devices. This package is for the udisks 2.x
|
||||||
@ -92,6 +98,7 @@ daemon. This package is for the udisks 2.x series.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n udisks-%{version}
|
%setup -q -n udisks-%{version}
|
||||||
|
%patch0 -p1 -b .firewire-ident
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# we can't use _hardened_build here, see
|
# we can't use _hardened_build here, see
|
||||||
@ -155,6 +162,9 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
|
|||||||
|
|
||||||
# Note: please don't forget the %{?dist} in the changelog. Thanks
|
# Note: please don't forget the %{?dist} in the changelog. Thanks
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 28 2013 Tomas Bzatek <tbzatek@redhat.com> - 2.1.0-2%{?dist}
|
||||||
|
- Fix firewire drives identification (#909010)
|
||||||
|
|
||||||
* Wed Mar 20 2013 Kalev Lember <kalevlember@gmail.com> - 2.1.0-1
|
* Wed Mar 20 2013 Kalev Lember <kalevlember@gmail.com> - 2.1.0-1
|
||||||
- Update to 2.1.0
|
- Update to 2.1.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user