New udisks upstream release 2.8.1
This commit is contained in:
parent
fdfe302708
commit
504348dfdc
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
||||
/udisks-2.7.6.tar.bz2
|
||||
/udisks-2.7.7.tar.bz2
|
||||
/udisks-2.8.0.tar.bz2
|
||||
/udisks-2.8.1.tar.bz2
|
||||
|
@ -1,56 +0,0 @@
|
||||
From b3d9f04f354d2ac21964a637ef42815476b6ff78 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Thu, 13 Sep 2018 16:40:44 -0700
|
||||
Subject: [PATCH] Fix DM_MULTIPATH_DEVICE_PATH in udev rules
|
||||
|
||||
As we worked out in
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1628774 , with
|
||||
multipath-tools 0.7.7 or higher, DM_MULTIPATH_DEVICE_PATH gets
|
||||
set to the value 0 for non-multipath devices in some cases.
|
||||
Before 0.7.7, it was always either set to 1 or not set at all.
|
||||
Now it can be set to 0, checks like this:
|
||||
|
||||
ENV{DM_MULTIPATH_DEVICE_PATH}=="?*"
|
||||
|
||||
don't work right any more, because that check will actually
|
||||
match if the value is 0 (it will only not match if the var is
|
||||
not set at all, or is set to an empty string). Instead we should
|
||||
just check if it is set to exactly 1, otherwise assume the device
|
||||
isn't multipath.
|
||||
|
||||
The impact of this is I think quite limited: we only skip two
|
||||
rules if this check matches, and they only affect mdraid devices.
|
||||
On installed systems without any multipath devices, the bug
|
||||
should not happen, because there should be no /etc/multipath.conf
|
||||
and when that file doesn't exist, the multipath rules skip out
|
||||
early and don't wind up setting the value to 0 ever. I think the
|
||||
only cases affected by this are 'generic' environments like live
|
||||
images and installers, and installed systems with multipath
|
||||
devices. In both these cases there will be a /etc/multipath.conf
|
||||
file, so for some devices, the multipath rules will get far
|
||||
enough to set the value to 0. The consequence will be that the
|
||||
UDISKS_MD_* values that these two rules try to set will not get
|
||||
set for devices they *should* get set for. I'm not sure what the
|
||||
further consequences of that are, if any.
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
data/80-udisks2.rules | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/data/80-udisks2.rules b/data/80-udisks2.rules
|
||||
index e8f7c5ee..a64f1cb3 100644
|
||||
--- a/data/80-udisks2.rules
|
||||
+++ b/data/80-udisks2.rules
|
||||
@@ -10,7 +10,7 @@
|
||||
# Skip probing if not a block device or if requested by other rules
|
||||
#
|
||||
SUBSYSTEM!="block", GOTO="udisks_probe_end"
|
||||
-ENV{DM_MULTIPATH_DEVICE_PATH}=="?*", GOTO="udisks_probe_end"
|
||||
+ENV{DM_MULTIPATH_DEVICE_PATH}=="1", GOTO="udisks_probe_end"
|
||||
ENV{DM_UDEV_DISABLE_OTHER_RULES_FLAG}=="?*", GOTO="udisks_probe_end"
|
||||
|
||||
# MD-RAID (aka Linux Software RAID) members
|
||||
--
|
||||
2.19.0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (udisks-2.8.0.tar.bz2) = 3814c4c02fbadc58d9e3a6615f015d385648211f12075ce46eb0016605f102fa0c8eeca152f2e03491522b484c43039901bf8f1be2f469ac35b1b6259e7e0ceb
|
||||
SHA512 (udisks-2.8.1.tar.bz2) = a3c7d26cd1bbd9cce59b25d118076c34482a698d7dca9e0468b6f9c928f40c8dbdd0b1cb61cf288ae77151643dc4a3eacf31e22af2c7b35a2828e49ee335e70b
|
||||
|
15
udisks2.spec
15
udisks2.spec
@ -18,6 +18,9 @@
|
||||
%define default_luks_encryption luks1
|
||||
|
||||
%define is_fedora 0%{?rhel} == 0
|
||||
%define is_git %(git show > /dev/null 2>&1 && echo 1 || echo 0)
|
||||
%define git_hash %(git log -1 --pretty=format:"%h" || true)
|
||||
%define build_date %(date '+%Y%m%d')
|
||||
|
||||
|
||||
# bcache is not available on RHEL
|
||||
@ -55,16 +58,12 @@
|
||||
|
||||
Name: udisks2
|
||||
Summary: Disk Manager
|
||||
Version: 2.8.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.8.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: https://github.com/storaged-project/udisks
|
||||
Source0: https://github.com/storaged-project/udisks/releases/download/udisks-%{version}/udisks-%{version}.tar.bz2
|
||||
# https://github.com/storaged-project/udisks/pull/576
|
||||
# Fix udev multipath device check for device-mapper-multipath 0.7.7+
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1628192
|
||||
Patch0: 0001-Fix-DM_MULTIPATH_DEVICE_PATH-in-udev-rules.patch
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
|
||||
@ -268,7 +267,6 @@ This package contains module for VDO management.
|
||||
|
||||
%prep
|
||||
%setup -q -n udisks-%{version}
|
||||
%patch0 -p1
|
||||
sed -i udisks/udisks2.conf.in -e "s/encryption=luks1/encryption=%{default_luks_encryption}/"
|
||||
|
||||
%build
|
||||
@ -442,6 +440,9 @@ udevadm trigger
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Sep 26 2018 Vojtech Trefny <vtrefny@redhat.com> - 2.8.1-1
|
||||
- Version 2.8.1
|
||||
|
||||
* Fri Sep 14 2018 Adam Williamson <awilliam@redhat.com> - 2.8.0-2
|
||||
- Backport PR #576 to fix udev multipath device check (see RHBZ#1628192)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user