New udisks upstream release 2.7.1
This commit is contained in:
parent
c06b73f255
commit
440320f8a2
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/udisks-2.6.4.tar.bz2
|
||||
/udisks-2.6.5.tar.bz2
|
||||
/udisks-2.7.0.tar.bz2
|
||||
/udisks-2.7.1.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (udisks-2.7.0.tar.bz2) = b04c6c2e40f052a83243f245f60446ef1664e528ee1554f777e89e3eefbcf26dac37ad5db8f255fd7cc2c1cae2813a33c7d51bbca062436785471e69456ffe20
|
||||
SHA512 (udisks-2.7.1.tar.bz2) = 0821ab3d182335bb7e2aa07432bcdaeb5744d886fda39d19a5f2c96d25fc76a48bc343785c854d2c377c9d9ccfdd95435149c702fef70371d2c94dc79e95e9b5
|
||||
|
@ -1,37 +0,0 @@
|
||||
From c6fab8ce4149496eb03205f7ce5fe15ca72c8bb7 Mon Sep 17 00:00:00 2001
|
||||
From: Vojtech Trefny <vtrefny@redhat.com>
|
||||
Date: Mon, 19 Jun 2017 13:37:16 +0200
|
||||
Subject: [PATCH] UDisksClient: Do not try remove changed_blacklist hash table
|
||||
in finalize
|
||||
|
||||
"changed_blacklist" table is a class member and we really don't
|
||||
want to destroy it when destroying one instance of the UDisksClient.
|
||||
---
|
||||
udisks/udisksclient.c | 7 -------
|
||||
1 file changed, 7 deletions(-)
|
||||
|
||||
diff --git a/udisks/udisksclient.c b/udisks/udisksclient.c
|
||||
index e2cd9a38..e961c655 100644
|
||||
--- a/udisks/udisksclient.c
|
||||
+++ b/udisks/udisksclient.c
|
||||
@@ -127,7 +127,6 @@ static void
|
||||
udisks_client_finalize (GObject *object)
|
||||
{
|
||||
UDisksClient *client = UDISKS_CLIENT (object);
|
||||
- UDisksClientClass *client_class = UDISKS_CLIENT_GET_CLASS (client);
|
||||
|
||||
if (client->changed_timeout_source != NULL)
|
||||
g_source_destroy (client->changed_timeout_source);
|
||||
@@ -135,12 +134,6 @@ udisks_client_finalize (GObject *object)
|
||||
if (client->initialization_error != NULL)
|
||||
g_clear_error (&(client->initialization_error));
|
||||
|
||||
- if (client_class->changed_blacklist != NULL)
|
||||
- {
|
||||
- g_hash_table_destroy (client_class->changed_blacklist);
|
||||
- client_class->changed_blacklist = NULL;
|
||||
- }
|
||||
-
|
||||
/* might be NULL if failing early in the constructor */
|
||||
if (client->object_manager != NULL)
|
||||
{
|
@ -1,35 +0,0 @@
|
||||
From 192a17d1a89d098a8df7e8b6d1e23c1005597fd5 Mon Sep 17 00:00:00 2001
|
||||
From: Vratislav Podzimek <vpodzime@redhat.com>
|
||||
Date: Fri, 16 Jun 2017 11:59:57 +0200
|
||||
Subject: [PATCH] Fix how UDisksClient filters property changes
|
||||
|
||||
The value returned from g_strcmp0() is not a boolean. And a
|
||||
GVariantIter has to be initialized before use.
|
||||
---
|
||||
udisks/udisksclient.c | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/udisks/udisksclient.c b/udisks/udisksclient.c
|
||||
index ae9364d6..e2cd9a38 100644
|
||||
--- a/udisks/udisksclient.c
|
||||
+++ b/udisks/udisksclient.c
|
||||
@@ -1566,14 +1566,15 @@ on_interface_proxy_properties_changed (GDBusObjectManagerClient *manager,
|
||||
UDisksClient *client = UDISKS_CLIENT (user_data);
|
||||
UDisksClientClass *client_class = UDISKS_CLIENT_GET_CLASS (client);
|
||||
|
||||
- GVariantIter *iter = NULL;
|
||||
- const gchar *property_name = NULL;
|
||||
+ GVariantIter iter;
|
||||
+ gchar *property_name = NULL;
|
||||
|
||||
/* never emit the change signal for Job objects */
|
||||
- if (g_strcmp0 (g_dbus_proxy_get_interface_name (interface_proxy), "org.freedesktop.UDisks2.Drive.Job"))
|
||||
+ if (g_strcmp0 (g_dbus_proxy_get_interface_name (interface_proxy), "org.freedesktop.UDisks2.Drive.Job") == 0)
|
||||
return;
|
||||
|
||||
- while (g_variant_iter_next (iter, "{&sv}", &property_name, NULL))
|
||||
+ g_variant_iter_init (&iter, changed_properties);
|
||||
+ while (g_variant_iter_next (&iter, "{&sv}", &property_name, NULL))
|
||||
{
|
||||
if (! g_hash_table_contains (client_class->changed_blacklist, property_name))
|
||||
{
|
12
udisks2.spec
12
udisks2.spec
@ -5,7 +5,6 @@
|
||||
%global libatasmart_version 0.17
|
||||
%global dbus_version 1.4.0
|
||||
%global with_gtk_doc 1
|
||||
%global with_libblockdev_part 1
|
||||
%global libblockdev_version 2.4
|
||||
|
||||
%define is_fedora 0%{?rhel} == 0
|
||||
@ -15,14 +14,12 @@
|
||||
|
||||
Name: udisks2
|
||||
Summary: Disk Manager
|
||||
Version: 2.7.0
|
||||
Release: 3%{?dist}
|
||||
Version: 2.7.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: https://github.com/storaged-project/udisks
|
||||
Source0: https://github.com/storaged-project/udisks/releases/download/udisks-%{version}/udisks-%{version}.tar.bz2
|
||||
Patch0: udisks-2.7.0-fix-changed-signal-filtering.patch
|
||||
Patch1: udisks-2.7.0-do-not-try-remove-changed_blacklist-hashtable.patch
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
|
||||
@ -203,8 +200,6 @@ This package contains module for ZRAM configuration.
|
||||
|
||||
%prep
|
||||
%setup -q -n udisks-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
autoreconf -ivf
|
||||
@ -347,6 +342,9 @@ udevadm trigger
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 03 2017 Vojtech Trefny <vtrefny@redhat.com> - 2.7.1-1
|
||||
- Version 2.7.1
|
||||
|
||||
* Tue Jun 20 2017 Vojtech Trefny <vtrefny@redhat.com> - 2.7.0-3
|
||||
- Do not try to remove changed_blacklist hash table in finalize
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user