import CS udica-0.2.8-2.el9
This commit is contained in:
parent
e60f9fefbc
commit
2eaeb6418c
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,170 @@
|
|||||||
|
From d444e67ead27266d57184ab8bc032c5528f7e26c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Vit Mojzis <vmojzis@redhat.com>
|
||||||
|
Date: Wed, 20 Dec 2023 14:33:27 +0100
|
||||||
|
Subject: [PATCH] Add tests covering confined user policy generation
|
||||||
|
|
||||||
|
Signed-off-by: Vit Mojzis <vmojzis@redhat.com>
|
||||||
|
---
|
||||||
|
tests/test_confined_abcdgilmns.cil | 24 ++++++++++++++++++++
|
||||||
|
tests/test_confined_cla.cil | 15 +++++++++++++
|
||||||
|
tests/test_confined_lb.cil | 12 ++++++++++
|
||||||
|
tests/test_confined_lsid.cil | 17 +++++++++++++++
|
||||||
|
tests/test_main.py | 35 +++++++++++++++++++++++++-----
|
||||||
|
5 files changed, 98 insertions(+), 5 deletions(-)
|
||||||
|
create mode 100644 tests/test_confined_abcdgilmns.cil
|
||||||
|
create mode 100644 tests/test_confined_cla.cil
|
||||||
|
create mode 100644 tests/test_confined_lb.cil
|
||||||
|
create mode 100644 tests/test_confined_lsid.cil
|
||||||
|
|
||||||
|
diff --git a/tests/test_confined_abcdgilmns.cil b/tests/test_confined_abcdgilmns.cil
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..5fd619f
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/test_confined_abcdgilmns.cil
|
||||||
|
@@ -0,0 +1,24 @@
|
||||||
|
+(boolean my_container_exec_content true)
|
||||||
|
+(role my_container_r)
|
||||||
|
+(type my_container_dbus_t)
|
||||||
|
+(type my_container_gkeyringd_t)
|
||||||
|
+(type my_container_ssh_agent_t)
|
||||||
|
+(type my_container_sudo_t)
|
||||||
|
+(type my_container_sudo_tmp_t)
|
||||||
|
+(type my_container_t)
|
||||||
|
+(type my_container_userhelper_t)
|
||||||
|
+(user my_container_u)
|
||||||
|
+(userrole my_container_u my_container_r)
|
||||||
|
+(userlevel my_container_u (s0))
|
||||||
|
+(userrange my_container_u ((s0 ) (s0 (c0))))
|
||||||
|
+
|
||||||
|
+(call confinedom_admin_commands_macro (my_container_t my_container_r my_container_sudo_t))
|
||||||
|
+(call confinedom_graphical_login_macro (my_container_t my_container_r my_container_dbus_t))
|
||||||
|
+(call confinedom_mozilla_usage_macro (my_container_t my_container_r))
|
||||||
|
+(call confinedom_networking_macro (my_container_t my_container_r))
|
||||||
|
+(call confinedom_security_advanced_macro (my_container_t my_container_r my_container_sudo_t my_container_userhelper_t))
|
||||||
|
+(call confinedom_security_basic_macro (my_container_t my_container_r))
|
||||||
|
+(call confinedom_sudo_macro (my_container_t my_container_r my_container_sudo_t my_container_sudo_tmp_t))
|
||||||
|
+(call confinedom_user_login_macro (my_container_t my_container_r my_container_gkeyringd_t my_container_dbus_t my_container_exec_content))
|
||||||
|
+(call confined_ssh_connect_macro (my_container_t my_container_r my_container_ssh_agent_t))
|
||||||
|
+(call confined_use_basic_commands_macro (my_container_t my_container_r))
|
||||||
|
\ No newline at end of file
|
||||||
|
diff --git a/tests/test_confined_cla.cil b/tests/test_confined_cla.cil
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..a633aaa
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/test_confined_cla.cil
|
||||||
|
@@ -0,0 +1,15 @@
|
||||||
|
+(boolean my_container_exec_content true)
|
||||||
|
+(role my_container_r)
|
||||||
|
+(type my_container_dbus_t)
|
||||||
|
+(type my_container_gkeyringd_t)
|
||||||
|
+(type my_container_ssh_agent_t)
|
||||||
|
+(type my_container_sudo_t)
|
||||||
|
+(type my_container_t)
|
||||||
|
+(user my_container_u)
|
||||||
|
+(userrole my_container_u my_container_r)
|
||||||
|
+(userlevel my_container_u (s0))
|
||||||
|
+(userrange my_container_u ((s0 ) (s0 (c0))))
|
||||||
|
+
|
||||||
|
+(call confinedom_admin_commands_macro (my_container_t my_container_r my_container_sudo_t))
|
||||||
|
+(call confinedom_user_login_macro (my_container_t my_container_r my_container_gkeyringd_t my_container_dbus_t my_container_exec_content))
|
||||||
|
+(call confined_ssh_connect_macro (my_container_t my_container_r my_container_ssh_agent_t))
|
||||||
|
\ No newline at end of file
|
||||||
|
diff --git a/tests/test_confined_lb.cil b/tests/test_confined_lb.cil
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..3e3c997
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/test_confined_lb.cil
|
||||||
|
@@ -0,0 +1,12 @@
|
||||||
|
+(boolean my_container_exec_content true)
|
||||||
|
+(role my_container_r)
|
||||||
|
+(type my_container_dbus_t)
|
||||||
|
+(type my_container_gkeyringd_t)
|
||||||
|
+(type my_container_t)
|
||||||
|
+(user my_container_u)
|
||||||
|
+(userrole my_container_u my_container_r)
|
||||||
|
+(userlevel my_container_u (s0))
|
||||||
|
+(userrange my_container_u ((s0 ) (s0 (c0))))
|
||||||
|
+
|
||||||
|
+(call confinedom_user_login_macro (my_container_t my_container_r my_container_gkeyringd_t my_container_dbus_t my_container_exec_content))
|
||||||
|
+(call confined_use_basic_commands_macro (my_container_t my_container_r))
|
||||||
|
\ No newline at end of file
|
||||||
|
diff --git a/tests/test_confined_lsid.cil b/tests/test_confined_lsid.cil
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..8719420
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/test_confined_lsid.cil
|
||||||
|
@@ -0,0 +1,17 @@
|
||||||
|
+(boolean my_container_exec_content true)
|
||||||
|
+(role my_container_r)
|
||||||
|
+(type my_container_dbus_t)
|
||||||
|
+(type my_container_gkeyringd_t)
|
||||||
|
+(type my_container_sudo_t)
|
||||||
|
+(type my_container_sudo_tmp_t)
|
||||||
|
+(type my_container_t)
|
||||||
|
+(type my_container_userhelper_t)
|
||||||
|
+(user my_container_u)
|
||||||
|
+(userrole my_container_u my_container_r)
|
||||||
|
+(userlevel my_container_u (s0))
|
||||||
|
+(userrange my_container_u ((s0 ) (s0 (c0))))
|
||||||
|
+
|
||||||
|
+(call confinedom_security_advanced_macro (my_container_t my_container_r my_container_sudo_t my_container_userhelper_t))
|
||||||
|
+(call confinedom_security_basic_macro (my_container_t my_container_r))
|
||||||
|
+(call confinedom_sudo_macro (my_container_t my_container_r my_container_sudo_t my_container_sudo_tmp_t))
|
||||||
|
+(call confinedom_user_login_macro (my_container_t my_container_r my_container_gkeyringd_t my_container_dbus_t my_container_exec_content))
|
||||||
|
\ No newline at end of file
|
||||||
|
diff --git a/tests/test_main.py b/tests/test_main.py
|
||||||
|
index fb6a9ab..0c73861 100644
|
||||||
|
--- a/tests/test_main.py
|
||||||
|
+++ b/tests/test_main.py
|
||||||
|
@@ -369,7 +369,26 @@ class TestBase(unittest.TestCase):
|
||||||
|
self.assert_templates(output, ["base_container"])
|
||||||
|
self.assert_policy(test_file("test_devices.podman.cil"))
|
||||||
|
|
||||||
|
- def run_udica(self, args):
|
||||||
|
+ # Confined user tests
|
||||||
|
+ def test_confined_user(self):
|
||||||
|
+ """udica confined_user <args> --level s0 --range s0:c0 my_container"""
|
||||||
|
+ for arg in ["cla", "lb", "lsid", "abcdgilmns"]:
|
||||||
|
+ output = self.run_udica(
|
||||||
|
+ [
|
||||||
|
+ "udica",
|
||||||
|
+ "confined_user",
|
||||||
|
+ "-{}".format(arg),
|
||||||
|
+ "--level",
|
||||||
|
+ "s0",
|
||||||
|
+ "--range",
|
||||||
|
+ "s0:c0",
|
||||||
|
+ "my_container",
|
||||||
|
+ ],
|
||||||
|
+ True,
|
||||||
|
+ )
|
||||||
|
+ self.assert_policy(test_file("test_confined_{}.cil".format(arg)))
|
||||||
|
+
|
||||||
|
+ def run_udica(self, args, confined=False):
|
||||||
|
with patch("sys.argv", args):
|
||||||
|
with patch("sys.stderr.write") as mock_err, patch(
|
||||||
|
"sys.stdout.write"
|
||||||
|
@@ -383,10 +402,16 @@ class TestBase(unittest.TestCase):
|
||||||
|
udica.__main__.main()
|
||||||
|
mock_err.assert_not_called()
|
||||||
|
|
||||||
|
- self.assertRegex(mock_out.output, "Policy my_container created")
|
||||||
|
- self.assertRegex(
|
||||||
|
- mock_out.output, "--security-opt label=type:my_container.process"
|
||||||
|
- )
|
||||||
|
+ if confined:
|
||||||
|
+ self.assertRegex(mock_out.output, "semodule -i my_container.cil")
|
||||||
|
+ self.assertRegex(
|
||||||
|
+ mock_out.output, "semanage login -a -s my_container_u my_container"
|
||||||
|
+ )
|
||||||
|
+ else:
|
||||||
|
+ self.assertRegex(mock_out.output, "Policy my_container created")
|
||||||
|
+ self.assertRegex(
|
||||||
|
+ mock_out.output, "--security-opt label=type:my_container.process"
|
||||||
|
+ )
|
||||||
|
|
||||||
|
return mock_out.output
|
||||||
|
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
57
SOURCES/0003-confined-make-l-non-optional.patch
Normal file
57
SOURCES/0003-confined-make-l-non-optional.patch
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
From f411c146986fabe7375724528b2d4ba8cf78b904 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Vit Mojzis <vmojzis@redhat.com>
|
||||||
|
Date: Mon, 12 Feb 2024 19:38:14 +0100
|
||||||
|
Subject: [PATCH] confined: make "-l" non optional
|
||||||
|
|
||||||
|
The confinedom_user_login_macro is needed for all custom users.
|
||||||
|
|
||||||
|
Also, allow the new user type to be accessed via remote login.
|
||||||
|
|
||||||
|
Signed-off-by: Vit Mojzis <vmojzis@redhat.com>
|
||||||
|
---
|
||||||
|
udica/__main__.py | 2 +-
|
||||||
|
udica/macros/confined_user_macros.cil | 8 +++++++-
|
||||||
|
2 files changed, 8 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/udica/__main__.py b/udica/__main__.py
|
||||||
|
index 1ba8515..801499c 100644
|
||||||
|
--- a/udica/__main__.py
|
||||||
|
+++ b/udica/__main__.py
|
||||||
|
@@ -92,7 +92,7 @@ def get_args():
|
||||||
|
"-l",
|
||||||
|
"--user_login",
|
||||||
|
action="store_true",
|
||||||
|
- default=False,
|
||||||
|
+ default=True,
|
||||||
|
dest="user_login",
|
||||||
|
help="Basic rules common to all users (tty, pty, ...)",
|
||||||
|
)
|
||||||
|
diff --git a/udica/macros/confined_user_macros.cil b/udica/macros/confined_user_macros.cil
|
||||||
|
index ddb5689..06c4c56 100644
|
||||||
|
--- a/udica/macros/confined_user_macros.cil
|
||||||
|
+++ b/udica/macros/confined_user_macros.cil
|
||||||
|
@@ -2411,7 +2411,7 @@
|
||||||
|
(typetransition utype sudo_exec_t process sudo_type)
|
||||||
|
(allow sudo_type utype (fd (use)))
|
||||||
|
(allow sudo_type utype (fifo_file (ioctl read write getattr lock append)))
|
||||||
|
- (allow sudo_type utype (process (sigchld)))
|
||||||
|
+ (allow sudo_type utype (process (getpgid sigchld)))
|
||||||
|
(allow sudo_type bin_t (dir (getattr open search)))
|
||||||
|
(allow sudo_type bin_t (dir (ioctl read getattr lock open search)))
|
||||||
|
(allow sudo_type bin_t (dir (getattr open search)))
|
||||||
|
@@ -4006,6 +4006,12 @@
|
||||||
|
)
|
||||||
|
)
|
||||||
|
)
|
||||||
|
+ ; Telnet login
|
||||||
|
+ (optional confinedom_user_login_optional_3
|
||||||
|
+ (typeattributeset cil_gen_require remote_login_t)
|
||||||
|
+ (allow remote_login_t utype (process (signal transition)))
|
||||||
|
+ (allow utype self (bpf (prog_load)))
|
||||||
|
+ )
|
||||||
|
)
|
||||||
|
|
||||||
|
(macro confined_ssh_connect_macro ((type utype) (role urole) (type ssh_agent_type))
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
@ -0,0 +1,31 @@
|
|||||||
|
From 131d228c6a91eaaeccc1d000821beeccba69d134 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Vit Mojzis <vmojzis@redhat.com>
|
||||||
|
Date: Mon, 4 Mar 2024 12:59:53 +0100
|
||||||
|
Subject: [PATCH] confined: allow asynchronous I/O operations
|
||||||
|
|
||||||
|
Signed-off-by: Vit Mojzis <vmojzis@redhat.com>
|
||||||
|
---
|
||||||
|
udica/macros/confined_user_macros.cil | 7 +++++++
|
||||||
|
1 file changed, 7 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/udica/macros/confined_user_macros.cil b/udica/macros/confined_user_macros.cil
|
||||||
|
index 06c4c56..dcb5198 100644
|
||||||
|
--- a/udica/macros/confined_user_macros.cil
|
||||||
|
+++ b/udica/macros/confined_user_macros.cil
|
||||||
|
@@ -4012,6 +4012,13 @@
|
||||||
|
(allow remote_login_t utype (process (signal transition)))
|
||||||
|
(allow utype self (bpf (prog_load)))
|
||||||
|
)
|
||||||
|
+ ; asynchronous I/O operations RHEL 10
|
||||||
|
+ (optional confinedom_user_login_optional_4
|
||||||
|
+ (typeattributeset cil_gen_require io_uring_t)
|
||||||
|
+ (allow utype self (io_uring (sqpoll)))
|
||||||
|
+ (allow utype io_uring_t (anon_inode (create)))
|
||||||
|
+ (allow utype io_uring_t (anon_inode (read write getattr map)))
|
||||||
|
+ )
|
||||||
|
)
|
||||||
|
|
||||||
|
(macro confined_ssh_connect_macro ((type utype) (role urole) (type ssh_agent_type))
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
@ -1,8 +1,13 @@
|
|||||||
Summary: A tool for generating SELinux security policies for containers
|
Summary: A tool for generating SELinux security policies for containers
|
||||||
Name: udica
|
Name: udica
|
||||||
Version: 0.2.8
|
Version: 0.2.8
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Source0: https://github.com/containers/udica/archive/v%{version}.tar.gz
|
Source0: https://github.com/containers/udica/archive/v%{version}.tar.gz
|
||||||
|
#git format-patch -N v0.2.8 -- . ':!.cirrus.yml' ':!.github'
|
||||||
|
Patch0001: 0001-Add-option-to-generate-custom-policy-for-a-confined-.patch
|
||||||
|
Patch0002: 0002-Add-tests-covering-confined-user-policy-generation.patch
|
||||||
|
Patch0003: 0003-confined-make-l-non-optional.patch
|
||||||
|
Patch0004: 0004-confined-allow-asynchronous-I-O-operations.patch
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Url: https://github.com/containers/udica
|
Url: https://github.com/containers/udica
|
||||||
@ -37,6 +42,7 @@ inspection of container JSON file.
|
|||||||
%{__python2} setup.py install --single-version-externally-managed --root=%{buildroot}
|
%{__python2} setup.py install --single-version-externally-managed --root=%{buildroot}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
install --directory %{buildroot}%{_datadir}/udica/macros
|
||||||
install --directory %{buildroot}%{_mandir}/man8
|
install --directory %{buildroot}%{_mandir}/man8
|
||||||
install -m 0644 udica/man/man8/udica.8 %{buildroot}%{_mandir}/man8/udica.8
|
install -m 0644 udica/man/man8/udica.8 %{buildroot}%{_mandir}/man8/udica.8
|
||||||
|
|
||||||
@ -45,7 +51,9 @@ install -m 0644 udica/man/man8/udica.8 %{buildroot}%{_mandir}/man8/udica.8
|
|||||||
%{_bindir}/udica
|
%{_bindir}/udica
|
||||||
%dir %{_datadir}/udica
|
%dir %{_datadir}/udica
|
||||||
%dir %{_datadir}/udica/ansible
|
%dir %{_datadir}/udica/ansible
|
||||||
|
%dir %{_datadir}/udica/macros
|
||||||
%{_datadir}/udica/ansible/*
|
%{_datadir}/udica/ansible/*
|
||||||
|
%{_datadir}/udica/macros/*
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
@ -58,6 +66,12 @@ install -m 0644 udica/man/man8/udica.8 %{buildroot}%{_mandir}/man8/udica.8
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 05 2024 Vit Mojzis <vmojzis@redhat.com> - 0.2.8-2
|
||||||
|
- Add option to generate custom policy for a confined user (RHEL-28166)
|
||||||
|
- Add tests covering confined user policy generation
|
||||||
|
- confined: make "-l" non optional
|
||||||
|
- confined: allow asynchronous I/O operations
|
||||||
|
|
||||||
* Thu Nov 30 2023 Vit Mojzis <vmojzis@redhat.com> - 0.2.8-1
|
* Thu Nov 30 2023 Vit Mojzis <vmojzis@redhat.com> - 0.2.8-1
|
||||||
- Improve code readability based on lint and black findings
|
- Improve code readability based on lint and black findings
|
||||||
- Fix generating policy for Crio mounts
|
- Fix generating policy for Crio mounts
|
||||||
|
Loading…
Reference in New Issue
Block a user