Update to upstream release 1.17.0
Resolves: RHEL-24811 Signed-off-by: Kamal Heib <kheib@redhat.com>
This commit is contained in:
parent
a950e6149c
commit
eeacfc5ada
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@
|
|||||||
/ucx-1.13.1.tar.gz
|
/ucx-1.13.1.tar.gz
|
||||||
/ucx-1.14.1.tar.gz
|
/ucx-1.14.1.tar.gz
|
||||||
/ucx-1.15.0.tar.gz
|
/ucx-1.15.0.tar.gz
|
||||||
|
/ucx-1.17.0.tar.gz
|
||||||
|
29
UCS-TIME-Fix-undeclared-INFINITY-error-in-ucs_time_u.patch
Normal file
29
UCS-TIME-Fix-undeclared-INFINITY-error-in-ucs_time_u.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From b0a275a5492125a13020cd095fe9934e0b5e7c6a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Aboorva Devarajan <aboorvad@linux.ibm.com>
|
||||||
|
Date: Wed, 19 Jun 2024 13:47:14 -0400
|
||||||
|
Subject: [PATCH] UCS/TIME: Fix undeclared INFINITY error in
|
||||||
|
ucs_time_units_to_sec()
|
||||||
|
|
||||||
|
Included <math.h> in ucs_time_units_to_sec() to resolve compilation
|
||||||
|
errors due to missing INFINITY constant.
|
||||||
|
|
||||||
|
Signed-off-by: Aboorva Devarajan <aboorvad@linux.ibm.com>
|
||||||
|
---
|
||||||
|
src/ucs/time/time.h | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/ucs/time/time.h b/src/ucs/time/time.h
|
||||||
|
index cff9810cdad8..c51362273f8d 100644
|
||||||
|
--- a/src/ucs/time/time.h
|
||||||
|
+++ b/src/ucs/time/time.h
|
||||||
|
@@ -11,6 +11,7 @@
|
||||||
|
#include <ucs/time/time_def.h>
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <limits.h>
|
||||||
|
+#include <math.h>
|
||||||
|
|
||||||
|
BEGIN_C_DECLS
|
||||||
|
|
||||||
|
--
|
||||||
|
2.47.0
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (ucx-1.15.0.tar.gz) = 8ad9d4bc09a890ffae74c71496221d6ad710116e25531e867f78a84ff90808fe8859d856e261f536e89fba8d7d1b6ed3f7cf5054b6e34edee1bea19d5fdd1e0b
|
SHA512 (ucx-1.17.0.tar.gz) = 1033959bd223d1b4507b2a159e6ce65e76c1c5f231afc166bb0ed2e5c6c4aaa3db96b7c35c97c8b332e6e11f4ab24deb66d484009b7dc2af52b73981c1e72a25
|
||||||
|
12
ucx.spec
12
ucx.spec
@ -11,8 +11,8 @@
|
|||||||
%bcond_with vfs
|
%bcond_with vfs
|
||||||
|
|
||||||
Name: ucx
|
Name: ucx
|
||||||
Version: 1.15.0
|
Version: 1.17.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: UCX is a communication library implementing high-performance messaging
|
Summary: UCX is a communication library implementing high-performance messaging
|
||||||
|
|
||||||
License: BSD-3-Clause AND MIT AND CC-PDDC AND (BSD-3-Clause OR Apache-2.0)
|
License: BSD-3-Clause AND MIT AND CC-PDDC AND (BSD-3-Clause OR Apache-2.0)
|
||||||
@ -31,6 +31,7 @@ Source: https://github.com/openucx/%{name}/releases/download/v%{version}/ucx-%{v
|
|||||||
# BUILD/CONFIG: Keep CFLAGS and CXXFLAGS separate
|
# BUILD/CONFIG: Keep CFLAGS and CXXFLAGS separate
|
||||||
# Fixes build for https://fedoraproject.org/wiki/Changes/PortingToModernC
|
# Fixes build for https://fedoraproject.org/wiki/Changes/PortingToModernC
|
||||||
Patch0: https://github.com/openucx/%{name}/pull/9558.patch
|
Patch0: https://github.com/openucx/%{name}/pull/9558.patch
|
||||||
|
Patch1: UCS-TIME-Fix-undeclared-INFINITY-error-in-ucs_time_u.patch
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
@ -98,6 +99,7 @@ Provides header files and examples for developing with UCX.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch -P0 -p1
|
%patch -P0 -p1
|
||||||
|
%patch -P1 -p1
|
||||||
autoreconf -fiv
|
autoreconf -fiv
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -135,6 +137,7 @@ rm -f %{buildroot}%{_libdir}/ucx/lib*.a
|
|||||||
%{_libdir}/lib*.so.*
|
%{_libdir}/lib*.so.*
|
||||||
%{_bindir}/ucx_info
|
%{_bindir}/ucx_info
|
||||||
%{_bindir}/ucx_perftest
|
%{_bindir}/ucx_perftest
|
||||||
|
%{_bindir}/ucx_perftest_daemon
|
||||||
%{_bindir}/ucx_read_profile
|
%{_bindir}/ucx_read_profile
|
||||||
%{_bindir}/io_demo
|
%{_bindir}/io_demo
|
||||||
%{_datadir}/ucx
|
%{_datadir}/ucx
|
||||||
@ -142,6 +145,7 @@ rm -f %{buildroot}%{_libdir}/ucx/lib*.a
|
|||||||
%doc README AUTHORS NEWS
|
%doc README AUTHORS NEWS
|
||||||
%{!?_licensedir:%global license %%doc}
|
%{!?_licensedir:%global license %%doc}
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
|
%{_sysconfdir}/ucx/ucx.conf
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/uc*
|
%{_includedir}/uc*
|
||||||
@ -317,6 +321,10 @@ status, and more.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 13 2024 Kamal Heib <kheib@redhat.com> - 1.17.0-1
|
||||||
|
- Update to upstream release 1.17.0
|
||||||
|
Resolves: RHEL-24811
|
||||||
|
|
||||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 1.15.0-4
|
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 1.15.0-4
|
||||||
- Bump release for October 2024 mass rebuild:
|
- Bump release for October 2024 mass rebuild:
|
||||||
Resolves: RHEL-64018
|
Resolves: RHEL-64018
|
||||||
|
Loading…
Reference in New Issue
Block a user