Fix build for ppc64le
Resolves: RHEL-52883 Signed-off-by: Kamal Heib <kheib@redhat.com>
This commit is contained in:
parent
bc21fcecaa
commit
9f5f99d3dd
29
UCS-TIME-Fix-undeclared-INFINITY-error-in-ucs_time_u.patch
Normal file
29
UCS-TIME-Fix-undeclared-INFINITY-error-in-ucs_time_u.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From b0a275a5492125a13020cd095fe9934e0b5e7c6a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Aboorva Devarajan <aboorvad@linux.ibm.com>
|
||||||
|
Date: Wed, 19 Jun 2024 13:47:14 -0400
|
||||||
|
Subject: [PATCH] UCS/TIME: Fix undeclared INFINITY error in
|
||||||
|
ucs_time_units_to_sec()
|
||||||
|
|
||||||
|
Included <math.h> in ucs_time_units_to_sec() to resolve compilation
|
||||||
|
errors due to missing INFINITY constant.
|
||||||
|
|
||||||
|
Signed-off-by: Aboorva Devarajan <aboorvad@linux.ibm.com>
|
||||||
|
---
|
||||||
|
src/ucs/time/time.h | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/ucs/time/time.h b/src/ucs/time/time.h
|
||||||
|
index cff9810cdad8..c51362273f8d 100644
|
||||||
|
--- a/src/ucs/time/time.h
|
||||||
|
+++ b/src/ucs/time/time.h
|
||||||
|
@@ -11,6 +11,7 @@
|
||||||
|
#include <ucs/time/time_def.h>
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <limits.h>
|
||||||
|
+#include <math.h>
|
||||||
|
|
||||||
|
BEGIN_C_DECLS
|
||||||
|
|
||||||
|
--
|
||||||
|
2.47.0
|
||||||
|
|
9
ucx.spec
9
ucx.spec
@ -12,12 +12,13 @@
|
|||||||
|
|
||||||
Name: ucx
|
Name: ucx
|
||||||
Version: 1.17.0
|
Version: 1.17.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: UCX is a communication library implementing high-performance messaging
|
Summary: UCX is a communication library implementing high-performance messaging
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://www.openucx.org
|
URL: http://www.openucx.org
|
||||||
Source: https://github.com/openucx/%{name}/releases/download/v%{version}/ucx-%{version}.tar.gz
|
Source: https://github.com/openucx/%{name}/releases/download/v%{version}/ucx-%{version}.tar.gz
|
||||||
|
Patch0: UCS-TIME-Fix-undeclared-INFINITY-error-in-ucs_time_u.patch
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
@ -84,6 +85,8 @@ Provides header files and examples for developing with UCX.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch -P0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%define _with_arg() %{expand:%%{?with_%{1}:--with-%{2}}%%{!?with_%{1}:--without-%{2}}}
|
%define _with_arg() %{expand:%%{?with_%{1}:--with-%{2}}%%{!?with_%{1}:--without-%{2}}}
|
||||||
%define _enable_arg() %{expand:%%{?with_%{1}:--enable-%{2}}%%{!?with_%{1}:--disable-%{2}}}
|
%define _enable_arg() %{expand:%%{?with_%{1}:--enable-%{2}}%%{!?with_%{1}:--disable-%{2}}}
|
||||||
@ -290,6 +293,10 @@ library internals, protocol objects, transports status, and more.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 06 2024 Kamal Heib <kheib@redhat.com> - 1.17.0-2
|
||||||
|
- Fix build for ppc64le
|
||||||
|
- Resolves: RHEL-52883
|
||||||
|
|
||||||
* Wed Nov 06 2024 Kamal Heib <kheib@redhat.com> - 1.17.0-1
|
* Wed Nov 06 2024 Kamal Heib <kheib@redhat.com> - 1.17.0-1
|
||||||
- Update to upstream release 1.17.0
|
- Update to upstream release 1.17.0
|
||||||
- Resolves: RHEL-52883
|
- Resolves: RHEL-52883
|
||||||
|
Loading…
Reference in New Issue
Block a user