Bump version to 1.10.1
Related: rhbz#1858571 Signed-off-by: Honggang Li <honli@redhat.com>
This commit is contained in:
parent
862bfbc74d
commit
2b73bb620d
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
|||||||
/ucx-1.8.1-rc4.tar.gz
|
/ucx-1.8.1-rc4.tar.gz
|
||||||
/ucx-1.8.1.tar.gz
|
/ucx-1.8.1.tar.gz
|
||||||
/ucx-1.9.0.tar.gz
|
/ucx-1.9.0.tar.gz
|
||||||
|
/ucx-1.10.1.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (ucx-1.9.0.tar.gz) = 2e8507e9cbba9ea445efdf8be5b5128dfc76cce30111805e9f7a5618bbbbb77d2bb449b6ad5e415f086b3156b63128306671d3a906583248cde720edb4241c67
|
SHA512 (ucx-1.10.1.tar.gz) = 949d0583f655b1b08701acb38bc97d46f03644b496168dec57bc9477ab117966f6addbc266e4ba0ef95050b516bdf747773362d7b46ad1838d1972b14ff2bcd8
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
diff --git a/config/m4/sysdep.m4 b/config/m4/sysdep.m4
|
|
||||||
index b1e5485..0133803 100644
|
|
||||||
--- a/config/m4/sysdep.m4
|
|
||||||
+++ b/config/m4/sysdep.m4
|
|
||||||
@@ -158,7 +158,7 @@ AC_MSG_CHECKING([malloc hooks])
|
|
||||||
SAVE_CFLAGS=$CFLAGS
|
|
||||||
CFLAGS="$CFLAGS $CFLAGS_NO_DEPRECATED"
|
|
||||||
CHECK_CROSS_COMP([AC_LANG_SOURCE([#include <malloc.h>
|
|
||||||
- static int rc = 1;
|
|
||||||
+ static volatile int rc = 1;
|
|
||||||
void *ptr;
|
|
||||||
void *myhook(size_t size, const void *caller) {
|
|
||||||
rc = 0;
|
|
||||||
diff --git a/configure b/configure
|
|
||||||
index db54a6a..fa4352d 100755
|
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -22221,7 +22221,7 @@ CFLAGS="$CFLAGS $CFLAGS_NO_DEPRECATED"
|
|
||||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
||||||
/* end confdefs.h. */
|
|
||||||
#include <malloc.h>
|
|
||||||
- static int rc = 1;
|
|
||||||
+ volatile static int rc = 1;
|
|
||||||
void *ptr;
|
|
||||||
void *myhook(size_t size, const void *caller) {
|
|
||||||
rc = 0;
|
|
||||||
@@ -22252,7 +22252,7 @@ else
|
|
||||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
||||||
/* end confdefs.h. */
|
|
||||||
#include <malloc.h>
|
|
||||||
- static int rc = 1;
|
|
||||||
+ volatile static int rc = 1;
|
|
||||||
void *ptr;
|
|
||||||
void *myhook(size_t size, const void *caller) {
|
|
||||||
rc = 0;
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/ucs/datastruct/mpool.inl b/src/ucs/datastruct/mpool.inl
|
|
||||||
index d06e2f9..6b32406 100644
|
|
||||||
--- a/src/ucs/datastruct/mpool.inl
|
|
||||||
+++ b/src/ucs/datastruct/mpool.inl
|
|
||||||
@@ -71,7 +71,7 @@ static inline ucs_mpool_t *ucs_mpool_obj_owner(void *obj)
|
|
||||||
|
|
||||||
static inline void ucs_mpool_put_inline(void *obj)
|
|
||||||
{
|
|
||||||
- ucs_mpool_elem_t *elem;
|
|
||||||
+ ucs_mpool_elem_t * volatile elem;
|
|
||||||
ucs_mpool_t *mp;
|
|
||||||
|
|
||||||
elem = ucs_mpool_obj_to_elem(obj);
|
|
28
ucx.spec
28
ucx.spec
@ -15,19 +15,16 @@
|
|||||||
%bcond_with xpmem
|
%bcond_with xpmem
|
||||||
|
|
||||||
Name: ucx
|
Name: ucx
|
||||||
Version: 1.9.0
|
Version: 1.10.1
|
||||||
Release: 2%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: UCX is a communication library implementing high-performance messaging
|
Summary: UCX is a communication library implementing high-performance messaging
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://www.openucx.org
|
URL: http://www.openucx.org
|
||||||
Source: https://github.com/openucx/%{name}/releases/download/v%{version}/ucx-%{version}.tar.gz
|
Source: https://github.com/openucx/%{name}/releases/download/v1.10.1/ucx-1.10.1.tar.gz
|
||||||
Patch: ucx-config.patch
|
|
||||||
# This avoids a false positive from gcc-11 by making the problematic
|
|
||||||
# pointer volatile rather than disabling the warning completely
|
|
||||||
Patch1: %{name}-gcc11.patch
|
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
Prefix: %{_prefix}
|
||||||
|
|
||||||
# UCX currently supports only the following architectures
|
# UCX currently supports only the following architectures
|
||||||
ExclusiveArch: aarch64 ppc64le x86_64
|
ExclusiveArch: aarch64 ppc64le x86_64
|
||||||
@ -68,15 +65,16 @@ BuildRequires: xpmem-devel
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
UCX stands for Unified Communication X. UCX provides an optimized communication
|
UCX is an optimized communication framework for high-performance distributed
|
||||||
layer for Message Passing (MPI), PGAS/OpenSHMEM libraries and RPC/data-centric
|
|
||||||
applications. UCX utilizes high-speed networks, such as RDMA (InfiniBand, RoCE,
|
applications. UCX utilizes high-speed networks, such as RDMA (InfiniBand, RoCE,
|
||||||
etc), Cray Gemini or Aries, for inter-node communication. If no such network is
|
etc), Cray Gemini or Aries, for inter-node communication. If no such network is
|
||||||
available, TCP is used instead. UCX supports efficient transfer of data in
|
available, TCP is used instead. UCX supports efficient transfer of data in
|
||||||
either main memory (RAM) or GPU memory (through CUDA and ROCm libraries).
|
either main memory (RAM) or GPU memory (through CUDA and ROCm libraries). In
|
||||||
In addition, UCX provides efficient intra-node communication, by leveraging the
|
addition, UCX provides efficient intra-node communication, by leveraging the
|
||||||
following shared memory mechanisms: posix, sysv, cma, knem, and xpmem.
|
following shared memory mechanisms: posix, sysv, cma, knem, and xpmem.
|
||||||
This package was built from '' branch, commit 6b29558.
|
The acronym UCX stands for "Unified Communication X".
|
||||||
|
|
||||||
|
This package was built from '' branch, commit c334359.
|
||||||
|
|
||||||
%if "%{_vendor}" == "suse"
|
%if "%{_vendor}" == "suse"
|
||||||
%debug_package
|
%debug_package
|
||||||
@ -91,8 +89,6 @@ Provides header files and examples for developing with UCX.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch -p1
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%define _with_arg() %{expand:%%{?with_%{1}:--with-%{2}}%%{!?with_%{1}:--without-%{2}}}
|
%define _with_arg() %{expand:%%{?with_%{1}:--with-%{2}}%%{!?with_%{1}:--without-%{2}}}
|
||||||
@ -102,7 +98,6 @@ Provides header files and examples for developing with UCX.
|
|||||||
--disable-debug \
|
--disable-debug \
|
||||||
--disable-assertions \
|
--disable-assertions \
|
||||||
--disable-params-check \
|
--disable-params-check \
|
||||||
--enable-examples \
|
|
||||||
--without-java \
|
--without-java \
|
||||||
%_enable_arg cma cma \
|
%_enable_arg cma cma \
|
||||||
%_with_arg cuda cuda \
|
%_with_arg cuda cuda \
|
||||||
@ -128,6 +123,7 @@ rm -f %{buildroot}%{_libdir}/ucx/lib*.a
|
|||||||
%files
|
%files
|
||||||
%{_libdir}/lib*.so.*
|
%{_libdir}/lib*.so.*
|
||||||
%{_bindir}/uc*
|
%{_bindir}/uc*
|
||||||
|
%{_bindir}/io_demo
|
||||||
%{_datadir}/ucx
|
%{_datadir}/ucx
|
||||||
%exclude %{_datadir}/ucx/examples
|
%exclude %{_datadir}/ucx/examples
|
||||||
%doc README AUTHORS NEWS
|
%doc README AUTHORS NEWS
|
||||||
@ -293,6 +289,10 @@ process to map the memory of another process into its virtual address space.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 12 2021 Honggang Li <honli@redhat.com> - 1.10.1-2
|
||||||
|
- Bump version to 1.10.1
|
||||||
|
- Related: rhbz#1858571
|
||||||
|
|
||||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.9.0-2
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.9.0-2
|
||||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user