import tzdata-2020a-1.el8
This commit is contained in:
commit
ca1b416f18
4
.gitignore
vendored
Normal file
4
.gitignore
vendored
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
SOURCES/javazic-1.8-37392f2f5d59.tar.xz
|
||||||
|
SOURCES/javazic.tar.gz
|
||||||
|
SOURCES/tzcode2020a.tar.gz
|
||||||
|
SOURCES/tzdata2020a.tar.gz
|
4
.tzdata.metadata
Normal file
4
.tzdata.metadata
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
77292e1839952807567570118e01405b405af80c SOURCES/javazic-1.8-37392f2f5d59.tar.xz
|
||||||
|
ee8ad215161cd132e65e2be447b279457158b540 SOURCES/javazic.tar.gz
|
||||||
|
adda5022d02085cfe81862a6b8f60cd7df1dedde SOURCES/tzcode2020a.tar.gz
|
||||||
|
d9f29aab03246713e6c5b792f49871846b4cfeda SOURCES/tzdata2020a.tar.gz
|
12
SOURCES/0002-Fix-have-snprintf-error.patch
Normal file
12
SOURCES/0002-Fix-have-snprintf-error.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nrup a/Makefile b/Makefile
|
||||||
|
--- a/Makefile 2017-10-23 18:03:40.237177646 -0400
|
||||||
|
+++ b/Makefile 2017-10-23 18:06:20.060683518 -0400
|
||||||
|
@@ -292,7 +292,7 @@ GCC_DEBUG_FLAGS = -DGCC_LINT -g3 -O3 -fn
|
||||||
|
# January's first Monday when a "%V" format is used and January 1
|
||||||
|
# falls on a Friday, Saturday, or Sunday.
|
||||||
|
|
||||||
|
-CFLAGS=
|
||||||
|
+CFLAGS= -DHAVE_SNPRINTF=1
|
||||||
|
|
||||||
|
# Linker flags. Default to $(LFLAGS) for backwards compatibility
|
||||||
|
# to release 2012h and earlier.
|
44
SOURCES/7090844.patch
Normal file
44
SOURCES/7090844.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff --git a/7090844.patch b/7090844.patch
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..fd5b531
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/7090844.patch
|
||||||
|
@@ -0,0 +1,38 @@
|
||||||
|
+--- sun/tools/javazic/Mappings.java.orig 2015-04-13 12:42:30.000000000 -0400
|
||||||
|
++++ sun/tools/javazic/Mappings.java 2015-04-13 12:43:32.000000000 -0400
|
||||||
|
+@@ -1,5 +1,5 @@
|
||||||
|
+ /*
|
||||||
|
+- * Copyright (c) 2000, 2004, Oracle and/or its affiliates. All rights reserved.
|
||||||
|
++ * Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved.
|
||||||
|
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||||
|
+ *
|
||||||
|
+ * This code is free software; you can redistribute it and/or modify it
|
||||||
|
+@@ -26,9 +26,6 @@
|
||||||
|
+ package sun.tools.javazic;
|
||||||
|
+
|
||||||
|
+ import java.util.ArrayList;
|
||||||
|
+-import java.util.HashMap;
|
||||||
|
+-import java.util.HashSet;
|
||||||
|
+-import java.util.Iterator;
|
||||||
|
+ import java.util.LinkedList;
|
||||||
|
+ import java.util.List;
|
||||||
|
+ import java.util.Map;
|
||||||
|
+@@ -79,8 +76,8 @@
|
||||||
|
+ // If the GMT offset of this Zone will change in some
|
||||||
|
+ // future time, this Zone is added to the exclude list.
|
||||||
|
+ boolean isExcluded = false;
|
||||||
|
+- if (zone.size() > 1) {
|
||||||
|
+- ZoneRec zrec = zone.get(zone.size()-2);
|
||||||
|
++ for (int i = 0; i < zone.size(); i++) {
|
||||||
|
++ ZoneRec zrec = zone.get(i);
|
||||||
|
+ if ((zrec.getGmtOffset() != rawOffset)
|
||||||
|
+ && (zrec.getUntilTime(0) > Time.getCurrentTime())) {
|
||||||
|
+ if (excludeList == null) {
|
||||||
|
+@@ -88,6 +85,7 @@
|
||||||
|
+ }
|
||||||
|
+ excludeList.add(zone.getName());
|
||||||
|
+ isExcluded = true;
|
||||||
|
++ break;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+
|
44
SOURCES/7133138.patch
Normal file
44
SOURCES/7133138.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff --git a/7133138.patch b/7133138.patch
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..882f15f
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/7133138.patch
|
||||||
|
@@ -0,0 +1,38 @@
|
||||||
|
+--- sun/tools/javazic/Mappings.java.orig 2015-04-13 12:44:10.000000000 -0400
|
||||||
|
++++ sun/tools/javazic/Mappings.java 2015-04-13 12:45:28.000000000 -0400
|
||||||
|
+@@ -1,5 +1,5 @@
|
||||||
|
+ /*
|
||||||
|
+- * Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved.
|
||||||
|
++ * Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.
|
||||||
|
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||||
|
+ *
|
||||||
|
+ * This code is free software; you can redistribute it and/or modify it
|
||||||
|
+@@ -26,6 +26,7 @@
|
||||||
|
+ package sun.tools.javazic;
|
||||||
|
+
|
||||||
|
+ import java.util.ArrayList;
|
||||||
|
++import java.util.HashMap;
|
||||||
|
+ import java.util.LinkedList;
|
||||||
|
+ import java.util.List;
|
||||||
|
+ import java.util.Map;
|
||||||
|
+@@ -162,6 +163,20 @@
|
||||||
|
+ for (String key : toBeRemoved) {
|
||||||
|
+ aliases.remove(key);
|
||||||
|
+ }
|
||||||
|
++ // Eliminate any alias-to-alias mappings. For example, if
|
||||||
|
++ // there are A->B and B->C, A->B is changed to A->C.
|
||||||
|
++ Map<String, String> newMap = new HashMap<String, String>();
|
||||||
|
++ for (String key : aliases.keySet()) {
|
||||||
|
++ String realid = aliases.get(key);
|
||||||
|
++ String leaf = realid;
|
||||||
|
++ while (aliases.get(leaf) != null) {
|
||||||
|
++ leaf = aliases.get(leaf);
|
||||||
|
++ }
|
||||||
|
++ if (!realid.equals(leaf)) {
|
||||||
|
++ newMap.put(key, leaf);
|
||||||
|
++ }
|
||||||
|
++ }
|
||||||
|
++ aliases.putAll(newMap);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ Map<String,String> getAliases() {
|
17
SOURCES/8051641.patch
Normal file
17
SOURCES/8051641.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -r c8a71253d6e2 -r 189490f29d1e make/src/classes/build/tools/tzdb/ZoneRulesBuilder.java
|
||||||
|
--- javazic-1.8/build/tools/tzdb/ZoneRulesBuilder.java Thu Oct 23 11:42:20 2014 +0200
|
||||||
|
+++ javazic-1.8/build/tools/tzdb/ZoneRulesBuilder.java Mon Dec 29 21:42:22 2014 +0300
|
||||||
|
@@ -491,10 +491,10 @@
|
||||||
|
TZRule rule = new TZRule(year, month, dayOfMonthIndicator, dayOfWeek, time, timeEndOfDay, timeDefinition, savingAmountSecs);
|
||||||
|
if (lastRule) {
|
||||||
|
lastRuleList.add(rule);
|
||||||
|
- maxLastRuleStartYear = Math.max(startYear, maxLastRuleStartYear);
|
||||||
|
} else {
|
||||||
|
ruleList.add(rule);
|
||||||
|
}
|
||||||
|
+ maxLastRuleStartYear = Math.max(startYear, maxLastRuleStartYear);
|
||||||
|
year++;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
--
|
||||||
|
cgit v0.9.2
|
34
SOURCES/javazic-fixup.patch
Normal file
34
SOURCES/javazic-fixup.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
--- sun/util/calendar/LocalGregorianCalendar.java.keiths 2007-09-07 14:48:19.000000000 -0700
|
||||||
|
+++ sun/util/calendar/LocalGregorianCalendar.java 2007-09-07 14:52:58.000000000 -0700
|
||||||
|
@@ -120,8 +120,7 @@ public class LocalGregorianCalendar exte
|
||||||
|
static LocalGregorianCalendar getLocalGregorianCalendar(String name) {
|
||||||
|
Properties calendarProps = null;
|
||||||
|
try {
|
||||||
|
- String homeDir = (String) AccessController.doPrivileged(
|
||||||
|
- new sun.security.action.GetPropertyAction("java.home"));
|
||||||
|
+ String homeDir = (String) System.getProperty("java.home");
|
||||||
|
final String fname = homeDir + File.separator + "lib" + File.separator
|
||||||
|
+ "calendars.properties";
|
||||||
|
calendarProps = (Properties) AccessController.doPrivileged(new PrivilegedExceptionAction() {
|
||||||
|
--- sun/util/calendar/ZoneInfoFile.java.keiths 2007-09-07 14:54:58.000000000 -0700
|
||||||
|
+++ sun/util/calendar/ZoneInfoFile.java 2007-09-07 14:55:36.000000000 -0700
|
||||||
|
@@ -1021,8 +1021,7 @@ public class ZoneInfoFile {
|
||||||
|
byte[] buffer = null;
|
||||||
|
|
||||||
|
try {
|
||||||
|
- String zi_dir = (String) AccessController.doPrivileged(
|
||||||
|
- new sun.security.action.GetPropertyAction("user.zoneinfo.dir"));
|
||||||
|
+ String zi_dir = (String) System.getProperty("user.zoneinfo.dir");
|
||||||
|
File dir = null;
|
||||||
|
if (zi_dir != null)
|
||||||
|
dir = new File(zi_dir);
|
||||||
|
@@ -1035,8 +1034,7 @@ public class ZoneInfoFile {
|
||||||
|
}
|
||||||
|
|
||||||
|
if (dir == null) {
|
||||||
|
- String homeDir = (String) AccessController.doPrivileged(
|
||||||
|
- new sun.security.action.GetPropertyAction("java.home"));
|
||||||
|
+ String homeDir = (String) System.getProperty("java.home");
|
||||||
|
zi_dir = homeDir + File.separator + "lib" + File.separator
|
||||||
|
+ "zi";
|
||||||
|
}
|
37
SOURCES/rebase-01.patch
Normal file
37
SOURCES/rebase-01.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
diff --git a/rebase-01.patch b/rebase-01.patch
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..bca6ed4
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/rebase-01.patch
|
||||||
|
@@ -0,0 +1,31 @@
|
||||||
|
+--- sun/tools/javazic/Mappings.java.orig 2007-08-30 03:55:48.000000000 -0400
|
||||||
|
++++ sun/tools/javazic/Mappings.java 2015-04-13 12:39:44.000000000 -0400
|
||||||
|
+@@ -1,12 +1,12 @@
|
||||||
|
+ /*
|
||||||
|
+- * Copyright 2000-2004 Sun Microsystems, Inc. All Rights Reserved.
|
||||||
|
++ * Copyright (c) 2000, 2004, Oracle and/or its affiliates. All rights reserved.
|
||||||
|
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||||
|
+ *
|
||||||
|
+ * This code is free software; you can redistribute it and/or modify it
|
||||||
|
+ * under the terms of the GNU General Public License version 2 only, as
|
||||||
|
+- * published by the Free Software Foundation. Sun designates this
|
||||||
|
++ * published by the Free Software Foundation. Oracle designates this
|
||||||
|
+ * particular file as subject to the "Classpath" exception as provided
|
||||||
|
+- * by Sun in the LICENSE file that accompanied this code.
|
||||||
|
++ * by Oracle in the LICENSE file that accompanied this code.
|
||||||
|
+ *
|
||||||
|
+ * This code is distributed in the hope that it will be useful, but WITHOUT
|
||||||
|
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||||
|
+@@ -18,9 +18,9 @@
|
||||||
|
+ * 2 along with this work; if not, write to the Free Software Foundation,
|
||||||
|
+ * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||||
|
+ *
|
||||||
|
+- * Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
|
||||||
|
+- * CA 95054 USA or visit www.sun.com if you need additional information or
|
||||||
|
+- * have any questions.
|
||||||
|
++ * Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
|
||||||
|
++ * or visit www.oracle.com if you need additional information or have any
|
||||||
|
++ * questions.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+ package sun.tools.javazic;
|
42
SOURCES/rebase-02.patch
Normal file
42
SOURCES/rebase-02.patch
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
diff --git a/rebase-02.patch b/rebase-02.patch
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..0f57125
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/rebase-02.patch
|
||||||
|
@@ -0,0 +1,36 @@
|
||||||
|
+--- sun/tools/javazic/Mappings.java.orig 2015-04-13 12:40:26.000000000 -0400
|
||||||
|
++++ sun/tools/javazic/Mappings.java 2015-04-13 12:42:11.000000000 -0400
|
||||||
|
+@@ -75,8 +75,10 @@
|
||||||
|
+ Zone zone = zones.get(zoneName);
|
||||||
|
+ String zonename = zone.getName();
|
||||||
|
+ int rawOffset = zone.get(zone.size()-1).getGmtOffset();
|
||||||
|
++
|
||||||
|
+ // If the GMT offset of this Zone will change in some
|
||||||
|
+ // future time, this Zone is added to the exclude list.
|
||||||
|
++ boolean isExcluded = false;
|
||||||
|
+ if (zone.size() > 1) {
|
||||||
|
+ ZoneRec zrec = zone.get(zone.size()-2);
|
||||||
|
+ if ((zrec.getGmtOffset() != rawOffset)
|
||||||
|
+@@ -85,7 +87,7 @@
|
||||||
|
+ excludeList = new ArrayList<String>();
|
||||||
|
+ }
|
||||||
|
+ excludeList.add(zone.getName());
|
||||||
|
+- continue;
|
||||||
|
++ isExcluded = true;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+@@ -101,9 +103,11 @@
|
||||||
|
+ rawOffsetsIndex.add(i, rawOffset);
|
||||||
|
+
|
||||||
|
+ Set<String> perRawOffset = new TreeSet<String>();
|
||||||
|
+- perRawOffset.add(zonename);
|
||||||
|
++ if (!isExcluded) {
|
||||||
|
++ perRawOffset.add(zonename);
|
||||||
|
++ }
|
||||||
|
+ rawOffsetsIndexTable.add(i, perRawOffset);
|
||||||
|
+- } else {
|
||||||
|
++ } else if (!isExcluded) {
|
||||||
|
+ int i = rawOffsetsIndex.indexOf(new Integer(rawOffset));
|
||||||
|
+ Set<String> perRawOffset = rawOffsetsIndexTable.get(i);
|
||||||
|
+ perRawOffset.add(zonename);
|
1214
SPECS/tzdata.spec
Normal file
1214
SPECS/tzdata.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user