Resolves: RHEL-57790
Update to tzdata-2024b - Improve historical data for Mexico, Mongolia, and Portugal. - System V names are now obsolescent. - The main data form now uses %z. - The code now conforms to RFC 8536 for early timestamps. - Support POSIX.1-2024, which removes asctime_r and ctime_r. - Assume POSIX.2-1992 or later for shell scripts. - SUPPORT_C89 now defaults to 1. - Include two upstream patches for month names as in April vs Apr.
This commit is contained in:
parent
26f35410f1
commit
420b6cbad9
2
.gitignore
vendored
2
.gitignore
vendored
@ -212,3 +212,5 @@ noarch/
|
||||
/tzdata2023d.tar.gz
|
||||
/tzcode2024a.tar.gz
|
||||
/tzdata2024a.tar.gz
|
||||
/tzcode2024b.tar.gz
|
||||
/tzdata2024b.tar.gz
|
||||
|
23
0004-Fix-Apr-vs-April-2024b.patch
Normal file
23
0004-Fix-Apr-vs-April-2024b.patch
Normal file
@ -0,0 +1,23 @@
|
||||
commit 926b507fa5c3192b1b68fab5910cbd3ba9377c97
|
||||
Author: Paul Eggert <eggert@cs.ucla.edu>
|
||||
Date: Thu Sep 5 14:36:02 2024 -0700
|
||||
|
||||
"Apr", not "April", in IN column
|
||||
|
||||
* northamerica (Rule): Use "Apr", not "April", in the IN column.
|
||||
Both forms are valid, but "Apr" is more consistent.
|
||||
Problem reported by Howard Hinnant.
|
||||
|
||||
diff --git a/northamerica b/northamerica
|
||||
index 01f392e0..1af874b6 100644
|
||||
--- a/northamerica
|
||||
+++ b/northamerica
|
||||
@@ -2631,7 +2631,7 @@ Zone America/Dawson -9:17:40 - LMT 1900 Aug 20
|
||||
# http://puentelibre.mx/noticia/ciudad_juarez_cambio_horario_noviembre_2022/
|
||||
|
||||
# Rule NAME FROM TO - IN ON AT SAVE LETTER/S
|
||||
-Rule Mexico 1931 only - April 30 0:00 1:00 D
|
||||
+Rule Mexico 1931 only - Apr 30 0:00 1:00 D
|
||||
Rule Mexico 1931 only - Oct 1 0:00 0 S
|
||||
Rule Mexico 1939 only - Feb 5 0:00 1:00 D
|
||||
Rule Mexico 1939 only - Jun 25 0:00 0 S
|
77
0005-Improve-style-checks-for-months-2024b.patch
Normal file
77
0005-Improve-style-checks-for-months-2024b.patch
Normal file
@ -0,0 +1,77 @@
|
||||
commit 7b6fb155cadd5e5ee70b55c2770e1bdd2f5d2a38
|
||||
Author: Paul Eggert <eggert@cs.ucla.edu>
|
||||
Date: Thu Sep 5 14:38:35 2024 -0700
|
||||
|
||||
Improve style checks for months
|
||||
|
||||
* checktab.awk: Check style of STDOFF and month names.
|
||||
|
||||
diff --git a/checktab.awk b/checktab.awk
|
||||
index 9a26e465..15a3a697 100644
|
||||
--- a/checktab.awk
|
||||
+++ b/checktab.awk
|
||||
@@ -9,6 +9,19 @@ BEGIN {
|
||||
if (!zone_table) zone_table = "zone1970.tab"
|
||||
if (!want_warnings) want_warnings = -1
|
||||
|
||||
+ monthabbr["Jan"] = 1
|
||||
+ monthabbr["Feb"] = 1
|
||||
+ monthabbr["Mar"] = 1
|
||||
+ monthabbr["Apr"] = 1
|
||||
+ monthabbr["May"] = 1
|
||||
+ monthabbr["Jun"] = 1
|
||||
+ monthabbr["Jul"] = 1
|
||||
+ monthabbr["Aug"] = 1
|
||||
+ monthabbr["Sep"] = 1
|
||||
+ monthabbr["Oct"] = 1
|
||||
+ monthabbr["Nov"] = 1
|
||||
+ monthabbr["Dec"] = 1
|
||||
+
|
||||
while (getline <iso_table) {
|
||||
iso_NR++
|
||||
if ($0 ~ /^#/) continue
|
||||
@@ -128,12 +141,14 @@ BEGIN {
|
||||
$1 ~ /^#/ { next }
|
||||
|
||||
{
|
||||
- tz = rules = ""
|
||||
+ tz = rules = stdoff = ""
|
||||
if ($1 == "Zone") {
|
||||
tz = $2
|
||||
+ stdoff = $3
|
||||
ruleUsed[$4] = 1
|
||||
if ($5 ~ /%/) rulePercentUsed[$4] = 1
|
||||
- } else if ($1 == "Link" && zone_table == "zone.tab") {
|
||||
+ } else if ($1 == "Link") {
|
||||
+ if (zone_table == "zone.tab") {
|
||||
# Ignore Link commands if source and destination basenames
|
||||
# are identical, e.g. Europe/Istanbul versus Asia/Istanbul.
|
||||
src = $2
|
||||
@@ -141,13 +156,27 @@ $1 ~ /^#/ { next }
|
||||
while ((i = index(src, "/"))) src = substr(src, i+1)
|
||||
while ((i = index(dst, "/"))) dst = substr(dst, i+1)
|
||||
if (src != dst) tz = $3
|
||||
+ }
|
||||
} else if ($1 == "Rule") {
|
||||
ruleDefined[$2] = 1
|
||||
if ($10 != "-") ruleLetters[$2] = 1
|
||||
+ if (!monthabbr[$6]) {
|
||||
+ printf "%s:%d: tricky month: %s\n", FILENAME, FNR, $6 \
|
||||
+ >>"/dev/stderr"
|
||||
+ status = 1
|
||||
+ }
|
||||
} else {
|
||||
+ stdoff = $1
|
||||
ruleUsed[$2] = 1
|
||||
if ($3 ~ /%/) rulePercentUsed[$2] = 1
|
||||
}
|
||||
+
|
||||
+ if (stdoff && stdoff !~ /^\-?1?[0-9](:[0-5][0-9](:[0-5][0-9])?)?$/) {
|
||||
+ printf "%s:%d: unlikely STDOFF: %s\n", FILENAME, FNR, stdoff \
|
||||
+ >>"/dev/stderr"
|
||||
+ status = 1
|
||||
+ }
|
||||
+
|
||||
if (tz && tz ~ /\// && tz !~ /^Etc\//) {
|
||||
if (!tztab[tz] && FILENAME != "backward" \
|
||||
&& zone_table != "zonenow.tab") {
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (javazic.tar.gz) = c23a4a437a87d0792f23e98025520a11273fc3d12ef5dcf64af8332ed60ba9ce77eaadfd234cee92b3ca9dc08b9e4123e804745925d68ddbd0b2e1e9039e526b
|
||||
SHA512 (javazic-1.8-37392f2f5d59.tar.xz) = 2ba718dfeed53a3bd6b44e3dfe96338a609e482e4e6d942e2a7e622fc6c52606cb323ac3a59739c463e34f70fff217c0a61f5b3d3c4958eff2801b1504ee4204
|
||||
SHA512 (tzcode2024a.tar.gz) = 46da8bfa762c7d109db93e5c060789097fc0e1e38bdad5bb8fec886ef47f138bd03b913a743cd5f7e23dc359a72bfd63e7ffc0de199d2b51e6a174361dbdc43c
|
||||
SHA512 (tzdata2024a.tar.gz) = 1f09f1b2327cc9e1afc7e9045e83ee3377918dafe1bee2f282b6991828d03b3c70a4d3a17f9207dfb1361bb25bc214a8922a756e84fa114e9ba476226db57236
|
||||
SHA512 (tzcode2024b.tar.gz) = 0e4e872d6c6d9e2ce8c4e567fcbb7658942b8544157d1e48673d9cb989f3af3379fa58e7a71ab98f4a8f2ac6727de1f8c4cd1981053409ebd8989345dc640026
|
||||
SHA512 (tzdata2024b.tar.gz) = 0d86686e215672343debb3471b7e7ccb8a27f063f085c9b532d5e0470377843daa0dfb6aee0db4fb9068dd52810c69aeee914a1a7c7e603fdecda7e855020193
|
||||
|
23
tzdata.spec
23
tzdata.spec
@ -1,9 +1,9 @@
|
||||
Summary: Timezone data
|
||||
Name: tzdata
|
||||
Version: 2024a
|
||||
%define tzdata_version 2024a
|
||||
%define tzcode_version 2024a
|
||||
Release: 2%{?dist}
|
||||
Version: 2024b
|
||||
%define tzdata_version 2024b
|
||||
%define tzcode_version 2024b
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
URL: https://www.iana.org/time-zones
|
||||
Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
|
||||
@ -13,6 +13,8 @@ Patch002: 0002-Fix-have-snprintf.patch
|
||||
%if 0%{?rhel} || 0%{?eln}
|
||||
Patch003: 0003-continue-to-ship-posixrules.patch
|
||||
%endif
|
||||
Patch004: 0004-Fix-Apr-vs-April-2024b.patch
|
||||
Patch005: 0005-Improve-style-checks-for-months-2024b.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gawk, glibc, perl-interpreter
|
||||
@ -46,6 +48,8 @@ This package contains timezone information for use by Java runtimes.
|
||||
%if 0%{?rhel} || 0%{?eln}
|
||||
%patch003 -p1
|
||||
%endif
|
||||
%patch004 -p1
|
||||
%patch005 -p1
|
||||
|
||||
# tzdata-2018g introduced 25:00 transition times. This breaks OpenJDK.
|
||||
# Use rearguard for java
|
||||
@ -153,6 +157,17 @@ install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
|
||||
%{_datadir}/javazi-1.8
|
||||
|
||||
%changelog
|
||||
* Wed Sep 11 2024 Patsy Griffin <patsy@redhat.com> - 2024b-1
|
||||
- Update to tzdata-2024b
|
||||
- Improve historical data for Mexico, Mongolia, and Portugal.
|
||||
- System V names are now obsolescent.
|
||||
- The main data form now uses %z.
|
||||
- The code now conforms to RFC 8536 for early timestamps.
|
||||
- Support POSIX.1-2024, which removes asctime_r and ctime_r.
|
||||
- Assume POSIX.2-1992 or later for shell scripts.
|
||||
- SUPPORT_C89 now defaults to 1.
|
||||
- Include two upstream patches for month names as in April vs Apr.
|
||||
|
||||
* Thu Mar 14 2024 Patsy Griffin <patsy@redhat.com> - 2024a-2
|
||||
- Add java patch to fix incorrect calculations for
|
||||
Africa/Casablanca starting in 2027. (RHEL-26860)
|
||||
|
Loading…
Reference in New Issue
Block a user