diff --git a/ZoneTest.java b/ZoneTest.java
index d217105..e690728 100644
--- a/ZoneTest.java
+++ b/ZoneTest.java
@@ -1,4 +1,19 @@
-/* Smoke test to ensure that tzdb.data can be loaded. */
+/* Smoke test to ensure that tzdb.data can be loaded.
+ Copyright (c) 2024 Red Hat, Inc.
+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU Affero General Public License as
+ published by the Free Software Foundation, either version 3 of the
+ License, or (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU Affero General Public License for more details.
+
+ You should have received a copy of the GNU Affero General Public License
+ along with this program. If not, see . */
+
import java.time.zone.ZoneRulesProvider;
import java.util.Calendar;
@@ -24,3 +39,4 @@ public class ZoneTest {
System.exit(1);
}
}
+
diff --git a/javazic-harden-links.patch b/javazic-harden-links.patch
index 83827f1..9d5aad5 100644
--- a/javazic-harden-links.patch
+++ b/javazic-harden-links.patch
@@ -1,3 +1,13 @@
+Modified for downstream inclusion in tzdata-java.
+
+commit 1bc13a1c10a580f84f1b7686c95344ec2633f611
+Author: Florian Weimer
+Date: Thu Sep 26 22:37:45 2024 +0000
+
+ 8340552: Harden TzdbZoneRulesCompiler against missing zone names
+
+ Reviewed-by: andrew, jlu, naoto
+
diff -ur tzdata-2024b.orig/javazic-1.8/build/tools/tzdb/TzdbZoneRulesCompiler.java tzdata-2024b/javazic-1.8/build/tools/tzdb/TzdbZoneRulesCompiler.java
--- tzdata-2024b.orig/javazic-1.8/build/tools/tzdb/TzdbZoneRulesCompiler.java 2014-04-22 19:46:49.000000000 +0200
+++ tzdata-2024b/javazic-1.8/build/tools/tzdb/TzdbZoneRulesCompiler.java 2024-09-20 21:10:12.748483767 +0200
diff --git a/tzdata.spec b/tzdata.spec
index 8a7729f..7e0a8c3 100644
--- a/tzdata.spec
+++ b/tzdata.spec
@@ -3,7 +3,7 @@ Name: tzdata
Version: 2024b
%define tzdata_version 2024b
%define tzcode_version 2024b
-Release: 2%{?dist}
+Release: 3%{?dist}
License: Public Domain
Group: System Environment/Base
URL: https://www.iana.org/time-zones
@@ -17,6 +17,8 @@ Patch005: 0005-Improve-style-checks-for-months-2024b.patch
BuildRequires: gawk, glibc, perl-interpreter
BuildRequires: java-devel
+BuildRequires: make
+BuildRequires: gcc
BuildRequires: glibc-common >= 2.5.90-7
Conflicts: glibc-common <= 2.3.2-63
BuildArchitectures: noarch
@@ -170,6 +172,10 @@ echo ============END TESTING===========
%{_datadir}/javazi-1.8
%changelog
+* Thu Oct 03 2024 Patsy Griffin - 2024b-3
+- Add copyright, patch attribution and build dependencies for
+ the previous commit. (RHEL-59542)
+
* Fri Sep 20 2024 Florian Weimer - 2024b-2
- Harden against links to removed zones (RHEL-59542)