Resolves #1507341
- Rebase to tzdata-2017c - Northern Cyprus will revert to using EQ rules on October 29, 2017. - Sudan will switch from +03 to +02 on November 1, 2017. - Tonga will not change it's clocks on Novemeber 5, 2017 ending it's experiment with DST. - Fiji DST will end on January 14, 2018 rather than January 21, 2018. - Namibia - starting September 3, 2017 switches from +)1 with DST to +02 all year. This change takes effect April 1, 2018. - Turks & Caicos changes from -04 all year to -05 with US DST starting on March 11, 2018. Effective change date is November 4, 2018. - tzdata now includes two text versions of the time zone data - tzdata.zi and leapseconds. - Includes two patches to deal with build issues.
This commit is contained in:
parent
55fef8cdba
commit
00f1b9ba49
2
.gitignore
vendored
2
.gitignore
vendored
@ -156,3 +156,5 @@ noarch/
|
||||
/tzcode2017a.tar.gz
|
||||
/tzcode2017b.tar.gz
|
||||
/tzdata2017b.tar.gz
|
||||
/tzcode2017c.tar.gz
|
||||
/tzdata2017c.tar.gz
|
||||
|
149
0001-Fix-Makefile-quoting-bug.patch
Normal file
149
0001-Fix-Makefile-quoting-bug.patch
Normal file
@ -0,0 +1,149 @@
|
||||
From b520d20b8122a783f99f088758b78d928f70ee34 Mon Sep 17 00:00:00 2001
|
||||
From: Paul Eggert <eggert@cs.ucla.edu>
|
||||
Date: Mon, 23 Oct 2017 11:42:45 -0700
|
||||
Subject: [PROPOSED] Fix Makefile quoting bug
|
||||
|
||||
Problem with INSTALLARGS reported by Zefram in:
|
||||
https://mm.icann.org/pipermail/tz/2017-October/025360.html
|
||||
Fix similar problems too.
|
||||
* Makefile (ZIC_INSTALL, VALIDATE_ENV, CC, install)
|
||||
(INSTALL, version, INSTALLARGS, right_posix, posix_right)
|
||||
(check_public): Use apostrophes to prevent undesirable
|
||||
interpretation of names by the shell. We still do not support
|
||||
directory names containing apostrophes or newlines, but this is
|
||||
good enough.
|
||||
* NEWS: Mention this.
|
||||
---
|
||||
Makefile | 64 ++++++++++++++++++++++++++++++++--------------------------------
|
||||
NEWS | 8 ++++++++
|
||||
2 files changed, 40 insertions(+), 32 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index c92edc0..97649ca 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -313,7 +313,7 @@ ZFLAGS=
|
||||
|
||||
# How to use zic to install tz binary files.
|
||||
|
||||
-ZIC_INSTALL= $(ZIC) -d $(DESTDIR)$(TZDIR) $(LEAPSECONDS)
|
||||
+ZIC_INSTALL= $(ZIC) -d '$(DESTDIR)$(TZDIR)' $(LEAPSECONDS)
|
||||
|
||||
# The name of a Posix-compliant 'awk' on your system.
|
||||
AWK= awk
|
||||
@@ -341,8 +341,8 @@ SGML_CATALOG_FILES= \
|
||||
VALIDATE = nsgmls
|
||||
VALIDATE_FLAGS = -s -B -wall -wno-unused-param
|
||||
VALIDATE_ENV = \
|
||||
- SGML_CATALOG_FILES=$(SGML_CATALOG_FILES) \
|
||||
- SGML_SEARCH_PATH=$(SGML_SEARCH_PATH) \
|
||||
+ SGML_CATALOG_FILES='$(SGML_CATALOG_FILES)' \
|
||||
+ SGML_SEARCH_PATH='$(SGML_SEARCH_PATH)' \
|
||||
SP_CHARSET_FIXED=YES \
|
||||
SP_ENCODING=UTF-8
|
||||
|
||||
@@ -396,7 +396,7 @@ GZIPFLAGS= -9n
|
||||
#MAKE= make
|
||||
|
||||
cc= cc
|
||||
-CC= $(cc) -DTZDIR=\"$(TZDIR)\"
|
||||
+CC= $(cc) -DTZDIR='"$(TZDIR)"'
|
||||
|
||||
AR= ar
|
||||
|
||||
@@ -473,29 +473,29 @@ all: tzselect yearistype zic zdump libtz.a $(TABDATA)
|
||||
ALL: all date $(ENCHILADA)
|
||||
|
||||
install: all $(DATA) $(REDO) $(MANS)
|
||||
- mkdir -p $(DESTDIR)$(ETCDIR) $(DESTDIR)$(TZDIR) \
|
||||
- $(DESTDIR)$(LIBDIR) \
|
||||
- $(DESTDIR)$(MANDIR)/man3 $(DESTDIR)$(MANDIR)/man5 \
|
||||
- $(DESTDIR)$(MANDIR)/man8
|
||||
+ mkdir -p '$(DESTDIR)$(ETCDIR)' '$(DESTDIR)$(TZDIR)' \
|
||||
+ '$(DESTDIR)$(LIBDIR)' \
|
||||
+ '$(DESTDIR)$(MANDIR)/man3' '$(DESTDIR)$(MANDIR)/man5' \
|
||||
+ '$(DESTDIR)$(MANDIR)/man8'
|
||||
$(ZIC_INSTALL) -l $(LOCALTIME) -p $(POSIXRULES)
|
||||
- cp -f $(TABDATA) $(DESTDIR)$(TZDIR)/.
|
||||
- cp tzselect zic zdump $(DESTDIR)$(ETCDIR)/.
|
||||
- cp libtz.a $(DESTDIR)$(LIBDIR)/.
|
||||
- $(RANLIB) $(DESTDIR)$(LIBDIR)/libtz.a
|
||||
- cp -f newctime.3 newtzset.3 $(DESTDIR)$(MANDIR)/man3/.
|
||||
- cp -f tzfile.5 $(DESTDIR)$(MANDIR)/man5/.
|
||||
- cp -f tzselect.8 zdump.8 zic.8 $(DESTDIR)$(MANDIR)/man8/.
|
||||
+ cp -f $(TABDATA) '$(DESTDIR)$(TZDIR)/.'
|
||||
+ cp tzselect zic zdump '$(DESTDIR)$(ETCDIR)/.'
|
||||
+ cp libtz.a '$(DESTDIR)$(LIBDIR)/.'
|
||||
+ $(RANLIB) '$(DESTDIR)$(LIBDIR)/libtz.a'
|
||||
+ cp -f newctime.3 newtzset.3 '$(DESTDIR)$(MANDIR)/man3/.'
|
||||
+ cp -f tzfile.5 '$(DESTDIR)$(MANDIR)/man5/.'
|
||||
+ cp -f tzselect.8 zdump.8 zic.8 '$(DESTDIR)$(MANDIR)/man8/.'
|
||||
|
||||
INSTALL: ALL install date.1
|
||||
- mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(MANDIR)/man1
|
||||
- cp date $(DESTDIR)$(BINDIR)/.
|
||||
- cp -f date.1 $(DESTDIR)$(MANDIR)/man1/.
|
||||
+ mkdir -p '$(DESTDIR)$(BINDIR)' '$(DESTDIR)$(MANDIR)/man1'
|
||||
+ cp date '$(DESTDIR)$(BINDIR)/.'
|
||||
+ cp -f date.1 '$(DESTDIR)$(MANDIR)/man1/.'
|
||||
|
||||
version: $(VERSION_DEPS)
|
||||
{ (type git) >/dev/null 2>&1 && \
|
||||
V=`git describe --match '[0-9][0-9][0-9][0-9][a-z]*' \
|
||||
--abbrev=7 --dirty` || \
|
||||
- V=$(VERSION); } && \
|
||||
+ V='$(VERSION)'; } && \
|
||||
printf '%s\n' "$$V" >$@.out
|
||||
mv $@.out $@
|
||||
|
||||
@@ -529,12 +529,12 @@ leapseconds: $(LEAP_DEPS)
|
||||
# Arguments to pass to submakes of install_data.
|
||||
# They can be overridden by later submake arguments.
|
||||
INSTALLARGS = \
|
||||
- BACKWARD=$(BACKWARD) \
|
||||
- DESTDIR=$(DESTDIR) \
|
||||
+ BACKWARD='$(BACKWARD)' \
|
||||
+ DESTDIR='$(DESTDIR)' \
|
||||
LEAPSECONDS='$(LEAPSECONDS)' \
|
||||
PACKRATDATA='$(PACKRATDATA)' \
|
||||
- TZDIR=$(TZDIR) \
|
||||
- YEARISTYPE=$(YEARISTYPE) \
|
||||
+ TZDIR='$(TZDIR)' \
|
||||
+ YEARISTYPE='$(YEARISTYPE)' \
|
||||
ZIC='$(ZIC)'
|
||||
|
||||
# 'make install_data' installs one set of tz binary files.
|
||||
@@ -558,16 +558,16 @@ right_only:
|
||||
# You must replace all of $(TZDIR) to switch from not using leap seconds
|
||||
# to using them, or vice versa.
|
||||
right_posix: right_only
|
||||
- rm -fr $(DESTDIR)$(TZDIR)-leaps
|
||||
- ln -s $(TZDIR_BASENAME) $(DESTDIR)$(TZDIR)-leaps || \
|
||||
- $(MAKE) $(INSTALLARGS) TZDIR=$(TZDIR)-leaps right_only
|
||||
- $(MAKE) $(INSTALLARGS) TZDIR=$(TZDIR)-posix posix_only
|
||||
+ rm -fr '$(DESTDIR)$(TZDIR)-leaps'
|
||||
+ ln -s '$(TZDIR_BASENAME)' '$(DESTDIR)$(TZDIR)-leaps' || \
|
||||
+ $(MAKE) $(INSTALLARGS) TZDIR='$(TZDIR)-leaps' right_only
|
||||
+ $(MAKE) $(INSTALLARGS) TZDIR='$(TZDIR)-posix' posix_only
|
||||
|
||||
posix_right: posix_only
|
||||
- rm -fr $(DESTDIR)$(TZDIR)-posix
|
||||
- ln -s $(TZDIR_BASENAME) $(DESTDIR)$(TZDIR)-posix || \
|
||||
- $(MAKE) $(INSTALLARGS) TZDIR=$(TZDIR)-posix posix_only
|
||||
- $(MAKE) $(INSTALLARGS) TZDIR=$(TZDIR)-leaps right_only
|
||||
+ rm -fr '$(DESTDIR)$(TZDIR)-posix'
|
||||
+ ln -s '$(TZDIR_BASENAME)' '$(DESTDIR)$(TZDIR)-posix' || \
|
||||
+ $(MAKE) $(INSTALLARGS) TZDIR='$(TZDIR)-posix' posix_only
|
||||
+ $(MAKE) $(INSTALLARGS) TZDIR='$(TZDIR)-leaps' right_only
|
||||
|
||||
# This obsolescent rule is present for backwards compatibility with
|
||||
# tz releases 2014g through 2015g. It should go away eventually.
|
||||
@@ -764,7 +764,7 @@ set-timestamps.out: $(ENCHILADA)
|
||||
|
||||
check_public:
|
||||
$(MAKE) maintainer-clean
|
||||
- $(MAKE) "CFLAGS=$(GCC_DEBUG_FLAGS)" ALL
|
||||
+ $(MAKE) CFLAGS='$(GCC_DEBUG_FLAGS)' ALL
|
||||
mkdir -p public.dir
|
||||
for i in $(TDATA) tzdata.zi; do \
|
||||
$(zic) -v -d public.dir $$i 2>&1 || exit; \
|
12
0002-Fix-have-snprintf-error.patch
Normal file
12
0002-Fix-have-snprintf-error.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nrup a/Makefile b/Makefile
|
||||
--- a/Makefile 2017-10-23 18:03:40.237177646 -0400
|
||||
+++ b/Makefile 2017-10-23 18:06:20.060683518 -0400
|
||||
@@ -292,7 +292,7 @@ GCC_DEBUG_FLAGS = -DGCC_LINT -g3 -O3 -fn
|
||||
# January's first Monday when a "%V" format is used and January 1
|
||||
# falls on a Friday, Saturday, or Sunday.
|
||||
|
||||
-CFLAGS=
|
||||
+CFLAGS= -DHAVE_SNPRINTF=1
|
||||
|
||||
# Linker flags. Default to $(LFLAGS) for backwards compatibility
|
||||
# to release 2012h and earlier.
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (javazic.tar.gz) = c23a4a437a87d0792f23e98025520a11273fc3d12ef5dcf64af8332ed60ba9ce77eaadfd234cee92b3ca9dc08b9e4123e804745925d68ddbd0b2e1e9039e526b
|
||||
SHA512 (javazic-1.8-37392f2f5d59.tar.xz) = 2ba718dfeed53a3bd6b44e3dfe96338a609e482e4e6d942e2a7e622fc6c52606cb323ac3a59739c463e34f70fff217c0a61f5b3d3c4958eff2801b1504ee4204
|
||||
SHA512 (tzcode2017b.tar.gz) = 9a73af4b868506d1f6287a8285dea489e68f6828da19509114f9144e2a2019c7fd28f4fb98ea907030d11d011ce3a87d99dbe43bca218beddafff151f0d61df1
|
||||
SHA512 (tzdata2017b.tar.gz) = 3e090dba1f52e4c63b4930b28f4bf38b56aabd6728f23094cb5801d10f4e464f17231f17b75b8866714bf98199c166ea840de0787b75b2274aa419a4e14bbc4d
|
||||
SHA512 (tzcode2017c.tar.gz) = 0d8c3e07b0de9015a137602450468ceb6358312a50eeda2a860882367107b8ba9ef275880b292570a671b9910afc54e6209e1e642387d246bc9c08c4ff660ffb
|
||||
SHA512 (tzdata2017c.tar.gz) = feb5c544e617b30c73a397e5a1c51f9847d0fddf1dfa0f9ace2e6f686786f09b666937b2048e07075c84593fc584bd5a25d639fce70eca9735267df28621ab4c
|
||||
|
37
tzdata.spec
37
tzdata.spec
@ -1,15 +1,17 @@
|
||||
Summary: Timezone data
|
||||
Name: tzdata
|
||||
Version: 2017b
|
||||
%define tzdata_version 2017b
|
||||
%define tzcode_version 2017b
|
||||
Release: 2%{?dist}
|
||||
Version: 2017c
|
||||
%define tzdata_version 2017c
|
||||
%define tzcode_version 2017c
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
Group: System Environment/Base
|
||||
URL: https://www.iana.org/time-zones
|
||||
Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
|
||||
Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
|
||||
# Add new patches here...
|
||||
|
||||
Patch001: 0001-Fix-Makefile-quoting-bug.patch
|
||||
Patch002: 0002-Fix-have-snprintf-error.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gawk, glibc, perl-interpreter
|
||||
@ -39,7 +41,8 @@ This package contains timezone information for use by Java runtimes.
|
||||
%prep
|
||||
%setup -q -c -a 1
|
||||
|
||||
# Add new patches here...
|
||||
%patch001 -p1
|
||||
%patch002 -p1
|
||||
|
||||
mkdir javazic
|
||||
tar zxf %{SOURCE3} -C javazic
|
||||
@ -67,6 +70,9 @@ tar xf %{SOURCE4}
|
||||
echo "%{name}%{tzdata_version}" >> VERSION
|
||||
|
||||
%build
|
||||
# Run make to create the tzdata.zi file
|
||||
make tzdata.zi
|
||||
|
||||
FILES="africa antarctica asia australasia europe northamerica southamerica
|
||||
pacificnew etcetera backward"
|
||||
|
||||
@ -100,7 +106,7 @@ java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
|
||||
rm -fr $RPM_BUILD_ROOT
|
||||
install -d $RPM_BUILD_ROOT%{_datadir}
|
||||
cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
|
||||
install -p -m 644 zone.tab zone1970.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
|
||||
install -p -m 644 zone.tab zone1970.tab iso3166.tab leapseconds tzdata.zi $RPM_BUILD_ROOT%{_datadir}/zoneinfo
|
||||
cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
|
||||
install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
|
||||
@ -113,7 +119,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/zoneinfo
|
||||
%license LICENSE
|
||||
%doc README
|
||||
%doc Theory
|
||||
%doc theory.html
|
||||
%doc tz-link.html
|
||||
|
||||
%files java
|
||||
@ -122,6 +128,21 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/javazi-1.8
|
||||
|
||||
%changelog
|
||||
* Thu Oct 26 2017 Patsy Franklin <pfrankli@redhat.com> - 2017c-1
|
||||
- Rebase to tzdata-2017c.
|
||||
- Northern Cyprus will revert to using EQ rules on October 29, 2017.
|
||||
- Sudan will switch from +03 to +02 on November 1, 2017.
|
||||
- Tonga will not change it's clocks on Novemeber 5, 2017 ending it's
|
||||
experiment with DST.
|
||||
- Fiji DST will end on January 14, 2018 rather than January 21, 2018.
|
||||
- Namibia - starting September 3, 2017 switches from +)1 with DST to
|
||||
+02 all year. This change takes effect April 1, 2018.
|
||||
- Turks & Caicos changes from -04 all year to -05 with US DST starting
|
||||
on March 11, 2018. Effective change date is November 4, 2018.
|
||||
- tzdata now includes two text versions of the time zone data - tzdata.zi
|
||||
and leapseconds.
|
||||
- Includes two patches to deal with build issues.
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2017b-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user