fixed functions packaging and added explicit conflict with power-profiles-daemon
related: RHEL-50568
This commit is contained in:
parent
908bccb508
commit
f09b2249e5
@ -1,12 +1,11 @@
|
|||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index f73f572..abbf869 100644
|
index f73f572..1f30598 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -46,9 +46,8 @@ ifeq ($(PYTHON_SITELIB),)
|
@@ -47,8 +47,8 @@ $(error Failed to determine python library directory)
|
||||||
$(error Failed to determine python library directory)
|
|
||||||
endif
|
endif
|
||||||
KERNELINSTALLHOOKDIR = /usr/lib/kernel/install.d
|
KERNELINSTALLHOOKDIR = /usr/lib/kernel/install.d
|
||||||
-TUNED_SYSTEM_DIR = /usr/lib/tuned
|
TUNED_SYSTEM_DIR = /usr/lib/tuned
|
||||||
-TUNED_PROFILES_DIR = $(TUNED_SYSTEM_DIR)/profiles
|
-TUNED_PROFILES_DIR = $(TUNED_SYSTEM_DIR)/profiles
|
||||||
-TUNED_RECOMMEND_DIR = $(TUNED_SYSTEM_DIR)/recommend.d
|
-TUNED_RECOMMEND_DIR = $(TUNED_SYSTEM_DIR)/recommend.d
|
||||||
+TUNED_PROFILES_DIR = /usr/lib/tuned
|
+TUNED_PROFILES_DIR = /usr/lib/tuned
|
||||||
@ -14,7 +13,7 @@ index f73f572..abbf869 100644
|
|||||||
TUNED_USER_RECOMMEND_DIR = $(SYSCONFDIR)/tuned/recommend.d
|
TUNED_USER_RECOMMEND_DIR = $(SYSCONFDIR)/tuned/recommend.d
|
||||||
BASH_COMPLETIONS = $(DATADIR)/bash-completion/completions
|
BASH_COMPLETIONS = $(DATADIR)/bash-completion/completions
|
||||||
|
|
||||||
@@ -68,7 +67,7 @@ release-cp: release-dir
|
@@ -68,7 +68,7 @@ release-cp: release-dir
|
||||||
tuned-adm.bash dbus.conf recommend.conf tuned-main.conf 00_tuned \
|
tuned-adm.bash dbus.conf recommend.conf tuned-main.conf 00_tuned \
|
||||||
92-tuned.install bootcmdline modules.conf com.redhat.tuned.policy \
|
92-tuned.install bootcmdline modules.conf com.redhat.tuned.policy \
|
||||||
tuned-gui.py tuned-gui.glade tuned-ppd.py \
|
tuned-gui.py tuned-gui.glade tuned-ppd.py \
|
||||||
@ -23,7 +22,7 @@ index f73f572..abbf869 100644
|
|||||||
cp -a doc experiments libexec man profiles systemtap tuned contrib icons \
|
cp -a doc experiments libexec man profiles systemtap tuned contrib icons \
|
||||||
tests $(VERSIONED_NAME)
|
tests $(VERSIONED_NAME)
|
||||||
|
|
||||||
@@ -135,7 +134,6 @@ install-dirs:
|
@@ -135,7 +135,6 @@ install-dirs:
|
||||||
mkdir -p $(DESTDIR)/run/tuned
|
mkdir -p $(DESTDIR)/run/tuned
|
||||||
mkdir -p $(DESTDIR)$(DOCDIR)
|
mkdir -p $(DESTDIR)$(DOCDIR)
|
||||||
mkdir -p $(DESTDIR)$(SYSCONFDIR)
|
mkdir -p $(DESTDIR)$(SYSCONFDIR)
|
||||||
@ -31,16 +30,6 @@ index f73f572..abbf869 100644
|
|||||||
mkdir -p $(DESTDIR)$(TUNED_RECOMMEND_DIR)
|
mkdir -p $(DESTDIR)$(TUNED_RECOMMEND_DIR)
|
||||||
mkdir -p $(DESTDIR)$(TUNED_USER_RECOMMEND_DIR)
|
mkdir -p $(DESTDIR)$(TUNED_USER_RECOMMEND_DIR)
|
||||||
|
|
||||||
@@ -183,9 +181,6 @@ install: install-dirs
|
|
||||||
$(DESTDIR)$(SYSCONFDIR)/tuned/cpu-partitioning-powersave-variables.conf
|
|
||||||
install -pm 0644 recommend.conf $(DESTDIR)$(TUNED_RECOMMEND_DIR)/50-tuned.conf
|
|
||||||
|
|
||||||
- # bash functions used by profile scripts
|
|
||||||
- install -Dpm 0644 functions $(DESTDIR)$(TUNED_SYSTEM_DIR)
|
|
||||||
-
|
|
||||||
# bash completion
|
|
||||||
install -Dpm 0644 tuned-adm.bash $(DESTDIR)$(BASH_COMPLETIONS)/tuned-adm
|
|
||||||
|
|
||||||
diff --git a/doc/manual/modules/performance/con_inheritance-between-tuned-profiles.adoc b/doc/manual/modules/performance/con_inheritance-between-tuned-profiles.adoc
|
diff --git a/doc/manual/modules/performance/con_inheritance-between-tuned-profiles.adoc b/doc/manual/modules/performance/con_inheritance-between-tuned-profiles.adoc
|
||||||
index d72cc98..63517ac 100644
|
index d72cc98..63517ac 100644
|
||||||
--- a/doc/manual/modules/performance/con_inheritance-between-tuned-profiles.adoc
|
--- a/doc/manual/modules/performance/con_inheritance-between-tuned-profiles.adoc
|
||||||
|
@ -35,7 +35,7 @@
|
|||||||
Summary: A dynamic adaptive system tuning daemon
|
Summary: A dynamic adaptive system tuning daemon
|
||||||
Name: tuned
|
Name: tuned
|
||||||
Version: 2.24.0
|
Version: 2.24.0
|
||||||
Release: 0.1%{?prerel1}%{?dist}
|
Release: 0.2%{?prerel1}%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
||||||
# RHEL-9 specific recommend.conf:
|
# RHEL-9 specific recommend.conf:
|
||||||
@ -264,6 +264,7 @@ Requires: %{name} = %{version}
|
|||||||
# The compatibility daemon is swappable for power-profiles-daemon
|
# The compatibility daemon is swappable for power-profiles-daemon
|
||||||
Provides: ppd-service
|
Provides: ppd-service
|
||||||
Conflicts: ppd-service
|
Conflicts: ppd-service
|
||||||
|
Conflicts: power-profiles-daemon
|
||||||
|
|
||||||
%description ppd
|
%description ppd
|
||||||
An API translation daemon that allows applications to easily transition
|
An API translation daemon that allows applications to easily transition
|
||||||
@ -601,6 +602,10 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/tuned/ppd.conf
|
%config(noreplace) %{_sysconfdir}/tuned/ppd.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 26 2024 Jaroslav Škarvada <jskarvad@redhat.com> - 2.24.0-0.2.rc1
|
||||||
|
- fixed functions packaging and added explicit conflict with power-profiles-daemon
|
||||||
|
related: RHEL-50568
|
||||||
|
|
||||||
* Thu Jul 25 2024 Jaroslav Škarvada <jskarvad@redhat.com> - 2.24.0-0.1.rc1
|
* Thu Jul 25 2024 Jaroslav Škarvada <jskarvad@redhat.com> - 2.24.0-0.1.rc1
|
||||||
- new release
|
- new release
|
||||||
- rebased tuned to latest upstream
|
- rebased tuned to latest upstream
|
||||||
|
Loading…
Reference in New Issue
Block a user