new release
rebased tuned to latest upstream related: RHEL-17119 lower CPU usage by using runtime=0 in profiles using scheduler plugin resolves: RHEL-6869
This commit is contained in:
parent
0033af9076
commit
ef2d187cea
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tuned-2.22.0-rc.1.tar.gz) = a86c83f8e266285d346d82c12bca1afbe20ce4a6177a8cacbba244091dc153a1cb090bde4e8f876bfc7015034106b4dbcbab7032e91fa6bfba7ef62fc54af0b4
|
||||
SHA512 (tuned-2.22.0.tar.gz) = 653f946e8eff57eaa7e26b05c9215d60c8dcec6760b4a41a2855328e86b65f4dcbc0b2fd7d9f9355d00aae93f601c035a38d4e1611f30cb5003b417e31bea4dc
|
||||
|
@ -1,13 +1,14 @@
|
||||
diff --git a/profiles/latency-performance/tuned.conf b/profiles/latency-performance/tuned.conf
|
||||
index d200b5c..877229f 100644
|
||||
index 1dec690..e592138 100644
|
||||
--- a/profiles/latency-performance/tuned.conf
|
||||
+++ b/profiles/latency-performance/tuned.conf
|
||||
@@ -32,3 +32,16 @@ vm.dirty_background_ratio=3
|
||||
@@ -35,3 +35,17 @@ vm.dirty_background_ratio=3
|
||||
# 100 tells the kernel to aggressively swap processes out of physical memory
|
||||
# and move them to swap cache
|
||||
vm.swappiness=10
|
||||
+
|
||||
+[scheduler]
|
||||
+runtime=0
|
||||
+# ktune sysctl settings for rhel6 servers, maximizing i/o throughput
|
||||
+#
|
||||
+# Minimal preemption granularity for CPU-bound tasks:
|
||||
@ -20,26 +21,28 @@ index d200b5c..877229f 100644
|
||||
+# (system default is 500000, i.e. 0.5 ms)
|
||||
+sched_migration_cost_ns = 5000000
|
||||
diff --git a/profiles/sap-hana/tuned.conf b/profiles/sap-hana/tuned.conf
|
||||
index aeecf53..8dcee57 100644
|
||||
index aeecf53..1b15ea3 100644
|
||||
--- a/profiles/sap-hana/tuned.conf
|
||||
+++ b/profiles/sap-hana/tuned.conf
|
||||
@@ -20,3 +20,7 @@ kernel.numa_balancing = 0
|
||||
@@ -20,3 +20,8 @@ kernel.numa_balancing = 0
|
||||
vm.dirty_ratio = 40
|
||||
vm.dirty_background_ratio = 10
|
||||
vm.swappiness = 10
|
||||
+
|
||||
+[scheduler]
|
||||
+runtime=0
|
||||
+sched_min_granularity_ns = 3000000
|
||||
+sched_wakeup_granularity_ns = 4000000
|
||||
diff --git a/profiles/throughput-performance/tuned.conf b/profiles/throughput-performance/tuned.conf
|
||||
index 62a7322..7c55fb2 100644
|
||||
index e4e832f..3d9c42f 100644
|
||||
--- a/profiles/throughput-performance/tuned.conf
|
||||
+++ b/profiles/throughput-performance/tuned.conf
|
||||
@@ -63,9 +63,31 @@ vm.swappiness=10
|
||||
@@ -67,9 +67,33 @@ vm.swappiness=10
|
||||
# on older kernels
|
||||
net.core.somaxconn=>2048
|
||||
|
||||
+[scheduler]
|
||||
+runtime=0
|
||||
+# ktune sysctl settings for rhel6 servers, maximizing i/o throughput
|
||||
+#
|
||||
+# Minimal preemption granularity for CPU-bound tasks:
|
||||
@ -66,17 +69,19 @@ index 62a7322..7c55fb2 100644
|
||||
+type=scheduler
|
||||
+uname_regex=x86_64
|
||||
+cpuinfo_regex=${amd_cpuinfo_regex}
|
||||
+runtime=0
|
||||
+sched_migration_cost_ns=5000000
|
||||
diff --git a/profiles/virtual-host/tuned.conf b/profiles/virtual-host/tuned.conf
|
||||
index 5301d9f..74a5fb0 100644
|
||||
index 5301d9f..24d0fb4 100644
|
||||
--- a/profiles/virtual-host/tuned.conf
|
||||
+++ b/profiles/virtual-host/tuned.conf
|
||||
@@ -14,3 +14,9 @@ vm.dirty_background_ratio = 5
|
||||
@@ -14,3 +14,10 @@ vm.dirty_background_ratio = 5
|
||||
[cpu]
|
||||
# Setting C3 state sleep mode/power savings
|
||||
force_latency=cstate.id_no_zero:3|70
|
||||
+
|
||||
+[scheduler]
|
||||
+runtime=0
|
||||
+# The total time the scheduler will consider a migrated process
|
||||
+# "cache hot" and thus less likely to be re-migrated
|
||||
+# (system default is 500000, i.e. 0.5 ms)
|
18
tuned.spec
18
tuned.spec
@ -26,8 +26,8 @@
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%global prerelease rc
|
||||
%global prereleasenum 1
|
||||
#%%global prerelease rc
|
||||
#%%global prereleasenum 1
|
||||
|
||||
%global prerel1 %{?prerelease:.%{prerelease}%{prereleasenum}}
|
||||
%global prerel2 %{?prerelease:-%{prerelease}.%{prereleasenum}}
|
||||
@ -35,7 +35,7 @@
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.22.0
|
||||
Release: 0.1%{?prerel1}%{?dist}
|
||||
Release: 1%{?prerel1}%{?dist}
|
||||
License: GPLv2+
|
||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
||||
# RHEL-8 specific recommend.conf:
|
||||
@ -94,7 +94,7 @@ Requires: python3-syspurpose
|
||||
%endif
|
||||
%endif
|
||||
# Revert upstream profiles changes which have not been approved for RHEL-8 (yet)
|
||||
Patch0: tuned-2.20.0-rhel-8-profiles.patch
|
||||
Patch0: tuned-2.22.0-rhel-8-profiles.patch
|
||||
# Revert no balancing cores to use SD_LOAD_BALANCE (see rhbz#1874596 for details)
|
||||
Patch1: tuned-2.21.0-sd-load-balance.patch
|
||||
|
||||
@ -283,9 +283,6 @@ make html %{make_python_arg}
|
||||
%install
|
||||
make install DESTDIR=%{buildroot} DOCDIR=%{docdir} %{make_python_arg}
|
||||
make install-ppd DESTDIR=%{buildroot} DOCDIR=%{docdir} %{make_python_arg}
|
||||
%if 0%{?rhel}
|
||||
sed -i 's/\(dynamic_tuning[ \t]*=[ \t]*\).*/\10/' %{buildroot}%{_sysconfdir}/tuned/tuned-main.conf
|
||||
%endif
|
||||
|
||||
%if ! 0%{?rhel}
|
||||
# manual
|
||||
@ -572,6 +569,13 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/tuned/ppd.conf
|
||||
|
||||
%changelog
|
||||
* Fri Feb 16 2024 Jaroslav Škarvada <jskarvad@redhat.com> - 2.22.0-1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
related: RHEL-17119
|
||||
- lower CPU usage by using runtime=0 in profiles using scheduler plugin
|
||||
resolves: RHEL-6869
|
||||
|
||||
* Fri Feb 9 2024 Jaroslav Škarvada <jskarvad@redhat.com> - 2.22.0-0.1.rc1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
|
Loading…
Reference in New Issue
Block a user