new release
rebased tuned to latest upstream resolves: rhbz#2182119 sap-hana: new profile sap-hana-kvm-guest resolves: rhbz#2173740 serialized SIGHUP handler to prevent possible bootcmdline corruption resolves: rhbz#2215298 Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com>
This commit is contained in:
parent
0575ba1ba1
commit
db3572b897
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,5 +1 @@
|
||||
/tuned-2.18.0.tar.gz
|
||||
/tuned-2.19.0-rc.1.tar.gz
|
||||
/tuned-2.19.0.tar.gz
|
||||
/tuned-2.20.0-rc.1.tar.gz
|
||||
/tuned-2.20.0.tar.gz
|
||||
/tuned-*.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tuned-2.20.0.tar.gz) = c8b9fc5bdc684b3c518267875b3757fce5d607bec0df7946fe3a7d345683ea0baa2f8b9bbfb741083b82fd9ca7c825506ca86ea530551837b42c11b45f24ccea
|
||||
SHA512 (tuned-2.21.0-rc.1.tar.gz) = 92b0ef5a117c6f40c3260676ffdf23c5ea92952505501ccd67ede03a3a34b358c9a789757a00f4ab2c0dc89907f25d2eb5b53ec2e5766d941ba2c129cc123b92
|
||||
|
@ -1,5 +1,5 @@
|
||||
diff --git a/profiles/cpu-partitioning/script.sh b/profiles/cpu-partitioning/script.sh
|
||||
index 84e04fd..8677050 100755
|
||||
index ec422ca..cb378b7 100755
|
||||
--- a/profiles/cpu-partitioning/script.sh
|
||||
+++ b/profiles/cpu-partitioning/script.sh
|
||||
@@ -2,6 +2,38 @@
|
||||
@ -60,7 +60,7 @@ index 84e04fd..8677050 100755
|
||||
}
|
||||
|
||||
diff --git a/profiles/cpu-partitioning/tuned.conf b/profiles/cpu-partitioning/tuned.conf
|
||||
index 979e40b..842e2bd 100644
|
||||
index 11f03cf..a682c9c 100644
|
||||
--- a/profiles/cpu-partitioning/tuned.conf
|
||||
+++ b/profiles/cpu-partitioning/tuned.conf
|
||||
@@ -35,8 +35,6 @@ no_balance_cores_expanded=${f:cpulist_unpack:${no_balance_cores}}
|
||||
@ -69,10 +69,10 @@ index 979e40b..842e2bd 100644
|
||||
|
||||
-cmd_isolcpus=${f:regex_search_ternary:${no_balance_cores}:\s*[0-9]: isolcpus=${no_balance_cores}:}
|
||||
-
|
||||
[sysctl]
|
||||
kernel.hung_task_timeout_secs = 600
|
||||
kernel.nmi_watchdog = 0
|
||||
@@ -68,4 +66,4 @@ priority=10
|
||||
[sysfs]
|
||||
/sys/bus/workqueue/devices/writeback/cpumask = ${not_isolated_cpumask}
|
||||
/sys/devices/virtual/workqueue/cpumask = ${not_isolated_cpumask}
|
||||
@@ -62,4 +60,4 @@ priority=10
|
||||
initrd_remove_dir=True
|
||||
initrd_dst_img=tuned-initrd.img
|
||||
initrd_add_dir=${tmpdir}
|
23
tuned.spec
23
tuned.spec
@ -26,16 +26,16 @@
|
||||
%endif
|
||||
%endif
|
||||
|
||||
#%%global prerelease rc
|
||||
#%%global prereleasenum 1
|
||||
%global prerelease rc
|
||||
%global prereleasenum 1
|
||||
|
||||
%global prerel1 %{?prerelease:.%{prerelease}%{prereleasenum}}
|
||||
%global prerel2 %{?prerelease:-%{prerelease}.%{prereleasenum}}
|
||||
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.20.0
|
||||
Release: 1%{?prerel1}%{?dist}
|
||||
Version: 2.21.0
|
||||
Release: 0.1%{?prerel1}%{?dist}
|
||||
License: GPLv2+
|
||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
||||
# RHEL-8 specific recommend.conf:
|
||||
@ -96,7 +96,7 @@ Requires: python3-syspurpose
|
||||
# Revert upstream profiles changes which have not been approved for RHEL-8 (yet)
|
||||
Patch0: tuned-2.20.0-rhel-8-profiles.patch
|
||||
# Revert no balancing cores to use SD_LOAD_BALANCE (see rhbz#1874596 for details)
|
||||
Patch1: tuned-2.18.0-sd-load-balance.patch
|
||||
Patch1: tuned-2.21.0-sd-load-balance.patch
|
||||
|
||||
%description
|
||||
The tuned package contains a daemon that tunes system settings dynamically.
|
||||
@ -410,6 +410,7 @@ fi
|
||||
%exclude %{_prefix}/lib/tuned/spindown-disk
|
||||
%exclude %{_prefix}/lib/tuned/sap-netweaver
|
||||
%exclude %{_prefix}/lib/tuned/sap-hana
|
||||
%exclude %{_prefix}/lib/tuned/sap-hana-kvm-guest
|
||||
%exclude %{_prefix}/lib/tuned/mssql
|
||||
%exclude %{_prefix}/lib/tuned/oracle
|
||||
%exclude %{_prefix}/lib/tuned/atomic-host
|
||||
@ -434,7 +435,6 @@ fi
|
||||
%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/tuned/post_loaded_profile
|
||||
%config(noreplace) %{_sysconfdir}/tuned/tuned-main.conf
|
||||
%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/tuned/bootcmdline
|
||||
%{_sysconfdir}/dbus-1/system.d/com.redhat.tuned.conf
|
||||
%verify(not size mtime md5) %{_sysconfdir}/modprobe.d/tuned.conf
|
||||
%{_tmpfilesdir}/tuned.conf
|
||||
%{_unitdir}/tuned.service
|
||||
@ -446,6 +446,7 @@ fi
|
||||
%{_mandir}/man8/tuned*
|
||||
%dir %{_datadir}/tuned
|
||||
%{_datadir}/tuned/grub2
|
||||
%{_datadir}/dbus-1/system.d/com.redhat.tuned.conf
|
||||
%{_datadir}/polkit-1/actions/com.redhat.tuned.policy
|
||||
%ghost %{_sysconfdir}/modprobe.d/kvm.rt.tuned.conf
|
||||
%{_prefix}/lib/kernel/install.d/92-tuned.install
|
||||
@ -485,6 +486,7 @@ fi
|
||||
|
||||
%files profiles-sap-hana
|
||||
%{_prefix}/lib/tuned/sap-hana
|
||||
%{_prefix}/lib/tuned/sap-hana-kvm-guest
|
||||
%{_mandir}/man7/tuned-profiles-sap-hana.7*
|
||||
|
||||
%files profiles-mssql
|
||||
@ -550,6 +552,15 @@ fi
|
||||
%{_mandir}/man7/tuned-profiles-openshift.7*
|
||||
|
||||
%changelog
|
||||
* Sun Aug 20 2023 Jaroslav Škarvada <jskarvad@redhat.com> - 2.21.0-0.1.rc1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
resolves: rhbz#2182119
|
||||
- sap-hana: new profile sap-hana-kvm-guest
|
||||
resolves: rhbz#2173740
|
||||
- serialized SIGHUP handler to prevent possible bootcmdline corruption
|
||||
resolves: rhbz#2215298
|
||||
|
||||
* Fri Feb 17 2023 Jaroslav Škarvada <jskarvad@redhat.com> - 2.20.0-1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
|
Loading…
Reference in New Issue
Block a user