new release
rebased tuned to latest upstream related: rhbz#1546598 IRQ affinity handled by scheduler plugin resolves: rhbz#1590937
This commit is contained in:
parent
2894163119
commit
c4309b362f
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,4 +1 @@
|
||||
tuned-*.tar.bz2
|
||||
/tuned-2.9.0.rc1.tar.gz
|
||||
/tuned-2.9.0.tar.gz
|
||||
/kvm-unit-tests-20171020.tar.gz
|
||||
tuned-*.tar.gz
|
||||
|
@ -1,36 +0,0 @@
|
||||
@@ -, +, @@
|
||||
---
|
||||
profiles/realtime-virtual-host/run-tscdeadline-latency.sh | 4 ++--
|
||||
profiles/realtime-virtual-host/script.sh | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
--- a/profiles/realtime-virtual-host/run-tscdeadline-latency.sh
|
||||
+++ a/profiles/realtime-virtual-host/run-tscdeadline-latency.sh
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-QEMU=/usr/libexec/qemu-kvm
|
||||
+QEMU=$(type -P qemu-kvm || echo /usr/libexec/qemu-kvm)
|
||||
|
||||
if [ ! -f /sys/module/kvm/parameters/lapic_timer_advance_ns ]; then
|
||||
echo "/sys/module/kvm/parameters/lapic_timer_advance_ns not found"
|
||||
@@ -14,7 +14,7 @@ for i in `seq 1000 500 7000`; do
|
||||
chrt -f 1 taskset -c $1 $QEMU -enable-kvm -device pc-testdev \
|
||||
-device isa-debug-exit,iobase=0xf4,iosize=0x4 \
|
||||
-display none -serial stdio -device pci-testdev \
|
||||
- -kernel /usr/share/qemu-kvm/tscdeadline_latency.flat \
|
||||
+ -kernel /usr/share/tuned/tscdeadline_latency.flat \
|
||||
-cpu host | grep latency | cut -f 2 -d ":" > $dir/out
|
||||
|
||||
A=0
|
||||
--- a/profiles/realtime-virtual-host/script.sh
|
||||
+++ a/profiles/realtime-virtual-host/script.sh
|
||||
@@ -26,7 +26,7 @@ start() {
|
||||
|
||||
|
||||
if [ -f $ltanfile -a ! -f ./lapic_timer_adv_ns ]; then
|
||||
- if [ -f /usr/share/qemu-kvm/tscdeadline_latency.flat ]; then
|
||||
+ if [ -f /usr/share/tuned/tscdeadline_latency.flat ]; then
|
||||
tempdir=`mktemp -d`
|
||||
isolatedcpu=`echo "$TUNED_isolated_cores_expanded" | cut -f 1 -d ","`
|
||||
sh ./run-tscdeadline-latency.sh $isolatedcpu > $tempdir/lat.out
|
||||
--
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tuned-2.9.0.tar.gz) = ece7e2f21cddccc6df6cbd72d88b2368e06ae16975820f29a3a435cf2609679fe539899d7b42a894b9cc70f6a9a007722c450798d532ba16315471c1215d5edf
|
||||
SHA512 (tuned-2.10.0.tar.gz) = e0674533f17ac27cd3647808cda1f51d9905f563521af8cb3ffd1854098d6e2ca1adac82e542e6bdf86cce7e659303464eac50b8823167360783a75843d02a60
|
||||
|
@ -1,25 +0,0 @@
|
||||
From b776b7420cca949bf1e1e128e2cbbc9348d2345c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
|
||||
Date: Mon, 24 Jul 2017 16:42:28 +0200
|
||||
Subject: [PATCH] disk: Fix traceback in dynamic tuning
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
|
||||
---
|
||||
tuned/plugins/plugin_disk.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/tuned/plugins/plugin_disk.py b/tuned/plugins/plugin_disk.py
|
||||
index f91bd4e..22721d5 100644
|
||||
--- a/tuned/plugins/plugin_disk.py
|
||||
+++ b/tuned/plugins/plugin_disk.py
|
||||
@@ -180,6 +180,7 @@ def _instance_update_dynamic(self, instance, device):
|
||||
(rc, out) = self._cmd.execute(["hdparm", "-B%d" % new_power_level, "/dev/%s" % device], no_errors = [errno.ENOENT])
|
||||
self._update_errcnt(rc, False)
|
||||
elif instance._spindown_change_delayed[device] and self._drive_spinning(device):
|
||||
+ new_spindown_level = self._spindown_levels[idle["level"]]
|
||||
self._change_spindown(instance, device, new_spindown_level)
|
||||
|
||||
log.debug("%s load: read %0.2f, write %0.2f" % (device, stats["read"], stats["write"]))
|
139
tuned.spec
139
tuned.spec
@ -1,4 +1,27 @@
|
||||
%global _binaries_in_noarch_packages_terminate_build 0
|
||||
%if 0%{?fedora}
|
||||
%if 0%{?fedora} > 27
|
||||
%bcond_without python3
|
||||
%else
|
||||
%bcond_with python3
|
||||
%endif
|
||||
%else
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
%bcond_with python3
|
||||
%else
|
||||
%bcond_without python3
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%if %{with python3}
|
||||
%global _py python3
|
||||
%else
|
||||
%{!?python2_sitelib:%global python2_sitelib %{python_sitelib}}
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
%global _py python
|
||||
%else
|
||||
%global _py python2
|
||||
%endif
|
||||
%endif
|
||||
|
||||
#%%global prerelease rc
|
||||
#%%global prereleasenum 2
|
||||
@ -8,27 +31,31 @@
|
||||
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.9.0
|
||||
Release: 9%{?prerel1}%{?dist}
|
||||
Version: 2.10.0
|
||||
Release: 1%{?prerel1}%{?dist}
|
||||
License: GPLv2+
|
||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}.tar.gz#/%{name}-%{version}%{?prerel1}.tar.gz
|
||||
URL: http://www.tuned-project.org/
|
||||
BuildArch: noarch
|
||||
BuildRequires: python2, systemd, desktop-file-utils
|
||||
BuildRequires: gcc-x86_64-linux-gnu
|
||||
BuildRequires: systemd, desktop-file-utils
|
||||
Requires(post): systemd, virt-what
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
Requires: python2-decorator, python2-dbus, python2-gobject-base, python2-pyudev
|
||||
Requires: virt-what, python2-configobj, ethtool, gawk, hdparm
|
||||
Requires: util-linux, python2-perf, dbus, polkit, python2-linux-procfs
|
||||
Requires: python2-schedutils
|
||||
BuildRequires: %{_py}, %{_py}-devel
|
||||
Requires: %{_py}-decorator, %{_py}-pyudev, %{_py}-configobj
|
||||
Requires: %{_py}-schedutils, %{_py}-linux-procfs, %{_py}-perf
|
||||
# requires for packages with inconsistent python2/3 names
|
||||
%if %{with python3}
|
||||
Requires: python3-dbus, python3-gobject-base
|
||||
%else
|
||||
Requires: dbus-python, pygobject3-base
|
||||
%endif
|
||||
Requires: virt-what, ethtool, gawk, hdparm
|
||||
Requires: util-linux, dbus, polkit
|
||||
%if 0%{?fedora} > 22 || 0%{?rhel} > 7
|
||||
Recommends: kernel-tools
|
||||
%endif
|
||||
|
||||
Patch1: 0001-port-realtime-virtual-host-profile-to-Fedora.patch
|
||||
|
||||
%description
|
||||
The tuned package contains a daemon that tunes system settings dynamically.
|
||||
It does so by monitoring the usage of several system components periodically.
|
||||
@ -47,7 +74,13 @@ network and ATA harddisk devices are implemented.
|
||||
%package gtk
|
||||
Summary: GTK GUI for tuned
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: powertop, python2-gobject-base, polkit
|
||||
Requires: powertop, polkit
|
||||
# requires for packages with inconsistent python2/3 names
|
||||
%if %{with python3}
|
||||
Requires: python3-gobject-base
|
||||
%else
|
||||
Requires: pygobject3-base
|
||||
%endif
|
||||
|
||||
%description gtk
|
||||
GTK GUI that can control tuned and provides simple profile editor.
|
||||
@ -80,6 +113,13 @@ Requires: %{name} = %{version}
|
||||
%description profiles-sap
|
||||
Additional tuned profile(s) targeted to SAP NetWeaver loads.
|
||||
|
||||
%package profiles-mssql
|
||||
Summary: Additional tuned profile(s) for MS SQL Server
|
||||
Requires: %{name} = %{version}
|
||||
|
||||
%description profiles-mssql
|
||||
Additional tuned profile(s) for MS SQL Server.
|
||||
|
||||
%package profiles-oracle
|
||||
Summary: Additional tuned profile(s) targeted to Oracle loads
|
||||
Requires: %{name} = %{version}
|
||||
@ -122,8 +162,12 @@ Additional tuned profile(s) targeted to Network Function Virtualization (NFV) gu
|
||||
Summary: Additional tuned profile(s) targeted to Network Function Virtualization (NFV) host
|
||||
Requires: %{name} = %{version}
|
||||
Requires: %{name}-profiles-realtime = %{version}
|
||||
Recommends: tuned-profiles-nfv-host-bin
|
||||
Requires: tuna
|
||||
%if 0%{?rhel} == 7
|
||||
Requires: qemu-kvm-tools-rhev
|
||||
%else
|
||||
Recommends: tuned-profiles-nfv-host-bin
|
||||
%endif
|
||||
|
||||
%description profiles-nfv-host
|
||||
Additional tuned profile(s) targeted to Network Function Virtualization (NFV) host.
|
||||
@ -155,12 +199,16 @@ It can be also used to fine tune your system for specific scenarios.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?prerel2}
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot} DOCDIR=%{docdir}
|
||||
make install DESTDIR=%{buildroot} DOCDIR=%{docdir} \
|
||||
%if %{with python3}
|
||||
PYTHON=python3
|
||||
%else
|
||||
PYTHON=python2
|
||||
%endif
|
||||
%if 0%{?rhel}
|
||||
sed -i 's/\(dynamic_tuning[ \t]*=[ \t]*\).*/\10/' %{buildroot}%{_sysconfdir}/tuned/tuned-main.conf
|
||||
%endif
|
||||
@ -181,8 +229,6 @@ touch %{buildroot}%{_sysconfdir}/modprobe.d/kvm.rt.tuned.conf
|
||||
# validate desktop file
|
||||
desktop-file-validate %{buildroot}%{_datadir}/applications/tuned-gui.desktop
|
||||
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/tuned/recommend.d
|
||||
|
||||
%post
|
||||
%systemd_post tuned.service
|
||||
|
||||
@ -243,8 +289,13 @@ fi
|
||||
%exclude %{docdir}/README.NFV
|
||||
%doc %{docdir}
|
||||
%{_datadir}/bash-completion/completions/tuned-adm
|
||||
%exclude %{python_sitelib}/tuned/gtk
|
||||
%{python_sitelib}/tuned
|
||||
%if %{with python3}
|
||||
%exclude %{python3_sitelib}/tuned/gtk
|
||||
%{python3_sitelib}/tuned
|
||||
%else
|
||||
%exclude %{python2_sitelib}/tuned/gtk
|
||||
%{python2_sitelib}/tuned
|
||||
%endif
|
||||
%{_sbindir}/tuned
|
||||
%{_sbindir}/tuned-adm
|
||||
%exclude %{_sysconfdir}/tuned/realtime-variables.conf
|
||||
@ -262,6 +313,7 @@ fi
|
||||
%exclude %{_prefix}/lib/tuned/sap-netweaver
|
||||
%exclude %{_prefix}/lib/tuned/sap-hana
|
||||
%exclude %{_prefix}/lib/tuned/sap-hana-vmware
|
||||
%exclude %{_prefix}/lib/tuned/mssql
|
||||
%exclude %{_prefix}/lib/tuned/oracle
|
||||
%exclude %{_prefix}/lib/tuned/atomic-host
|
||||
%exclude %{_prefix}/lib/tuned/atomic-guest
|
||||
@ -296,7 +348,11 @@ fi
|
||||
%files gtk
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/tuned-gui
|
||||
%{python_sitelib}/tuned/gtk
|
||||
%if %{with python3}
|
||||
%{python3_sitelib}/tuned/gtk
|
||||
%else
|
||||
%{python2_sitelib}/tuned/gtk
|
||||
%endif
|
||||
%{_datadir}/tuned/ui
|
||||
%{_datadir}/polkit-1/actions/com.redhat.tuned.gui.policy
|
||||
%{_datadir}/icons/hicolor/scalable/apps/tuned.svg
|
||||
@ -333,6 +389,11 @@ fi
|
||||
%{_prefix}/lib/tuned/sap-hana-vmware
|
||||
%{_mandir}/man7/tuned-profiles-sap-hana.7*
|
||||
|
||||
%files profiles-mssql
|
||||
%defattr(-,root,root,-)
|
||||
%{_prefix}/lib/tuned/mssql
|
||||
%{_mandir}/man7/tuned-profiles-mssql.7*
|
||||
|
||||
%files profiles-oracle
|
||||
%defattr(-,root,root,-)
|
||||
%{_prefix}/lib/tuned/oracle
|
||||
@ -384,6 +445,44 @@ fi
|
||||
%{_mandir}/man7/tuned-profiles-compat.7*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 4 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.10.0-1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
related: rhbz#1546598
|
||||
- IRQ affinity handled by scheduler plugin
|
||||
resolves: rhbz#1590937
|
||||
|
||||
* Mon Jun 11 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.10.0-0.1.rc1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
resolves: rhbz#1546598
|
||||
- script: show stderr output in the log
|
||||
resolves: rhbz#1536476
|
||||
- realtime-virtual-host: script.sh: add error checking
|
||||
resolves: rhbz#1461509
|
||||
- man: improved tuned-profiles-cpu-partitioning.7
|
||||
resolves: rhbz#1548148
|
||||
- bootloader: check if grub2_cfg_file_name is None in _remove_grub2_tuning()
|
||||
resolves: rhbz#1571403
|
||||
- plugin_scheduler: whitelist/blacklist processed also for thread names
|
||||
resolves: rhbz#1512295
|
||||
- bootloader: patch all GRUB2 config files
|
||||
resolves: rhbz#1556990
|
||||
- profiles: added mssql profile
|
||||
resolves: rhbz#1442122
|
||||
- tuned-adm: print log excerpt when changing profile
|
||||
resolves: rhbz#1538745
|
||||
- cpu-partitioning: use no_balance_cores instead of no_rebalance_cores
|
||||
resolves: rhbz#1550573
|
||||
- sysctl: support assignment modifiers as other plugins do
|
||||
resolves: rhbz#1564092
|
||||
- oracle: fixed ip_local_port_range parity warning
|
||||
resolves: rhbz#1527219
|
||||
- Fix verifying cpumask on systems with more than 32 cores
|
||||
resolves: rhbz#1528368
|
||||
- oracle: updated the profile to be in sync with KCS 39188
|
||||
resolves: rhbz#1447323
|
||||
|
||||
* Fri Mar 23 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 2.9.0-9
|
||||
- Used weak deps for tuned-profiles-nfv-host-bin
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user