new-release:
- cpu plugin: fixed cpupower workaround - cpu plugin: fixed crash if cpupower is installed
This commit is contained in:
parent
542d061091
commit
bab7da30aa
2
sources
2
sources
@ -1 +1 @@
|
||||
23535f08a5429470210f0e5de1a5c138 tuned-2.2.1.tar.bz2
|
||||
5e11187ec86e8739772835a755f7a263 tuned-2.2.2.tar.bz2
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 7088da12020efb572f1c1fa52e4c26ab13f53814 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jaroslav=20=C5=A0karvada?= <jskarvad@redhat.com>
|
||||
Date: Mon, 4 Mar 2013 14:32:35 +0100
|
||||
Subject: [PATCH] cpu plugin: fixed crash if cpupower is installed
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com>
|
||||
---
|
||||
tuned/plugins/plugin_cpu.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tuned/plugins/plugin_cpu.py b/tuned/plugins/plugin_cpu.py
|
||||
index cf21496..99a979d 100644
|
||||
--- a/tuned/plugins/plugin_cpu.py
|
||||
+++ b/tuned/plugins/plugin_cpu.py
|
||||
@@ -124,9 +124,9 @@ class CPULatencyPlugin(base.Plugin):
|
||||
governor = None
|
||||
if self._has_cpupower:
|
||||
cpu_id = device.lstrip("cpu")
|
||||
- retcode, lines = tuned.utils.commands.execute(["cpupower", "-c", cpu_id, "frequency-info", "-p"]).splitlines()
|
||||
+ retcode, lines = tuned.utils.commands.execute(["cpupower", "-c", cpu_id, "frequency-info", "-p"])
|
||||
if retcode == 0:
|
||||
- for line in lines:
|
||||
+ for line in lines.splitlines():
|
||||
if line.startswith("analyzing"):
|
||||
continue
|
||||
l = line.split()
|
||||
--
|
||||
1.7.11.7
|
||||
|
13
tuned.spec
13
tuned.spec
@ -1,12 +1,10 @@
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.2.1
|
||||
Release: 2%{?dist}
|
||||
Version: 2.2.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Source: https://fedorahosted.org/releases/t/u/tuned/tuned-%{version}.tar.bz2
|
||||
URL: https://fedorahosted.org/tuned/
|
||||
# backported from upstream
|
||||
Patch0: tuned-2.2.1-cpu-fix-crash-if-cpupower.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: python, systemd
|
||||
Requires(post): systemd, virt-what
|
||||
@ -53,7 +51,6 @@ It can be also used to fine tune your system for specific scenarios.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -150,8 +147,10 @@ sed -i 's|.*/\([^/]\+\)/[^\.]\+\.conf|\1|' /etc/tuned/active_profile
|
||||
%{_prefix}/lib/tuned/spindown-disk
|
||||
|
||||
%changelog
|
||||
* Mon Mar 4 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2.1-2
|
||||
- fixed crash in cpupower plugin if cpupower is installed
|
||||
* Tue Mar 19 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2.2-1
|
||||
- new-release:
|
||||
- cpu plugin: fixed cpupower workaround
|
||||
- cpu plugin: fixed crash if cpupower is installed
|
||||
|
||||
* Fri Mar 1 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2.1-1
|
||||
- new release:
|
||||
|
Loading…
Reference in New Issue
Block a user