new release
rebased tuned to latest upstream resolves: rhbz#2057609 fixed parsing of inline comments added support for quotes in isolated_cores specification spec: reduced weak dependencies resolves: rhbz#2093841 recommend: do not ignore syspurpose_role if there is no syspurpose resolves: rhbz#2030580 added support for initial autosetup of isolated_cores resolves: rhbz#2093847
This commit is contained in:
parent
500c18046a
commit
955951ddd3
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tuned-2.18.0.tar.gz) = 9508bfad6502b7b9a72fb84d29308cbc10b3cb663b367c821e79ad4d57c2349086c199bf884440c46d230d08d0ad3df17d4f31ebdc03b68c7ba2695b6e18bcc9
|
||||
SHA512 (tuned-2.19.0-rc.1.tar.gz) = 471a751b86e116a9aa9c621900e4ae5214b7bdfe8b6d9bc5e376b792f689103f284c4a298d8907b47136a0f420962a326e134904398f3ebb529ed4d13bbedc3c
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 49cc817871672d0a5bad138dd7ad781b684a9fd9 Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Saenz Julienne <nsaenzju@redhat.com>
|
||||
Date: Wed, 16 Mar 2022 17:06:45 +0100
|
||||
Subject: [PATCH] realtime: Set tsc as 'reliable'
|
||||
|
||||
We already disable the clocksource watchdog, it's there to double-check
|
||||
whether clock results are coherent between reads. But a new reliability
|
||||
test was introduced in recent kernels[1], tracking tsc drift between
|
||||
CPUs[2]. It works by programming timers on all CPUs, including isolated
|
||||
ones, and checks whether the tsc was adjusted in between runs. This
|
||||
introduces unwarranted latency on real time systems. So let's promote
|
||||
tsc to 'reliable', which disables both checks.
|
||||
|
||||
There shouldn't be any impact on old nor new setups. First, this test
|
||||
didn't exist in the past, so any eventual drift was left uncorrected.
|
||||
Second, most telco and HPC use-cases will make heavy use of tsc in
|
||||
user-space, and its reliability is already assumed in the system's
|
||||
design.
|
||||
|
||||
[1] c7719e793478 x86/tsc: Add a timer to make sure TSC_adjust is always
|
||||
checked
|
||||
[2] Generally caused by rogue BIOSes adjusting the tsc on a CPU and not
|
||||
doing so on the rest
|
||||
|
||||
Signed-off-by: Nicolas Saenz Julienne <nsaenzju@redhat.com>
|
||||
---
|
||||
profiles/realtime/tuned.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/profiles/realtime/tuned.conf b/profiles/realtime/tuned.conf
|
||||
index b1657af..196ed01 100644
|
||||
--- a/profiles/realtime/tuned.conf
|
||||
+++ b/profiles/realtime/tuned.conf
|
||||
@@ -52,7 +52,7 @@ kernel.timer_migration = 0
|
||||
/sys/devices/system/machinecheck/machinecheck*/ignore_ce = 1
|
||||
|
||||
[bootloader]
|
||||
-cmdline_realtime=+isolcpus=${managed_irq}${isolated_cores} intel_pstate=disable nosoftlockup tsc=nowatchdog
|
||||
+cmdline_realtime=+isolcpus=${managed_irq}${isolated_cores} intel_pstate=disable nosoftlockup tsc=reliable
|
||||
|
||||
[irqbalance]
|
||||
banned_cpus=${isolated_cores}
|
||||
--
|
||||
2.35.1
|
||||
|
38
tuned.spec
38
tuned.spec
@ -26,16 +26,16 @@
|
||||
%endif
|
||||
%endif
|
||||
|
||||
#%%global prerelease rc
|
||||
#%%global prereleasenum 1
|
||||
%global prerelease rc
|
||||
%global prereleasenum 1
|
||||
|
||||
%global prerel1 %{?prerelease:.%{prerelease}%{prereleasenum}}
|
||||
%global prerel2 %{?prerelease:-%{prerelease}.%{prereleasenum}}
|
||||
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.18.0
|
||||
Release: 2%{?prerel1}%{?dist}
|
||||
Version: 2.19.0
|
||||
Release: 0.1%{?prerel1}%{?dist}
|
||||
License: GPLv2+
|
||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
||||
# RHEL-9 specific recommend.conf:
|
||||
@ -54,8 +54,8 @@ Requires(postun): systemd
|
||||
BuildRequires: make
|
||||
BuildRequires: %{_py}, %{_py}-devel
|
||||
# BuildRequires for 'make test'
|
||||
# python-mock is needed for python-2.7, but it's not available on RHEL-7
|
||||
%if %{without python3} && ( ! 0%{?rhel} || 0%{?rhel} >= 8 )
|
||||
# python-mock is needed for python-2.7, but it's not available on RHEL-7, only in the EPEL
|
||||
%if %{without python3} && ( ! 0%{?rhel} || 0%{?rhel} >= 8 || 0%{?epel})
|
||||
BuildRequires: %{_py}-mock
|
||||
%endif
|
||||
BuildRequires: %{_py}-pyudev
|
||||
@ -81,10 +81,11 @@ Requires: virt-what, ethtool, gawk
|
||||
Requires: util-linux, dbus, polkit
|
||||
%if 0%{?fedora} > 22 || 0%{?rhel} > 7
|
||||
Recommends: dmidecode
|
||||
Recommends: hdparm
|
||||
# i686 excluded
|
||||
Recommends: kernel-tools
|
||||
Recommends: kmod
|
||||
Recommends: iproute
|
||||
Requires: hdparm
|
||||
Requires: kmod
|
||||
Requires: iproute
|
||||
%endif
|
||||
# syspurpose
|
||||
%if 0%{?rhel} > 8
|
||||
@ -97,7 +98,6 @@ Recommends: subscription-manager
|
||||
Requires: python3-syspurpose
|
||||
%endif
|
||||
%endif
|
||||
Patch0: tuned-2.18.0-realtime-tsc-reliable.patch
|
||||
|
||||
%description
|
||||
The tuned package contains a daemon that tunes system settings dynamically.
|
||||
@ -298,10 +298,9 @@ touch %{buildroot}%{_sysconfdir}/modprobe.d/kvm.rt.tuned.conf
|
||||
# validate desktop file
|
||||
desktop-file-validate %{buildroot}%{_datadir}/applications/tuned-gui.desktop
|
||||
|
||||
# Run tests on RHEL > 7 or non RHEL
|
||||
# We cannot run tests on RHEL-7 because there is no python-mock package and
|
||||
# On RHEL-7 EPEL is needed, because there is no python-mock package and
|
||||
# python-2.7 doesn't have mock built-in
|
||||
%if 0%{?rhel} > 7 || ! 0%{?rhel}
|
||||
%if 0%{?rhel} >= 8 || 0%{?epel} || ! 0%{?rhel}
|
||||
%check
|
||||
make test %{make_python_arg}
|
||||
%endif
|
||||
@ -549,6 +548,19 @@ fi
|
||||
%{_mandir}/man7/tuned-profiles-openshift.7*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 9 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 2.19.0-0.1.rc1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
resolves: rhbz#2057609
|
||||
- fixed parsing of inline comments
|
||||
- added support for quotes in isolated_cores specification
|
||||
- spec: reduced weak dependencies
|
||||
resolves: rhbz#2093841
|
||||
- recommend: do not ignore syspurpose_role if there is no syspurpose
|
||||
resolves: rhbz#2030580
|
||||
- added support for initial autosetup of isolated_cores
|
||||
resolves: rhbz#2093847
|
||||
|
||||
* Thu May 19 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 2.18.0-2
|
||||
- realtime: set tsc as reliable
|
||||
resolves: rhbz#2086374
|
||||
|
Loading…
Reference in New Issue
Block a user