new release
rebased tuned to latest upstream resolves: rhbz#1685585 sap-netweaver: changed values of kernel.shmall and kernel.shmmax to RHEL-8 defaults resolves: rhbz#1708418 sap-netweaver: changed value of kernel.sem to RHEL-8 default resolves: rhbz#1701394 sap-hana-vmware: dropped profile resolves: rhbz#1715541 s2kb function: fixed to be compatible with python3 resolves: rhbz#1684122 do fallback to the powersave governor (balanced and powersave profiles) resolves: rhbz#1679205 added support for negation of CPU list resolves: rhbz#1676588 switched from sysctl tool to own implementation resolves: rhbz#1666678 realtime-virtual-host: added tsc-deadline=on to qemu cmdline resolves: rhbz#1554458 fixed handling of devices that have been removed and re-attached resolves: rhbz#1677730
This commit is contained in:
parent
3389e183b6
commit
887e970c0c
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tuned-2.11.0.tar.gz) = d3ce400f73bc868bafe34433c9b7c1c425e744e70559b86808b59c7820c6baefc41b435eeeb5e6fdbcc28731cee079e6adeb709615cb9c778dc316d69527b0a9
|
||||
SHA512 (tuned-2.12.0-rc.1.tar.gz) = bd1a83d1ff9c8b31815cec8fba432b2316bdd9d74b84e3376e5a31b9a1bdb4d0986cd01ecf25dc9a642bb0012ed91e7bb7b94df21764e28003b920b25ab3cd27
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/experiments/powertop2tuned.py b/experiments/powertop2tuned.py
|
||||
index ec69d97..76d048a 100755
|
||||
--- a/experiments/powertop2tuned.py
|
||||
+++ b/experiments/powertop2tuned.py
|
||||
@@ -96,7 +96,7 @@ class PowertopHTMLParser(HTMLParser):
|
||||
|
||||
def handle_starttag(self, tag, attrs):
|
||||
self.lastStartTag = tag
|
||||
- if self.lastStartTag == "div" and dict(attrs).get("id") == "tuning":
|
||||
+ if self.lastStartTag == "div" and dict(attrs).get("id") in ["tuning", "wakeup"]:
|
||||
self.inProperTable = True
|
||||
if self.inProperTable and tag == "td":
|
||||
self.tdCounter += 1
|
37
tuned.spec
37
tuned.spec
@ -25,16 +25,16 @@
|
||||
%endif
|
||||
%endif
|
||||
|
||||
#%%global prerelease rc
|
||||
#%%global prereleasenum 1
|
||||
%global prerelease rc
|
||||
%global prereleasenum 1
|
||||
|
||||
%global prerel1 %{?prerelease:.%{prerelease}%{prereleasenum}}
|
||||
%global prerel2 %{?prerelease:-%{prerelease}.%{prereleasenum}}
|
||||
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.11.0
|
||||
Release: 1%{?prerel1}%{?dist}
|
||||
Version: 2.12.0
|
||||
Release: 0.1%{?prerel1}%{?dist}
|
||||
License: GPLv2+
|
||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
||||
URL: http://www.tuned-project.org/
|
||||
@ -71,7 +71,6 @@ Recommends: kernel-tools
|
||||
%if 0%{?rhel} > 7
|
||||
Requires: python3-syspurpose
|
||||
%endif
|
||||
Patch0: tuned-2.11.0-powertop2tuned-add-wakeup-support.patch
|
||||
|
||||
%description
|
||||
The tuned package contains a daemon that tunes system settings dynamically.
|
||||
@ -216,7 +215,6 @@ It can be also used to fine tune your system for specific scenarios.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?prerel2}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
make html %{make_python_arg}
|
||||
@ -336,7 +334,6 @@ fi
|
||||
%exclude %{_sysconfdir}/tuned/realtime-virtual-guest-variables.conf
|
||||
%exclude %{_sysconfdir}/tuned/realtime-virtual-host-variables.conf
|
||||
%exclude %{_sysconfdir}/tuned/cpu-partitioning-variables.conf
|
||||
%exclude %{_sysconfdir}/tuned/sap-hana-vmware-variables.conf
|
||||
%exclude %{_prefix}/lib/tuned/default
|
||||
%exclude %{_prefix}/lib/tuned/desktop-powersave
|
||||
%exclude %{_prefix}/lib/tuned/laptop-ac-powersave
|
||||
@ -346,7 +343,6 @@ fi
|
||||
%exclude %{_prefix}/lib/tuned/spindown-disk
|
||||
%exclude %{_prefix}/lib/tuned/sap-netweaver
|
||||
%exclude %{_prefix}/lib/tuned/sap-hana
|
||||
%exclude %{_prefix}/lib/tuned/sap-hana-vmware
|
||||
%exclude %{_prefix}/lib/tuned/mssql
|
||||
%exclude %{_prefix}/lib/tuned/oracle
|
||||
%exclude %{_prefix}/lib/tuned/atomic-host
|
||||
@ -414,9 +410,7 @@ fi
|
||||
%{_mandir}/man7/tuned-profiles-sap.7*
|
||||
|
||||
%files profiles-sap-hana
|
||||
%config(noreplace) %{_sysconfdir}/tuned/sap-hana-vmware-variables.conf
|
||||
%{_prefix}/lib/tuned/sap-hana
|
||||
%{_prefix}/lib/tuned/sap-hana-vmware
|
||||
%{_mandir}/man7/tuned-profiles-sap-hana.7*
|
||||
|
||||
%files profiles-mssql
|
||||
@ -466,6 +460,29 @@ fi
|
||||
%{_mandir}/man7/tuned-profiles-compat.7*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 12 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 2.12.0-0.1.rc1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
resolves: rhbz#1685585
|
||||
- sap-netweaver: changed values of kernel.shmall and kernel.shmmax to RHEL-8 defaults
|
||||
resolves: rhbz#1708418
|
||||
- sap-netweaver: changed value of kernel.sem to RHEL-8 default
|
||||
resolves: rhbz#1701394
|
||||
- sap-hana-vmware: dropped profile
|
||||
resolves: rhbz#1715541
|
||||
- s2kb function: fixed to be compatible with python3
|
||||
resolves: rhbz#1684122
|
||||
- do fallback to the powersave governor (balanced and powersave profiles)
|
||||
resolves: rhbz#1679205
|
||||
- added support for negation of CPU list
|
||||
resolves: rhbz#1676588
|
||||
- switched from sysctl tool to own implementation
|
||||
resolves: rhbz#1666678
|
||||
- realtime-virtual-host: added tsc-deadline=on to qemu cmdline
|
||||
resolves: rhbz#1554458
|
||||
- fixed handling of devices that have been removed and re-attached
|
||||
resolves: rhbz#1677730
|
||||
|
||||
* Thu Mar 21 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 2.11.0-1
|
||||
- new release
|
||||
- rebased tuned to latest upstream
|
||||
|
Loading…
Reference in New Issue
Block a user