new version
This commit is contained in:
parent
ce40b308af
commit
3700404110
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (tuned-2.18.0.tar.gz) = 9508bfad6502b7b9a72fb84d29308cbc10b3cb663b367c821e79ad4d57c2349086c199bf884440c46d230d08d0ad3df17d4f31ebdc03b68c7ba2695b6e18bcc9
|
SHA512 (tuned-2.18.0-20220317gite1045f2d.tar.gz) = a80c8f35209307a6adbeece0e35af6014d1bd9016de4dcd2c808d5dcfa9f92b7169dbbbd6b5a70f04f8f333b2087ba6fedc76784d3eb9821dc72f767a4023cf7
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
From 4992d1b8f41561ba8baec23a3da13d202a82b09f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Vitaly Zaitsev <vitaly@easycoding.org>
|
|
||||||
Date: Sun, 13 Feb 2022 11:33:55 +0100
|
|
||||||
Subject: [PATCH] Added more conflicting implementations to the systemd unit
|
|
||||||
file.
|
|
||||||
|
|
||||||
Signed-off-by: Vitaly Zaitsev <vitaly@easycoding.org>
|
|
||||||
---
|
|
||||||
tuned.service | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tuned.service b/tuned.service
|
|
||||||
index 0d6c3c83..c822c105 100644
|
|
||||||
--- a/tuned.service
|
|
||||||
+++ b/tuned.service
|
|
||||||
@@ -2,7 +2,7 @@
|
|
||||||
Description=Dynamic System Tuning Daemon
|
|
||||||
After=systemd-sysctl.service network.target dbus.service
|
|
||||||
Requires=dbus.service polkit.service
|
|
||||||
-Conflicts=cpupower.service
|
|
||||||
+Conflicts=cpupower.service auto-cpufreq.service tlp.service power-profiles-daemon.service
|
|
||||||
Documentation=man:tuned(8) man:tuned.conf(5) man:tuned-adm(8)
|
|
||||||
|
|
||||||
[Service]
|
|
36
tuned.spec
36
tuned.spec
@ -1,3 +1,7 @@
|
|||||||
|
%global git_commit e1045f2d1d6fbcdd29a62b3540b846fa6b2a9153
|
||||||
|
#%%global git_date %%(date +'%Y%m%d')
|
||||||
|
%global git_date 20220317
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%if 0%{?fedora} > 27
|
%if 0%{?fedora} > 27
|
||||||
%bcond_without python3
|
%bcond_without python3
|
||||||
@ -26,6 +30,17 @@
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if 0%{?git_commit:1}
|
||||||
|
%if 0%{!?git_short_commit:1}
|
||||||
|
%global git_short_commit %(echo %{git_commit} | cut -c -8)
|
||||||
|
%global archive_topdir %{name}-%{git_commit}
|
||||||
|
%endif
|
||||||
|
%global git_suffix %{git_date}git%{git_short_commit}
|
||||||
|
# ! git_commit
|
||||||
|
%else
|
||||||
|
%global archive_topdir %{name}-%{version}%{?prerel2}
|
||||||
|
%endif
|
||||||
|
|
||||||
#%%global prerelease rc
|
#%%global prerelease rc
|
||||||
#%%global prereleasenum 1
|
#%%global prereleasenum 1
|
||||||
|
|
||||||
@ -35,9 +50,13 @@
|
|||||||
Summary: A dynamic adaptive system tuning daemon
|
Summary: A dynamic adaptive system tuning daemon
|
||||||
Name: tuned
|
Name: tuned
|
||||||
Version: 2.18.0
|
Version: 2.18.0
|
||||||
Release: 2%{?prerel1}%{?dist}
|
Release: 3%{?prerel1}%{?git_suffix:.%{git_suffix}}%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
|
%if 0%{?git_commit:1}
|
||||||
|
Source0: https://github.com/redhat-performance/%{name}/archive/%{git_commit}/%{name}-%{version}-%{git_suffix}.tar.gz
|
||||||
|
%else
|
||||||
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
Source0: https://github.com/redhat-performance/%{name}/archive/v%{version}%{?prerel2}/%{name}-%{version}%{?prerel2}.tar.gz
|
||||||
|
%endif
|
||||||
URL: http://www.tuned-project.org/
|
URL: http://www.tuned-project.org/
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: systemd, desktop-file-utils
|
BuildRequires: systemd, desktop-file-utils
|
||||||
@ -52,8 +71,8 @@ Requires(postun): systemd
|
|||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: %{_py}, %{_py}-devel
|
BuildRequires: %{_py}, %{_py}-devel
|
||||||
# BuildRequires for 'make test'
|
# BuildRequires for 'make test'
|
||||||
# python-mock is needed for python-2.7, but it's not available on RHEL-7
|
# python-mock is needed for python-2.7, but it's not available on RHEL-7, only in the EPEL
|
||||||
%if %{without python3} && ( ! 0%{?rhel} || 0%{?rhel} >= 8 )
|
%if %{without python3} && ( ! 0%{?rhel} || 0%{?rhel} >= 8 || 0%{?epel})
|
||||||
BuildRequires: %{_py}-mock
|
BuildRequires: %{_py}-mock
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: %{_py}-pyudev
|
BuildRequires: %{_py}-pyudev
|
||||||
@ -95,7 +114,6 @@ Recommends: subscription-manager
|
|||||||
Requires: python3-syspurpose
|
Requires: python3-syspurpose
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
Patch0: tuned-2.18.0-conflicting-services.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The tuned package contains a daemon that tunes system settings dynamically.
|
The tuned package contains a daemon that tunes system settings dynamically.
|
||||||
@ -256,7 +274,7 @@ Requires: %{name} = %{version}
|
|||||||
Additional TuneD profile(s) optimized for OpenShift.
|
Additional TuneD profile(s) optimized for OpenShift.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1 -n %{name}-%{version}%{?prerel2}
|
%autosetup -p1 -n %{archive_topdir}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Docs cannot be generated on RHEL now due to missing asciidoctor dependency
|
# Docs cannot be generated on RHEL now due to missing asciidoctor dependency
|
||||||
@ -292,10 +310,9 @@ touch %{buildroot}%{_sysconfdir}/modprobe.d/kvm.rt.tuned.conf
|
|||||||
# validate desktop file
|
# validate desktop file
|
||||||
desktop-file-validate %{buildroot}%{_datadir}/applications/tuned-gui.desktop
|
desktop-file-validate %{buildroot}%{_datadir}/applications/tuned-gui.desktop
|
||||||
|
|
||||||
# Run tests on RHEL > 7 or non RHEL
|
# On RHEL-7 EPEL is needed, because there is no python-mock package and
|
||||||
# We cannot run tests on RHEL-7 because there is no python-mock package and
|
|
||||||
# python-2.7 doesn't have mock built-in
|
# python-2.7 doesn't have mock built-in
|
||||||
%if 0%{?rhel} > 7 || ! 0%{?rhel}
|
%if 0%{?rhel} >= 8 || 0%{?epel} || ! 0%{?rhel}
|
||||||
%check
|
%check
|
||||||
make test %{make_python_arg}
|
make test %{make_python_arg}
|
||||||
%endif
|
%endif
|
||||||
@ -543,6 +560,9 @@ fi
|
|||||||
%{_mandir}/man7/tuned-profiles-openshift.7*
|
%{_mandir}/man7/tuned-profiles-openshift.7*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 16 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 2.18.0-3.20220317gite1045f2d
|
||||||
|
- new version
|
||||||
|
|
||||||
* Tue Feb 15 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 2.18.0-2
|
* Tue Feb 15 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 2.18.0-2
|
||||||
- added more conflicting services to the systemd service file
|
- added more conflicting services to the systemd service file
|
||||||
resolves: rhbz#2053919
|
resolves: rhbz#2053919
|
||||||
|
Loading…
Reference in New Issue
Block a user