new-release
resolves: rhbz#1020743 - audio plugin: fixed audio settings in standard profiles resolves: rhbz#1019805 - video plugin: fixed tunings - daemon: fixed crash if preset profile is not available resolves: rhbz#953128 - man: various updates and corrections - functions: fixed usb and bluetooth handling - tuned: switched to lightweighted pygobject3-base - daemon: added global config for dynamic_tuning resolves: rhbz#1006427 - utils: added pmqos-static script for debug purposes resolves: rhbz#1015676 - throughput-performance: various fixes resolves: rhbz#987570 - tuned: added global option update_interval - plugin_cpu: added support for x86_energy_perf_policy resolves: rhbz#1015675 - dbus: fixed KeyboardInterrupt handling - plugin_cpu: added support for intel_pstate resolves: rhbz#996722 - profiles: various fixes resolves: rhbz#922068 - profiles: added desktop profile resolves: rhbz#996723 - tuned-adm: implemented non DBus fallback control - profiles: added sap profile - tuned: lowered CPU usage due to python bug resolves: rhbz#917587
This commit is contained in:
parent
d51d7fe465
commit
340e63f3a9
2
sources
2
sources
@ -1 +1 @@
|
||||
5e11187ec86e8739772835a755f7a263 tuned-2.2.2.tar.bz2
|
||||
262304f1b3ddd8600aedd6c06be34ae2 tuned-2.3.0.tar.bz2
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up tuned-2.2.2/tuned/exports/dbus_exporter.py.orig tuned-2.2.2/tuned/exports/dbus_exporter.py
|
||||
--- tuned-2.2.2/tuned/exports/dbus_exporter.py.orig 2013-03-07 11:33:50.000000000 +0100
|
||||
+++ tuned-2.2.2/tuned/exports/dbus_exporter.py 2013-07-25 18:28:15.312578976 +0200
|
||||
@@ -2,9 +2,9 @@ import interfaces
|
||||
import decorator
|
||||
import dbus.service
|
||||
import dbus.mainloop.glib
|
||||
-import gobject
|
||||
import inspect
|
||||
import threading
|
||||
+from gi.repository import GObject as gobject
|
||||
|
||||
class DBusExporter(interfaces.ExporterInterface):
|
||||
"""
|
52
tuned.spec
52
tuned.spec
@ -1,7 +1,7 @@
|
||||
Summary: A dynamic adaptive system tuning daemon
|
||||
Name: tuned
|
||||
Version: 2.2.2
|
||||
Release: 2%{?dist}
|
||||
Version: 2.3.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Source: https://fedorahosted.org/releases/t/u/tuned/tuned-%{version}.tar.bz2
|
||||
URL: https://fedorahosted.org/tuned/
|
||||
@ -11,8 +11,7 @@ Requires(post): systemd, virt-what
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
Requires: python-decorator, dbus-python, pygobject3-base, python-pyudev
|
||||
Requires: virt-what, python-configobj, ethtool
|
||||
Patch0: tuned-2.2.2-pygobject-base.patch
|
||||
Requires: virt-what, python-configobj, ethtool, gawk
|
||||
|
||||
%description
|
||||
The tuned package contains a daemon that tunes system settings dynamically.
|
||||
@ -27,8 +26,8 @@ Summary: Various tuned utilities
|
||||
Requires: powertop
|
||||
|
||||
%description utils
|
||||
This package contains utilities that can help you to fine tune your
|
||||
system and manage tuned profiles.
|
||||
This package contains utilities that can help you to fine tune and
|
||||
debug your system and manage tuned profiles.
|
||||
|
||||
%package utils-systemtap
|
||||
Summary: Disk and net statistic monitoring systemtap scripts
|
||||
@ -53,13 +52,15 @@ It can be also used to fine tune your system for specific scenarios.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot} VERSIONED_NAME=tuned
|
||||
make install DESTDIR=%{buildroot}
|
||||
%if 0%{?rhel}
|
||||
sed -i 's/\(dynamic_tuning[ \t]*=[ \t]*\).*/\10/' %{buildroot}%{_sysconfdir}/tuned/tuned-main.conf
|
||||
%endif
|
||||
|
||||
|
||||
%post
|
||||
@ -111,6 +112,7 @@ sed -i 's|.*/\([^/]\+\)/[^\.]\+\.conf|\1|' /etc/tuned/active_profile
|
||||
%{_prefix}/lib/tuned
|
||||
%dir %{_sysconfdir}/tuned
|
||||
%config(noreplace) %{_sysconfdir}/tuned/active_profile
|
||||
%config(noreplace) %{_sysconfdir}/tuned/tuned-main.conf
|
||||
%{_sysconfdir}/tmpfiles.d
|
||||
%{_sysconfdir}/dbus-1/system.d/com.redhat.tuned.conf
|
||||
%{_unitdir}/tuned.service
|
||||
@ -123,6 +125,7 @@ sed -i 's|.*/\([^/]\+\)/[^\.]\+\.conf|\1|' /etc/tuned/active_profile
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_bindir}/powertop2tuned
|
||||
%{_libexecdir}/tuned/pmqos-static*
|
||||
|
||||
%files utils-systemtap
|
||||
%defattr(-,root,root,-)
|
||||
@ -149,8 +152,37 @@ sed -i 's|.*/\([^/]\+\)/[^\.]\+\.conf|\1|' /etc/tuned/active_profile
|
||||
%{_prefix}/lib/tuned/spindown-disk
|
||||
|
||||
%changelog
|
||||
* Thu Jul 25 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2.2-2
|
||||
- used pygobject3-base instead of pygobject2
|
||||
* Wed Nov 6 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.3.0-1
|
||||
- new-release
|
||||
resolves: rhbz#1020743
|
||||
- audio plugin: fixed audio settings in standard profiles
|
||||
resolves: rhbz#1019805
|
||||
- video plugin: fixed tunings
|
||||
- daemon: fixed crash if preset profile is not available
|
||||
resolves: rhbz#953128
|
||||
- man: various updates and corrections
|
||||
- functions: fixed usb and bluetooth handling
|
||||
- tuned: switched to lightweighted pygobject3-base
|
||||
- daemon: added global config for dynamic_tuning
|
||||
resolves: rhbz#1006427
|
||||
- utils: added pmqos-static script for debug purposes
|
||||
resolves: rhbz#1015676
|
||||
- throughput-performance: various fixes
|
||||
resolves: rhbz#987570
|
||||
- tuned: added global option update_interval
|
||||
- plugin_cpu: added support for x86_energy_perf_policy
|
||||
resolves: rhbz#1015675
|
||||
- dbus: fixed KeyboardInterrupt handling
|
||||
- plugin_cpu: added support for intel_pstate
|
||||
resolves: rhbz#996722
|
||||
- profiles: various fixes
|
||||
resolves: rhbz#922068
|
||||
- profiles: added desktop profile
|
||||
resolves: rhbz#996723
|
||||
- tuned-adm: implemented non DBus fallback control
|
||||
- profiles: added sap profile
|
||||
- tuned: lowered CPU usage due to python bug
|
||||
resolves: rhbz#917587
|
||||
|
||||
* Tue Mar 19 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.2.2-1
|
||||
- new-release:
|
||||
|
Loading…
Reference in New Issue
Block a user